Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Индекс столбца в зависимости от показателя в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс столбца в зависимости от показателя в ячейке (Формулы/Formulas)
Индекс столбца в зависимости от показателя в ячейке
stoniq Дата: Среда, 04.04.2018, 17:28 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день!
Прошу подсказать, что делаю не так? В ячейку A2 необходимо тянуть все значения столбца B, C или D, в зависимости от показателя "E2". Если правильно понимаю, то формула должна быть примерно такая:

Код
=ЕСЛИМН(E2="значение 1";ИНДЕКС(B2:B16);E2="значение 2";ИНДЕКС(C2:C16);E2="значение 3";ИНДЕКС(D2:D16))
 
Ответить
СообщениеДобрый день!
Прошу подсказать, что делаю не так? В ячейку A2 необходимо тянуть все значения столбца B, C или D, в зависимости от показателя "E2". Если правильно понимаю, то формула должна быть примерно такая:

Код
=ЕСЛИМН(E2="значение 1";ИНДЕКС(B2:B16);E2="значение 2";ИНДЕКС(C2:C16);E2="значение 3";ИНДЕКС(D2:D16))

Автор - stoniq
Дата добавления - 04.04.2018 в 17:28
stoniq Дата: Среда, 04.04.2018, 17:31 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Забыл файлик
К сообщению приложен файл: 6526428.xlsx(10.0 Kb)
 
Ответить
СообщениеЗабыл файлик

Автор - stoniq
Дата добавления - 04.04.2018 в 17:31
AlexM Дата: Среда, 04.04.2018, 18:05 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3755
Репутация: 947 ±
Замечаний: 0% ±

Excel 2003
Код
=ИНДЕКС(B2:D2;ПРАВБ(E$2))
К сообщению приложен файл: 6526428_01.xlsx(9.9 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ИНДЕКС(B2:D2;ПРАВБ(E$2))

Автор - AlexM
Дата добавления - 04.04.2018 в 18:05
stoniq Дата: Среда, 04.04.2018, 18:15 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
AlexM, Я понял) хорошо, а если это будет не "Значение 1,2,3", а Skoda Rapid, Reno Logan и Kia Rio?
 
Ответить
СообщениеAlexM, Я понял) хорошо, а если это будет не "Значение 1,2,3", а Skoda Rapid, Reno Logan и Kia Rio?

Автор - stoniq
Дата добавления - 04.04.2018 в 18:15
Karataev Дата: Среда, 04.04.2018, 18:15 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1249
Репутация: 481 ±
Замечаний: 0% ±

Excel
Сделал на основе поста 3. Формула для 'A2":
Код
=ЕСЛИ($E$2="Значение 1";B2;ЕСЛИ($E$2="Значение 2";C2;ЕСЛИ($E$2="Значение 3";D2)))&""
К сообщению приложен файл: 1_kar.xlsb(9.8 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеСделал на основе поста 3. Формула для 'A2":
Код
=ЕСЛИ($E$2="Значение 1";B2;ЕСЛИ($E$2="Значение 2";C2;ЕСЛИ($E$2="Значение 3";D2)))&""

Автор - Karataev
Дата добавления - 04.04.2018 в 18:15
AlexM Дата: Среда, 04.04.2018, 18:16 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3755
Репутация: 947 ±
Замечаний: 0% ±

Excel 2003
Пример приложите



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПример приложите

Автор - AlexM
Дата добавления - 04.04.2018 в 18:16
stoniq Дата: Среда, 04.04.2018, 18:28 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Karataev, огромное спасибо! отличный вариант
 
Ответить
СообщениеKarataev, огромное спасибо! отличный вариант

Автор - stoniq
Дата добавления - 04.04.2018 в 18:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс столбца в зависимости от показателя в ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!