Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование отдельных ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование отдельных ячеек (Формулы/Formulas)
Суммирование отдельных ячеек
s7os7ed Дата: Пятница, 06.04.2018, 11:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте
В ячейках С и D проставляется время. В ячейках В ведется их расчет, т.е. из большего значения вычитается наименьшее по ячейкам С и D.
Возможно ли создать суммирование ячеек по столбцу В???
Где будет считаться по условиям:
1. Общая сумма ячеек B где D>C =
2. Общая сумма ячеек B где C>D =
К сообщению приложен файл: 000.xlsx(10.0 Kb)
 
Ответить
СообщениеЗдравствуйте
В ячейках С и D проставляется время. В ячейках В ведется их расчет, т.е. из большего значения вычитается наименьшее по ячейкам С и D.
Возможно ли создать суммирование ячеек по столбцу В???
Где будет считаться по условиям:
1. Общая сумма ячеек B где D>C =
2. Общая сумма ячеек B где C>D =

Автор - s7os7ed
Дата добавления - 06.04.2018 в 11:47
Manyasha Дата: Пятница, 06.04.2018, 11:51 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 2193
Репутация: 892 ±
Замечаний: 0% ±

Excel 2010, 2016
s7os7ed, здравствуйте, можно и без столбца В, например так:
для 1. Общая сумма ячеек B где D>C =
Код
=СУММПРОИЗВ((D4:D9>C4:C9)*(D4:D9-C4:C9))

для п2 аналогично
К сообщению приложен файл: 000-1.xlsx(10.3 Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеs7os7ed, здравствуйте, можно и без столбца В, например так:
для 1. Общая сумма ячеек B где D>C =
Код
=СУММПРОИЗВ((D4:D9>C4:C9)*(D4:D9-C4:C9))

для п2 аналогично

Автор - Manyasha
Дата добавления - 06.04.2018 в 11:51
китин Дата: Пятница, 06.04.2018, 11:53 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
если правильно понял
Код
=СУММПРОИЗВ($B$4:$B$9*($D$4:$D$9<$C$4:$C$9))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеесли правильно понял
Код
=СУММПРОИЗВ($B$4:$B$9*($D$4:$D$9<$C$4:$C$9))

Автор - китин
Дата добавления - 06.04.2018 в 11:53
s7os7ed Дата: Пятница, 06.04.2018, 12:10 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Спасибо :)
 
Ответить
СообщениеСпасибо :)

Автор - s7os7ed
Дата добавления - 06.04.2018 в 12:10
Karataev Дата: Пятница, 06.04.2018, 13:22 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1256
Репутация: 485 ±
Замечаний: 0% ±

Excel
С применением столбца "B". Используются формулы массива - завершайте ввод формулы не клавишей Enter (как Вы это обычно делаете), а сочетанием клавиш Ctrl+Shift+Enter.
Код
=СУММ(ЕСЛИ(C4:C5000<D4:D5000;B4:B5000))

Код
=СУММ(ЕСЛИ(C4:C5000>D4:D5000;B4:B5000))

Формула просматривает строки с 4 по 5000.
К сообщению приложен файл: 000_kar.xlsx(10.0 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеС применением столбца "B". Используются формулы массива - завершайте ввод формулы не клавишей Enter (как Вы это обычно делаете), а сочетанием клавиш Ctrl+Shift+Enter.
Код
=СУММ(ЕСЛИ(C4:C5000<D4:D5000;B4:B5000))

Код
=СУММ(ЕСЛИ(C4:C5000>D4:D5000;B4:B5000))

Формула просматривает строки с 4 по 5000.

Автор - Karataev
Дата добавления - 06.04.2018 в 13:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование отдельных ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!