Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/В формуле написать ТЕКСТ, который не влиял бы на РЕЗУЛЬТАТ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В формуле написать ТЕКСТ, который не влиял бы на РЕЗУЛЬТАТ (Формулы/Formulas)
В формуле написать ТЕКСТ, который не влиял бы на РЕЗУЛЬТАТ
Никанор Дата: Понедельник, 09.04.2018, 16:14 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемые помощники!

Можно ли в формулу дописать ТЕКСТ (слово) – объяснение, что бы этот ТЕКСТ (слово) не влиял на результат?

Пример:
В ячейке (в строке формул) есть формула.
Если изменяется законодательство, то изменяются некоторые данные в формуле.

Объяснение – что надо изменять, можно написать разными способами:
1 способ: Написать это в примечании к ячейке.
2 способ: данные, которые изменяются записать – занести в отдельную таблицу. И при необходимости вносить эти изменения в таблицу.
А можно ли это сделать в формуле?

Пример:
Есть формула:
Код
=ОКРУГЛ(МАКС(0;18%*(AS14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5;"");881)*(AT14<=2470)*ЕПУСТО(D14)));2)

Где, в формуле:
18% – налог с доходов физических лиц;
1321,5 – Сумма налоговой социальной льготы 150% для лиц определенных в пп. 169.1.3 НКУ
881 – Сумма налоговой социальной льготы 100% для лиц определенных в пп. 169.1.1 и пп. 169.1.2 НКУ;
2470 – Предельный размер дохода, который дает право на получение налоговой социальной льготы в 2018 году

Должно быть приблизительно так:
=ОКРУГЛ(МАКС(0;18% «налог с доходов физических лиц» *(AS14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5 «Сумма налоговой социальной льготы 150% для лиц определенных в пп. 169.1.3 НКУ»;"");881 «Сумма налоговой социальной льготы 100% для лиц определенных в пп. 169.1.1 и пп. 169.1.2 НКУ»)*(AT14<=2470 «Предельный размер дохода, который дает право на получение налоговой социальной льготы в 2018 году»)*ЕПУСТО(D14)));2)

Что надо дописать в формулу я выделил красным шрифтом.
Я специально формулу как должно быть не оформлял тегами, что бы было видно какой ТЕКСТ надо написать в формулу. А если оформить тегами то не будет видно какой ТЕКСТ надо внести в формулу.

Я формулу написал для примера. Но может быть и другая формула.
Вопрос: Можно ли дописать ТЕКСТ (слово) в формулу, что бы ТЕКСТ в формуле не влиял бы на РЕЗУЛЬТАТ?

Думаю, для этого вопроса файл-пример не нужен.


Сообщение отредактировал Никанор - Понедельник, 09.04.2018, 16:20
 
Ответить
СообщениеЗдравствуйте уважаемые помощники!

Можно ли в формулу дописать ТЕКСТ (слово) – объяснение, что бы этот ТЕКСТ (слово) не влиял на результат?

Пример:
В ячейке (в строке формул) есть формула.
Если изменяется законодательство, то изменяются некоторые данные в формуле.

Объяснение – что надо изменять, можно написать разными способами:
1 способ: Написать это в примечании к ячейке.
2 способ: данные, которые изменяются записать – занести в отдельную таблицу. И при необходимости вносить эти изменения в таблицу.
А можно ли это сделать в формуле?

Пример:
Есть формула:
Код
=ОКРУГЛ(МАКС(0;18%*(AS14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5;"");881)*(AT14<=2470)*ЕПУСТО(D14)));2)

Где, в формуле:
18% – налог с доходов физических лиц;
1321,5 – Сумма налоговой социальной льготы 150% для лиц определенных в пп. 169.1.3 НКУ
881 – Сумма налоговой социальной льготы 100% для лиц определенных в пп. 169.1.1 и пп. 169.1.2 НКУ;
2470 – Предельный размер дохода, который дает право на получение налоговой социальной льготы в 2018 году

Должно быть приблизительно так:
=ОКРУГЛ(МАКС(0;18% «налог с доходов физических лиц» *(AS14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5 «Сумма налоговой социальной льготы 150% для лиц определенных в пп. 169.1.3 НКУ»;"");881 «Сумма налоговой социальной льготы 100% для лиц определенных в пп. 169.1.1 и пп. 169.1.2 НКУ»)*(AT14<=2470 «Предельный размер дохода, который дает право на получение налоговой социальной льготы в 2018 году»)*ЕПУСТО(D14)));2)

Что надо дописать в формулу я выделил красным шрифтом.
Я специально формулу как должно быть не оформлял тегами, что бы было видно какой ТЕКСТ надо написать в формулу. А если оформить тегами то не будет видно какой ТЕКСТ надо внести в формулу.

Я формулу написал для примера. Но может быть и другая формула.
Вопрос: Можно ли дописать ТЕКСТ (слово) в формулу, что бы ТЕКСТ в формуле не влиял бы на РЕЗУЛЬТАТ?

Думаю, для этого вопроса файл-пример не нужен.

Автор - Никанор
Дата добавления - 09.04.2018 в 16:14
sboy Дата: Понедельник, 09.04.2018, 16:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Цитата Никанор, 09.04.2018 в 16:14, в сообщении № 1 ()
Думаю, для этого вопроса файл-пример не нужен.

Тогда вставляйте сами) Вам поможет функция Ч()
 
Ответить
СообщениеДобрый день.
Цитата Никанор, 09.04.2018 в 16:14, в сообщении № 1 ()
Думаю, для этого вопроса файл-пример не нужен.

Тогда вставляйте сами) Вам поможет функция Ч()

Автор - sboy
Дата добавления - 09.04.2018 в 16:37
Никанор Дата: Понедельник, 09.04.2018, 17:03 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
sboy, Здравствуйте!
Спасибо за ответ.
Подскажите пожалуйста как это сделать с функцией (Ч) или прикрепить файл?
 
Ответить
Сообщениеsboy, Здравствуйте!
Спасибо за ответ.
Подскажите пожалуйста как это сделать с функцией (Ч) или прикрепить файл?

Автор - Никанор
Дата добавления - 09.04.2018 в 17:03
sboy Дата: Понедельник, 09.04.2018, 17:28 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Код
=ОКРУГЛ(МАКС(0;(18%+Ч(«налог с доходов физических лиц»))*(AS14-ЕСЛИОШИБКА( и т.д.

не забывайте про скобки для каждой +Ч
 
Ответить
Сообщение
Код
=ОКРУГЛ(МАКС(0;(18%+Ч(«налог с доходов физических лиц»))*(AS14-ЕСЛИОШИБКА( и т.д.

не забывайте про скобки для каждой +Ч

Автор - sboy
Дата добавления - 09.04.2018 в 17:28
Никанор Дата: Понедельник, 09.04.2018, 19:13 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
sboy, Не получается.
Я написал формулу
Код
=ОКРУГЛ(МАКС(0;(18%+Ч(налог с доходов физических лиц»))*(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5+Ч(Сумма налоговой социальной льготы 150% для лиц определенных в пп. 169.1.3 НКУ);"");881+Ч(Сумма налоговой социальной льготы 100% для лиц определенных в пп. 169.1.1 и пп. 169.1.2 НКУ)*(AT14<=2470+Ч(Предельный размер дохода, который дает право на получение налоговой социальной льготы в 2018 году)*ЕПУСТО(D14)));2)

Пишет ошибка в формуле. И буквы в формуле в файле не окрашиваются цветным шрифтом. Здесь в формуле окрашиваются, а в строке формул не окрашиваются.

Подскажите пожалуйста что не правильно сделал.


Сообщение отредактировал Никанор - Понедельник, 09.04.2018, 19:15
 
Ответить
Сообщениеsboy, Не получается.
Я написал формулу
Код
=ОКРУГЛ(МАКС(0;(18%+Ч(налог с доходов физических лиц»))*(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5+Ч(Сумма налоговой социальной льготы 150% для лиц определенных в пп. 169.1.3 НКУ);"");881+Ч(Сумма налоговой социальной льготы 100% для лиц определенных в пп. 169.1.1 и пп. 169.1.2 НКУ)*(AT14<=2470+Ч(Предельный размер дохода, который дает право на получение налоговой социальной льготы в 2018 году)*ЕПУСТО(D14)));2)

Пишет ошибка в формуле. И буквы в формуле в файле не окрашиваются цветным шрифтом. Здесь в формуле окрашиваются, а в строке формул не окрашиваются.

Подскажите пожалуйста что не правильно сделал.

Автор - Никанор
Дата добавления - 09.04.2018 в 19:13
Pelena Дата: Понедельник, 09.04.2018, 20:24 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13299
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Каждая фраза должна быть в кавычках
Здесь можно почитать


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКаждая фраза должна быть в кавычках
Здесь можно почитать

Автор - Pelena
Дата добавления - 09.04.2018 в 20:24
Никанор Дата: Понедельник, 09.04.2018, 22:17 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Pelena, Спасибо большое.
Я прочитал. И на основании написал формулу
Код
=ОКРУГЛ(МАКС(0;18%+Ч("налог с доходов физических лиц")*(AS14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%")*(AT14<=2470+Ч("Предельный размер дохода")*ЕПУСТО(D14)));2)

Но снова пишет Ошибка в формуле.
Но буквы уже окрашиваются разным цветом шрифта.
Может кто подскажет как данную формулу написать правильно с Добавление описания формулы в саму формулу.


Сообщение отредактировал Никанор - Вторник, 10.04.2018, 00:25
 
Ответить
СообщениеPelena, Спасибо большое.
Я прочитал. И на основании написал формулу
Код
=ОКРУГЛ(МАКС(0;18%+Ч("налог с доходов физических лиц")*(AS14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%")*(AT14<=2470+Ч("Предельный размер дохода")*ЕПУСТО(D14)));2)

Но снова пишет Ошибка в формуле.
Но буквы уже окрашиваются разным цветом шрифта.
Может кто подскажет как данную формулу написать правильно с Добавление описания формулы в саму формулу.

Автор - Никанор
Дата добавления - 09.04.2018 в 22:17
Pelena Дата: Вторник, 10.04.2018, 08:31 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13299
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Это должно быть в скобках
Код
18%+Ч("налог с доходов физических лиц")

и это тоже
Код
881+Ч("Сумма налоговой социальной льготы 100%")

Код
2470+Ч("Предельный размер дохода")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЭто должно быть в скобках
Код
18%+Ч("налог с доходов физических лиц")

и это тоже
Код
881+Ч("Сумма налоговой социальной льготы 100%")

Код
2470+Ч("Предельный размер дохода")

Автор - Pelena
Дата добавления - 10.04.2018 в 08:31
sboy Дата: Вторник, 10.04.2018, 10:35 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
А я Вам писал в посте №2
Цитата Никанор, 09.04.2018 в 16:14, в сообщении № 1 ()
Думаю, для этого вопроса файл-пример не нужен.

Тогда вставляйте сами)
 
Ответить
СообщениеА я Вам писал в посте №2
Цитата Никанор, 09.04.2018 в 16:14, в сообщении № 1 ()
Думаю, для этого вопроса файл-пример не нужен.

Тогда вставляйте сами)

Автор - sboy
Дата добавления - 10.04.2018 в 10:35
Никанор Дата: Вторник, 10.04.2018, 12:21 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте sboy и Pelena!
Спасибо за помощь.
Да конечно удобнее написать формулу, если есть файл – пример.
Тогда вставляйте сами)


Не получается – Вы правы пример файл должен быть обязательно.

Поэтому прикрепляю файл.
Формула, которую надо изменить находится в прикреплённом файле в ячейке AQ14. В этом столбце AQ в диапазоне AQ14:AQ29 и ниже такие же формулы с результатом, который должен быть.
В примере в столбце AQ виден результат как должно быть.
К сообщению приложен файл: ___-_____.xlsx(37.5 Kb)


Сообщение отредактировал Никанор - Вторник, 10.04.2018, 12:27
 
Ответить
СообщениеЗдравствуйте sboy и Pelena!
Спасибо за помощь.
Да конечно удобнее написать формулу, если есть файл – пример.
Тогда вставляйте сами)


Не получается – Вы правы пример файл должен быть обязательно.

Поэтому прикрепляю файл.
Формула, которую надо изменить находится в прикреплённом файле в ячейке AQ14. В этом столбце AQ в диапазоне AQ14:AQ29 и ниже такие же формулы с результатом, который должен быть.
В примере в столбце AQ виден результат как должно быть.

Автор - Никанор
Дата добавления - 10.04.2018 в 12:21
Никанор Дата: Вторник, 10.04.2018, 12:44 | Сообщение № 11
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
2 вопрос по этой же теме.
Как изменить формулу в диапазоне ячеек AP14:AP47 что бы в строке формул было объяснение.
Вот формула, которую надо изменить она находится в прикреплённом файле в ячейке: AP14
=ОКРУГЛ(ЕСЛИ(И(AO19>=3723;G19<=$G$99);ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Інвалид";B19;1)>0;AO19*0.0841;"");AO19*0.22);ЕСЛИ(И(AO19<3723;G19=$G$99);ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Інвалид";B19;1)>0;AO19*0.0841;"");819.06);ЕСЛИ(И(G19<$G$99;AO19<3723);ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Інвалид";B19;1)>0;AO19*0.0841;"");AO19*0.22))));2)

Объяснение формулы Нарахування ФОП Єдиний соціальний внесок: Красным шрифтом выделены числа, которые надо изменять

Объяснение формулы Нарахування ФОП Єдиний соціальний внесок: где
3 723.00 Минимальная зарплата
0.0841 Єдиний соціальний внесок з Інвалідів
0.22 Єдиний соціальний внесок з звичайних працівників
819.06 Равно Минимальная зарплата 3723 умножить на 22 %

Я специально не оформил формулу тегами – что бы визуально было видно что надо изменить с объяснением.


Сообщение отредактировал Никанор - Вторник, 10.04.2018, 12:58
 
Ответить
Сообщение2 вопрос по этой же теме.
Как изменить формулу в диапазоне ячеек AP14:AP47 что бы в строке формул было объяснение.
Вот формула, которую надо изменить она находится в прикреплённом файле в ячейке: AP14
=ОКРУГЛ(ЕСЛИ(И(AO19>=3723;G19<=$G$99);ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Інвалид";B19;1)>0;AO19*0.0841;"");AO19*0.22);ЕСЛИ(И(AO19<3723;G19=$G$99);ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Інвалид";B19;1)>0;AO19*0.0841;"");819.06);ЕСЛИ(И(G19<$G$99;AO19<3723);ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Інвалид";B19;1)>0;AO19*0.0841;"");AO19*0.22))));2)

Объяснение формулы Нарахування ФОП Єдиний соціальний внесок: Красным шрифтом выделены числа, которые надо изменять

Объяснение формулы Нарахування ФОП Єдиний соціальний внесок: где
3 723.00 Минимальная зарплата
0.0841 Єдиний соціальний внесок з Інвалідів
0.22 Єдиний соціальний внесок з звичайних працівників
819.06 Равно Минимальная зарплата 3723 умножить на 22 %

Я специально не оформил формулу тегами – что бы визуально было видно что надо изменить с объяснением.

Автор - Никанор
Дата добавления - 10.04.2018 в 12:44
Никанор Дата: Вторник, 10.04.2018, 13:09 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
У меня частично получилось,только не получилось написать объяснение % (процентам).
Вот что у меня получилось:
Код
=ОКРУГЛ(МАКС(0;18%*(AO14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321.5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%"))*(AO14<=2470+Ч("Предельный размер дохода"))*ЕПУСТО(D14)));2)



Единственно не получилось объяснить проценты. Если дописать следующим образом:

Код
=ОКРУГЛ(МАКС(0;18%+Ч("налог доходов физических лиц")*(AO14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321.5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%"))*(AO14<=2470+Ч("Предельный размер дохода"))*ЕПУСТО(D14)));2)

То РЕЗУЛЬТАТ: 0,18
А если написать не 0,18 а 0,22 то и результат 0,22
Что то надо изменить в процентах


Помогите пожалуйста.
А как написать полностью формулу с объяснением что было объяснением процентам %.


Сообщение отредактировал Никанор - Вторник, 10.04.2018, 13:21
 
Ответить
СообщениеУ меня частично получилось,только не получилось написать объяснение % (процентам).
Вот что у меня получилось:
Код
=ОКРУГЛ(МАКС(0;18%*(AO14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321.5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%"))*(AO14<=2470+Ч("Предельный размер дохода"))*ЕПУСТО(D14)));2)



Единственно не получилось объяснить проценты. Если дописать следующим образом:

Код
=ОКРУГЛ(МАКС(0;18%+Ч("налог доходов физических лиц")*(AO14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321.5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%"))*(AO14<=2470+Ч("Предельный размер дохода"))*ЕПУСТО(D14)));2)

То РЕЗУЛЬТАТ: 0,18
А если написать не 0,18 а 0,22 то и результат 0,22
Что то надо изменить в процентах


Помогите пожалуйста.
А как написать полностью формулу с объяснением что было объяснением процентам %.

Автор - Никанор
Дата добавления - 10.04.2018 в 13:09
sboy Дата: Вторник, 10.04.2018, 13:21 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Держите
К сообщению приложен файл: 9854191.xlsx(38.8 Kb)
 
Ответить
СообщениеДержите

Автор - sboy
Дата добавления - 10.04.2018 в 13:21
DV Дата: Вторник, 10.04.2018, 13:22 | Сообщение № 14
Группа: Друзья
Ранг: Обитатель
Сообщений: 286
Репутация: 194 ±
Замечаний: 0% ±

Excel 2010 RUS
Код
=ОКРУГЛ(МАКС(0;(18%+Ч("налог с доходов физических лиц"))*(AO14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%"))*(AO14<=2470+Ч("Предельный размер дохода"))*ЕПУСТО(D14)));2)
 
Ответить
Сообщение
Код
=ОКРУГЛ(МАКС(0;(18%+Ч("налог с доходов физических лиц"))*(AO14-ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ("Пільга 150%";B14;1)>0;1321,5+Ч("Сумма налоговой социальной льготы 150%");"");881+Ч("Сумма налоговой социальной льготы 100%"))*(AO14<=2470+Ч("Предельный размер дохода"))*ЕПУСТО(D14)));2)

Автор - DV
Дата добавления - 10.04.2018 в 13:22
Никанор Дата: Понедельник, 16.04.2018, 15:15 | Сообщение № 15
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемые sboy – Сергей, Pelena – Елена и DV – Дмитрий!
Во первых извините пожалуйста что с большим опозданием отвечаю Вам и благодарю за помощь.
Всегда стараюсь сразу отвечать, а в этот раз был очень занят.
Большое спасибо всем вам, что помогли мне.

Сергей большое Вам спасибо, что ответили на 23 минуте и за то, что сказали, что при наличии файла – примера лучше решать мой вопрос; и за то, что прислали правильный файл – пример с формулами для двух столбцов.

Елене большое спасибо что подсказали и дали ссылку на статью на Вашем сайте «Добавление описания формулы в саму формулу» http://www.excelworld.ru/board....3-1-0-6
и советы что написали, что должно быть в скобках.
Не согласен, что в некоторых комментариях к этой статье скептичиски написано об этой возможности написано: «ха-ха неужели это кому-то пригодится.» и «Для пояснения, описания и т.п. давным-давно придуманы ПРИМЕЧАНИЯ. Зачем загромождать рабочие формулы балластом?»
А я когда то ошибся при начислении заработной платы, так как у меня была длинная формула, и не внёс изменения в связи с изменением законодательства – немного больше было удержано с зарплаты сотрудника. Тогда пришлось на следующий месяц корректировать – подправлять.
Вывод: функция Ч() может быть очень полезной.

Дмитрию большое спасибо за формулу. У меня эта формула сразу «не работала», а когда я написал вместо запятой точку. Так было – 1321,5, а так написал 1321.5 формула «заработала».

Ещё раз всем большое спасибо за помощь.
Я когда задавал вопрос, то думал что в Excel (экселе) невозможно это сделать. И очень удивился, что это возможно.


Позвольте задать по этой теме попутно 2 вопроса:
1 вопрос: Можно ли в строке формул, самостоятельно окрасить каким либо цветом текст или числа? Я прикрепил рисунок с примером.
2 вопрос: всегда ли при правильном написании – добавлении в формулу функции Ч() будет правильный результат?


Ещё раз извините что благодарю за помощь не с опозданием.
К сообщению приложен файл: 5570808.gif(28.4 Kb)


Сообщение отредактировал Никанор - Понедельник, 16.04.2018, 15:19
 
Ответить
СообщениеЗдравствуйте уважаемые sboy – Сергей, Pelena – Елена и DV – Дмитрий!
Во первых извините пожалуйста что с большим опозданием отвечаю Вам и благодарю за помощь.
Всегда стараюсь сразу отвечать, а в этот раз был очень занят.
Большое спасибо всем вам, что помогли мне.

Сергей большое Вам спасибо, что ответили на 23 минуте и за то, что сказали, что при наличии файла – примера лучше решать мой вопрос; и за то, что прислали правильный файл – пример с формулами для двух столбцов.

Елене большое спасибо что подсказали и дали ссылку на статью на Вашем сайте «Добавление описания формулы в саму формулу» http://www.excelworld.ru/board....3-1-0-6
и советы что написали, что должно быть в скобках.
Не согласен, что в некоторых комментариях к этой статье скептичиски написано об этой возможности написано: «ха-ха неужели это кому-то пригодится.» и «Для пояснения, описания и т.п. давным-давно придуманы ПРИМЕЧАНИЯ. Зачем загромождать рабочие формулы балластом?»
А я когда то ошибся при начислении заработной платы, так как у меня была длинная формула, и не внёс изменения в связи с изменением законодательства – немного больше было удержано с зарплаты сотрудника. Тогда пришлось на следующий месяц корректировать – подправлять.
Вывод: функция Ч() может быть очень полезной.

Дмитрию большое спасибо за формулу. У меня эта формула сразу «не работала», а когда я написал вместо запятой точку. Так было – 1321,5, а так написал 1321.5 формула «заработала».

Ещё раз всем большое спасибо за помощь.
Я когда задавал вопрос, то думал что в Excel (экселе) невозможно это сделать. И очень удивился, что это возможно.


Позвольте задать по этой теме попутно 2 вопроса:
1 вопрос: Можно ли в строке формул, самостоятельно окрасить каким либо цветом текст или числа? Я прикрепил рисунок с примером.
2 вопрос: всегда ли при правильном написании – добавлении в формулу функции Ч() будет правильный результат?


Ещё раз извините что благодарю за помощь не с опозданием.

Автор - Никанор
Дата добавления - 16.04.2018 в 15:15
sboy Дата: Понедельник, 16.04.2018, 15:33 | Сообщение № 16
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Цитата Никанор, 16.04.2018 в 15:15, в сообщении № 15 ()
У меня эта формула сразу «не работала»

можно было просто скачать файл из сообщения 13
Цитата Никанор, 16.04.2018 в 15:15, в сообщении № 15 ()
1 вопрос: Можно ли в строке формул, самостоятельно окрасить каким либо цветом текст или числа?

нет
Цитата Никанор, 16.04.2018 в 15:15, в сообщении № 15 ()
всегда ли при правильном написании

да
 
Ответить
Сообщение
Цитата Никанор, 16.04.2018 в 15:15, в сообщении № 15 ()
У меня эта формула сразу «не работала»

можно было просто скачать файл из сообщения 13
Цитата Никанор, 16.04.2018 в 15:15, в сообщении № 15 ()
1 вопрос: Можно ли в строке формул, самостоятельно окрасить каким либо цветом текст или числа?

нет
Цитата Никанор, 16.04.2018 в 15:15, в сообщении № 15 ()
всегда ли при правильном написании

да

Автор - sboy
Дата добавления - 16.04.2018 в 15:33
Никанор Дата: Понедельник, 16.04.2018, 15:42 | Сообщение № 17
Группа: Проверенные
Ранг: Обитатель
Сообщений: 369
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
sboy, спасибо за исчерпывающие ответы!
можно было просто скачать файл из сообщения 13

я просто хотел проверить правильно ли формула работает. Думал что там другой вариант формулы – хотел сравнить.
Я Вам повысил репутацию там не весь текст поместился – весь текст в сообщении № 15.
 
Ответить
Сообщениеsboy, спасибо за исчерпывающие ответы!
можно было просто скачать файл из сообщения 13

я просто хотел проверить правильно ли формула работает. Думал что там другой вариант формулы – хотел сравнить.
Я Вам повысил репутацию там не весь текст поместился – весь текст в сообщении № 15.

Автор - Никанор
Дата добавления - 16.04.2018 в 15:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В формуле написать ТЕКСТ, который не влиял бы на РЕЗУЛЬТАТ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!