Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет ЗП для отпускных. Сумма последних 12 не пустых ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет ЗП для отпускных. Сумма последних 12 не пустых ячеек (Формулы/Formulas)
Расчет ЗП для отпускных. Сумма последних 12 не пустых ячеек
AVI Дата: Понедельник, 09.04.2018, 16:37 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 303
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Помогите с формулой расчета зарплаты для отпуска. В желтом столбце сумма оплаты из последних 12-ти не пустых ячеек, у меня набито топором... Начало отпуска в столбце Z. В ячейках могут быть либо цифры, либо ничего.
К сообщению приложен файл: 3954052.xlsx(11.0 Kb)
 
Ответить
СообщениеДобрый день!
Помогите с формулой расчета зарплаты для отпуска. В желтом столбце сумма оплаты из последних 12-ти не пустых ячеек, у меня набито топором... Начало отпуска в столбце Z. В ячейках могут быть либо цифры, либо ничего.

Автор - AVI
Дата добавления - 09.04.2018 в 16:37
sboy Дата: Понедельник, 09.04.2018, 17:23 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1944
Репутация: 564 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=СУММ(B3:ИНДЕКС(B3:Y3;ПОИСКПОЗ(Z3;$B$1:$Y$1;)-1))-СУММ(A3:ИНДЕКС(A3:Y3;МАКС(1;СЧЁТ(A3:ИНДЕКС(B3:Y3;ПОИСКПОЗ(Z3;$B$1:$Y$1;)-1))-11)))
К сообщению приложен файл: 0812370.xlsx(11.5 Kb)
 
Ответить
СообщениеДобрый день.
Код
=СУММ(B3:ИНДЕКС(B3:Y3;ПОИСКПОЗ(Z3;$B$1:$Y$1;)-1))-СУММ(A3:ИНДЕКС(A3:Y3;МАКС(1;СЧЁТ(A3:ИНДЕКС(B3:Y3;ПОИСКПОЗ(Z3;$B$1:$Y$1;)-1))-11)))

Автор - sboy
Дата добавления - 09.04.2018 в 17:23
AVI Дата: Понедельник, 09.04.2018, 17:44 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 303
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
sboy, боже... спасибо. Полдня просидел с ней.
 
Ответить
Сообщениеsboy, боже... спасибо. Полдня просидел с ней.

Автор - AVI
Дата добавления - 09.04.2018 в 17:44
Светлый Дата: Понедельник, 09.04.2018, 20:33 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 523
Репутация: 125 ±
Замечаний: 0% ±

Excel 2007
Массивная:
Код
=СУММ((СЧЁТЕСЛИ(СМЕЩ(Y3;;;;-СТРОКА($12:$24));"<>")=12)*СУММЕСЛИ(СМЕЩ(Y3;;;;-СТРОКА($12:$24));"<>"))

Не учёл дату начала...


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 09.04.2018, 20:38
 
Ответить
СообщениеМассивная:
Код
=СУММ((СЧЁТЕСЛИ(СМЕЩ(Y3;;;;-СТРОКА($12:$24));"<>")=12)*СУММЕСЛИ(СМЕЩ(Y3;;;;-СТРОКА($12:$24));"<>"))

Не учёл дату начала...

Автор - Светлый
Дата добавления - 09.04.2018 в 20:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет ЗП для отпускных. Сумма последних 12 не пустых ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!