Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заменить функцию ЕСЛИ-количество аргументов увеличивается - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заменить функцию ЕСЛИ-количество аргументов увеличивается (Формулы/Formulas)
Заменить функцию ЕСЛИ-количество аргументов увеличивается
blayd2007 Дата: Вторник, 10.04.2018, 04:58 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 80
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем добрый день!
Задача стоит в том, чем заменить функцию ЕСЛИ, так как количество аргументов увеличивается.
EXCEL 2003.
Файл примера приложил.

Спасибо!
К сообщению приложен файл: 7716972.xls(75.5 Kb)
 
Ответить
СообщениеВсем добрый день!
Задача стоит в том, чем заменить функцию ЕСЛИ, так как количество аргументов увеличивается.
EXCEL 2003.
Файл примера приложил.

Спасибо!

Автор - blayd2007
Дата добавления - 10.04.2018 в 04:58
Светлый Дата: Вторник, 10.04.2018, 06:35 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 407
Репутация: 92 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Может быть, это устроит?
Код
=ПОИСКПОЗ(F3;Сотрудники!A1:A20;)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Может быть, это устроит?
Код
=ПОИСКПОЗ(F3;Сотрудники!A1:A20;)

Автор - Светлый
Дата добавления - 10.04.2018 в 06:35
blayd2007 Дата: Вторник, 10.04.2018, 11:09 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 80
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо, но "ПОИСКПОЗ" ищет по номеру строчки, а у меня конкретно, если Иванов, то=2, не из за номера строки, просто Иванову присвоен номер 2, но может быть и 37.
Это в примере так совпало.

Изменил немного пример, чтоб не вводить в заблуждение.
К сообщению приложен файл: 0705123.xls(66.5 Kb)


Сообщение отредактировал blayd2007 - Вторник, 10.04.2018, 11:14
 
Ответить
СообщениеСпасибо, но "ПОИСКПОЗ" ищет по номеру строчки, а у меня конкретно, если Иванов, то=2, не из за номера строки, просто Иванову присвоен номер 2, но может быть и 37.
Это в примере так совпало.

Изменил немного пример, чтоб не вводить в заблуждение.

Автор - blayd2007
Дата добавления - 10.04.2018 в 11:09
Pelena Дата: Вторник, 10.04.2018, 11:15 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12598
Репутация: 2771 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Делайте таблицу соответствий и используйте функцию ВПР()


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДелайте таблицу соответствий и используйте функцию ВПР()

Автор - Pelena
Дата добавления - 10.04.2018 в 11:15
blayd2007 Дата: Вторник, 10.04.2018, 11:24 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 80
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Но мне кажется, что это не возможно, и я решил добавить еще один столбец в "Сотрудниках" и вставил формулу
Код
=СУММЕСЛИ(Сотрудники!A1:A12;F3;Сотрудники!B1:B12)


Подскажите, а есть ли еще похожие формулы для данного варианта или выбранная мной- это оптимальный вариант?

А если есть решения для первого варианта, буду рад их узнать, не всегда есть возможность вставить столбец.

Спасибо.
К сообщению приложен файл: 6687599.xls(67.0 Kb)
 
Ответить
СообщениеНо мне кажется, что это не возможно, и я решил добавить еще один столбец в "Сотрудниках" и вставил формулу
Код
=СУММЕСЛИ(Сотрудники!A1:A12;F3;Сотрудники!B1:B12)


Подскажите, а есть ли еще похожие формулы для данного варианта или выбранная мной- это оптимальный вариант?

А если есть решения для первого варианта, буду рад их узнать, не всегда есть возможность вставить столбец.

Спасибо.

Автор - blayd2007
Дата добавления - 10.04.2018 в 11:24
blayd2007 Дата: Вторник, 10.04.2018, 11:34 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 80
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Вот так еще получилось, спасибо Pelena!

Код
=ВПР(F3;Сотрудники!A1:B12;2;ЛОЖЬ)


А что рациональней в данном случае?
 
Ответить
СообщениеВот так еще получилось, спасибо Pelena!

Код
=ВПР(F3;Сотрудники!A1:B12;2;ЛОЖЬ)


А что рациональней в данном случае?

Автор - blayd2007
Дата добавления - 10.04.2018 в 11:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заменить функцию ЕСЛИ-количество аргументов увеличивается (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!