Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставление значения по дате - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление значения по дате (Формулы/Formulas)
Сопоставление значения по дате
baneska Дата: Понедельник, 16.04.2018, 15:03 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток.

Существует такая задача которую не могу до конча продумать: есть данные по погибшим. В настоящих данных умирают не каждый день. От сюда и существует столбец "A" - дата, когда кто-то погиб (период с 2010 по 2014 гг.) , столбец "B" - количество погибших в эти дни. А также есть столбец "E" - расписан дни по всем месяцам и годам за нужный период. И, собственно, сама задача: нужно погибших сопоставить по дате смерти в столбце "E".

Т.е. можно было бы написать формулу с помощью функции ЕСЛИ. И сравнить A$2 с E$2:E$1827, затем A$3 с E$2:E$1827, затем A$4 с E$2:E$1827 ...... и наконец A$73 с Е$2:Е$1827. Но, к сожалению, не смогла додуматься как это провернуть. Надеюсь понятно изъяснилась.

Заранее спасибо за помощь и потраченное время.
К сообщению приложен файл: 8407865.xlsx(33.9 Kb)


Новичок
 
Ответить
СообщениеДоброго времени суток.

Существует такая задача которую не могу до конча продумать: есть данные по погибшим. В настоящих данных умирают не каждый день. От сюда и существует столбец "A" - дата, когда кто-то погиб (период с 2010 по 2014 гг.) , столбец "B" - количество погибших в эти дни. А также есть столбец "E" - расписан дни по всем месяцам и годам за нужный период. И, собственно, сама задача: нужно погибших сопоставить по дате смерти в столбце "E".

Т.е. можно было бы написать формулу с помощью функции ЕСЛИ. И сравнить A$2 с E$2:E$1827, затем A$3 с E$2:E$1827, затем A$4 с E$2:E$1827 ...... и наконец A$73 с Е$2:Е$1827. Но, к сожалению, не смогла додуматься как это провернуть. Надеюсь понятно изъяснилась.

Заранее спасибо за помощь и потраченное время.

Автор - baneska
Дата добавления - 16.04.2018 в 15:03
sboy Дата: Понедельник, 16.04.2018, 15:11 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2105
Репутация: 604 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял.
2 варианта
Код
=СУММЕСЛИ($A$2:$A$73;F2;$B$2:$B$73)
Код
=ЕСЛИОШИБКА(ВПР(F2;$A$2:$B$73;2;);)

[p.s.]"Даты" переделал в даты
К сообщению приложен файл: 9851348.xlsx(54.5 Kb)
 
Ответить
СообщениеДобрый день.
Если правильно понял.
2 варианта
Код
=СУММЕСЛИ($A$2:$A$73;F2;$B$2:$B$73)
Код
=ЕСЛИОШИБКА(ВПР(F2;$A$2:$B$73;2;);)

[p.s.]"Даты" переделал в даты

Автор - sboy
Дата добавления - 16.04.2018 в 15:11
baneska Дата: Вторник, 17.04.2018, 18:12 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял.
2 варианта

=СУММЕСЛИ($A$2:$A$73;F2;$B$2:$B$73)

=ЕСЛИОШИБКА(ВПР(F2;$A$2:$B$73;2;);)


Вы совершенно правильно поняли. Спасибо Вам большое за помощь!


Новичок
 
Ответить
Сообщение
Добрый день.
Если правильно понял.
2 варианта

=СУММЕСЛИ($A$2:$A$73;F2;$B$2:$B$73)

=ЕСЛИОШИБКА(ВПР(F2;$A$2:$B$73;2;);)


Вы совершенно правильно поняли. Спасибо Вам большое за помощь!

Автор - baneska
Дата добавления - 17.04.2018 в 18:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление значения по дате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!