Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск констант внутри текста для сложения из другого столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск констант внутри текста для сложения из другого столбца (Формулы/Formulas)
Поиск констант внутри текста для сложения из другого столбца
privet2000 Дата: Вторник, 17.04.2018, 09:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Поиск констант внутри текста + сложение значений из другого столбца по найденным строкам

Нужно находить константы в столбце и складывать из найденных строк нужные значения из другого столбца от всех найденных констант. Константы находятся в ячейках с текстом.
Пока сделал формулу
Код
=СУММ(ИНДЕКС(C2:C12;ПОИСКПОЗ(12345232;A2:A12));ИНДЕКС(C2:C12;ПОИСКПОЗ(432243232;A2:A12));)

которая ищет константы, но работает только если константы без текста. Внизу под формулой такая же формула, видно #Н/Д так как пока формула не видит константы внутри текста. И почему то нужные значения складываются два раза. Возможно, если добавлять третью константу, то будет уже 3 раза складывать.
Помогите доработать эту формулу или может есть другой способ. Тк в экселе не силен, вместо идей прошу что-то более конкретное с примером. Файл эксель с примером прикладываю.
К сообщению приложен файл: 1075873.xlsx(10.7 Kb) · 8554203.jpg(57.3 Kb)


Сообщение отредактировал privet2000 - Вторник, 17.04.2018, 15:38
 
Ответить
СообщениеПоиск констант внутри текста + сложение значений из другого столбца по найденным строкам

Нужно находить константы в столбце и складывать из найденных строк нужные значения из другого столбца от всех найденных констант. Константы находятся в ячейках с текстом.
Пока сделал формулу
Код
=СУММ(ИНДЕКС(C2:C12;ПОИСКПОЗ(12345232;A2:A12));ИНДЕКС(C2:C12;ПОИСКПОЗ(432243232;A2:A12));)

которая ищет константы, но работает только если константы без текста. Внизу под формулой такая же формула, видно #Н/Д так как пока формула не видит константы внутри текста. И почему то нужные значения складываются два раза. Возможно, если добавлять третью константу, то будет уже 3 раза складывать.
Помогите доработать эту формулу или может есть другой способ. Тк в экселе не силен, вместо идей прошу что-то более конкретное с примером. Файл эксель с примером прикладываю.

Автор - privet2000
Дата добавления - 17.04.2018 в 09:23
pabchek Дата: Вторник, 17.04.2018, 15:56 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 839
Репутация: 188 ±
Замечаний: 0% ±

Excel 2007
И Вам, здравствуйте!
Навскидку
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G16;A2:A12)))*(C2:C12))
К сообщению приложен файл: 6717193.xlsx(10.5 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 17.04.2018, 15:59
 
Ответить
СообщениеИ Вам, здравствуйте!
Навскидку
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G16;A2:A12)))*(C2:C12))

Автор - pabchek
Дата добавления - 17.04.2018 в 15:56
privet2000 Дата: Среда, 18.04.2018, 12:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G17;A2:A17)))*(C2:C17))

К сожалению не работает формула если добавлять еще константы -в моем случае еще одна константа в ячейке G18
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G17:G18;A2:A17)))*(C2:C17))


или может нужно константы по другому добавлять?
Или вообще найдется способ для поиска констант сразу первом столбце внутри текстовых ячеек
К сообщению приложен файл: 4095259.xlsx(11.7 Kb)


Сообщение отредактировал privet2000 - Среда, 18.04.2018, 13:24
 
Ответить
Сообщение
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G17;A2:A17)))*(C2:C17))

К сожалению не работает формула если добавлять еще константы -в моем случае еще одна константа в ячейке G18
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G17:G18;A2:A17)))*(C2:C17))


или может нужно константы по другому добавлять?
Или вообще найдется способ для поиска констант сразу первом столбце внутри текстовых ячеек

Автор - privet2000
Дата добавления - 18.04.2018 в 12:32
privet2000 Дата: Среда, 18.04.2018, 13:37 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Хотя если просто прибавить через СУММ - то эта формула работает)
Код
=СУММ(СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G18;A2:A18)))*(C2:C18));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G19;A2:A18)))*(C2:C18)))
 
Ответить
СообщениеХотя если просто прибавить через СУММ - то эта формула работает)
Код
=СУММ(СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G18;A2:A18)))*(C2:C18));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(G19;A2:A18)))*(C2:C18)))

Автор - privet2000
Дата добавления - 18.04.2018 в 13:37
pabchek Дата: Среда, 18.04.2018, 13:55 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 839
Репутация: 188 ±
Замечаний: 0% ±

Excel 2007
не работает формула если добавлять еще константы

Вы уж условия обозначте все какие есть. В этом случае формула массива (вводится одновременным нажатием Кнтрл+Шфт+Ентер)
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ТРАНСП(G17:G18);A2:A17)))*(C2:C17))
К сообщению приложен файл: 2251287.xlsx(11.3 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 18.04.2018, 13:55
 
Ответить
Сообщение
не работает формула если добавлять еще константы

Вы уж условия обозначте все какие есть. В этом случае формула массива (вводится одновременным нажатием Кнтрл+Шфт+Ентер)
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ТРАНСП(G17:G18);A2:A17)))*(C2:C17))

Автор - pabchek
Дата добавления - 18.04.2018 в 13:55
privet2000 Дата: Среда, 18.04.2018, 14:41 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ага, но так то я три раза написал, что нужно складывать, и в самой теме. Не знаю как складывать используя диапазон через ctrl + shift + enter
А так получаются Формулы очень длинные при сложении нескольких констант
Код
=СУММ(СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A56;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A57;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A58;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A59;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A60;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A61;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50)))


Сообщение отредактировал privet2000 - Среда, 18.04.2018, 14:42
 
Ответить
СообщениеАга, но так то я три раза написал, что нужно складывать, и в самой теме. Не знаю как складывать используя диапазон через ctrl + shift + enter
А так получаются Формулы очень длинные при сложении нескольких констант
Код
=СУММ(СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A56;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A57;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A58;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A59;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A60;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50));СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ЛИСТ22!A61;ЛИСТ22!A7:A50)))*(ЛИСТ22!E7:E50)))

Автор - privet2000
Дата добавления - 18.04.2018 в 14:41
privet2000 Дата: Среда, 18.04.2018, 16:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
pabchek
Красавчик. Благодарю! Теперь работает
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ТРАНСП(лист222!A56:A61);лист222!A7:A50)))*(лист222!E7:E50))


Сообщение отредактировал privet2000 - Среда, 18.04.2018, 16:52
 
Ответить
Сообщениеpabchek
Красавчик. Благодарю! Теперь работает
Код
=СУММПРОИЗВ(НЕ(ЕОШИБКА(ПОИСК(ТРАНСП(лист222!A56:A61);лист222!A7:A50)))*(лист222!E7:E50))

Автор - privet2000
Дата добавления - 18.04.2018 в 16:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск констант внутри текста для сложения из другого столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!