Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ЕСЛИ с 4 условиями ЕСЛИ Больше, Меньше или ПУСТАЯ ячейка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ЕСЛИ с 4 условиями ЕСЛИ Больше, Меньше или ПУСТАЯ ячейка (Формулы/Formulas)
ЕСЛИ с 4 условиями ЕСЛИ Больше, Меньше или ПУСТАЯ ячейка
Никанор Дата: Пятница, 27.04.2018, 16:57 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 285
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемые помогающие!

Полное название темы, которое не поместилось вот полное название темы:
ЕСЛИ с 4 условиями. ЕСЛИ больше и ЕСЛИ меньше – то разный результат.
ЕСЛЕ пустая ячейка столбца А– результат – пустая ячейка


Помогите, пожалуйста, написать формулу в прикреплённый файл в столбец С в диапазон ячеек C11:C32 с условиями.
Для ячейки С11 Условия
1 Условие: ЕСЛИ не заполнена ячейка А11 – ячейка С11 пустая;
2 Условие: ЕСЛИ заполнена ячейки А11 и Е11 только тогда заполняется ячейка С11;
3 Условие: ЕСЛИ в ячейке С11 число меньше и равно 18 – то результат в С11 – 1.
4 Условие: ЕСЛИ в ячейке С11 число больше 18 – то результат в С11 – ячейка Е11 разделить на число 37 с округлением до целого числа. Наверное, надо использовать функцию ОКРУГЛТ.
37 – это Среднетехническая скорость автомобиля.
Для остальных ячеек диапазона C12:C32 условия такие же – надо будет только «протянуть» формулу вниз.

Я написал формулу:
Код
=ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);ЕСЛИ(E11<=18;1;""))

Но при этой формуле, если не заполнена ячейка А11 Результат – 1, а должно быть ПУСТАЯ ячейка.
К сообщению приложен файл: __4_.xlsx(15.4 Kb)


Сообщение отредактировал Никанор - Пятница, 27.04.2018, 18:35
 
Ответить
СообщениеЗдравствуйте уважаемые помогающие!

Полное название темы, которое не поместилось вот полное название темы:
ЕСЛИ с 4 условиями. ЕСЛИ больше и ЕСЛИ меньше – то разный результат.
ЕСЛЕ пустая ячейка столбца А– результат – пустая ячейка


Помогите, пожалуйста, написать формулу в прикреплённый файл в столбец С в диапазон ячеек C11:C32 с условиями.
Для ячейки С11 Условия
1 Условие: ЕСЛИ не заполнена ячейка А11 – ячейка С11 пустая;
2 Условие: ЕСЛИ заполнена ячейки А11 и Е11 только тогда заполняется ячейка С11;
3 Условие: ЕСЛИ в ячейке С11 число меньше и равно 18 – то результат в С11 – 1.
4 Условие: ЕСЛИ в ячейке С11 число больше 18 – то результат в С11 – ячейка Е11 разделить на число 37 с округлением до целого числа. Наверное, надо использовать функцию ОКРУГЛТ.
37 – это Среднетехническая скорость автомобиля.
Для остальных ячеек диапазона C12:C32 условия такие же – надо будет только «протянуть» формулу вниз.

Я написал формулу:
Код
=ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);ЕСЛИ(E11<=18;1;""))

Но при этой формуле, если не заполнена ячейка А11 Результат – 1, а должно быть ПУСТАЯ ячейка.

Автор - Никанор
Дата добавления - 27.04.2018 в 16:57
Nic70y Дата: Пятница, 27.04.2018, 17:15 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4738
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(И(A11<>"";E11<>"");
Код
=ЕСЛИ(И(A11<>"";E11<>"");ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);1);"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 27.04.2018, 17:20
 
Ответить
Сообщение
Код
=ЕСЛИ(И(A11<>"";E11<>"");
Код
=ЕСЛИ(И(A11<>"";E11<>"");ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);1);"")

Автор - Nic70y
Дата добавления - 27.04.2018 в 17:15
Никанор Дата: Пятница, 27.04.2018, 17:30 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 285
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Николай Здравствуйте!
Большое спасибо за быстрый ответ на 18 минуте после опубликования моего вопроса.
Я наверное больше времени писал – формулировал вопрос чем Вы отвечали.
И я очень много времени потратил на самостоятельное написание этой формулы.
У меня в моих пробах результат ЕСЛИ не заполнена ячейка А11 результат был ЛОЖЬ

Сейчас проверяю вторая формула «работает».
Ваша формула очень простая.
Скажите пожалуйста: Что это первая формула? Она «не работает».
А первая формула кажется считает правильно.


Сообщение отредактировал Никанор - Пятница, 27.04.2018, 17:38
 
Ответить
СообщениеNic70y, Николай Здравствуйте!
Большое спасибо за быстрый ответ на 18 минуте после опубликования моего вопроса.
Я наверное больше времени писал – формулировал вопрос чем Вы отвечали.
И я очень много времени потратил на самостоятельное написание этой формулы.
У меня в моих пробах результат ЕСЛИ не заполнена ячейка А11 результат был ЛОЖЬ

Сейчас проверяю вторая формула «работает».
Ваша формула очень простая.
Скажите пожалуйста: Что это первая формула? Она «не работает».
А первая формула кажется считает правильно.

Автор - Никанор
Дата добавления - 27.04.2018 в 17:30
Nic70y Дата: Пятница, 27.04.2018, 17:35 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4738
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2013
первая это вообще не формула, а
Цитата Никанор, 27.04.2018 в 16:57, в сообщении № 1 ()
ЕСЛИ заполнена ячейки А11 и Е11


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениепервая это вообще не формула, а
Цитата Никанор, 27.04.2018 в 16:57, в сообщении № 1 ()
ЕСЛИ заполнена ячейки А11 и Е11

Автор - Nic70y
Дата добавления - 27.04.2018 в 17:35
Никанор Дата: Пятница, 27.04.2018, 17:41 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 285
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Спасибо за ответ и объяснение!
Я понял это алгоритм – последовательность как начинать писать полную формулу с моими условиями, верно?


Сообщение отредактировал Никанор - Пятница, 27.04.2018, 17:42
 
Ответить
СообщениеСпасибо за ответ и объяснение!
Я понял это алгоритм – последовательность как начинать писать полную формулу с моими условиями, верно?

Автор - Никанор
Дата добавления - 27.04.2018 в 17:41
Никанор Дата: Пятница, 27.04.2018, 17:47 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 285
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Николай, скажите пожалуйста правильна ли будет формула только с УСЛОВИЕМ, ЕСЛИ не заполнена одна ячейка A11, не учитывая ячейку E11
Код
=ЕСЛИ(И(A11<>"");ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);1);"")
 
Ответить
СообщениеНиколай, скажите пожалуйста правильна ли будет формула только с УСЛОВИЕМ, ЕСЛИ не заполнена одна ячейка A11, не учитывая ячейку E11
Код
=ЕСЛИ(И(A11<>"");ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);1);"")

Автор - Никанор
Дата добавления - 27.04.2018 в 17:47
StoTisteg Дата: Суббота, 28.04.2018, 10:15 | Сообщение № 7
Группа: Авторы
Ранг: Ветеран
Сообщений: 918
Репутация: 78 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(A11<>"";ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);1);"")


Проверь всё. ThisWorkbook.Save. On Error Resume Next.

Сообщение отредактировал StoTisteg - Суббота, 28.04.2018, 10:16
 
Ответить
Сообщение
Код
=ЕСЛИ(A11<>"";ЕСЛИ(E11>18;ОКРУГЛТ(E11/37+Ч("Среднетехническая скорость");1);1);"")

Автор - StoTisteg
Дата добавления - 28.04.2018 в 10:15
_Boroda_ Дата: Суббота, 28.04.2018, 11:23 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12749
Репутация: 5227 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИ(A11;ЕСЛИ(E11>18;ОКРУГЛ(E11/37;);1);"")
К сообщению приложен файл: _4_1.xlsx(15.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(A11;ЕСЛИ(E11>18;ОКРУГЛ(E11/37;);1);"")

Автор - _Boroda_
Дата добавления - 28.04.2018 в 11:23
Никанор Дата: Вторник, 01.05.2018, 20:43 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 285
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте StoTisteg – Фил, Boroda_ – Александр!
Большое спасибо за формулы.
У меня сейчас нет возможности проверить Ваши формулы в файле.
Скажите пожалуйста Ваши формулы с условием ЕСЛИ не заполнена одна ячейка A11, не учитывая ячейку E11?


Сообщение отредактировал Никанор - Вторник, 01.05.2018, 21:20
 
Ответить
СообщениеЗдравствуйте StoTisteg – Фил, Boroda_ – Александр!
Большое спасибо за формулы.
У меня сейчас нет возможности проверить Ваши формулы в файле.
Скажите пожалуйста Ваши формулы с условием ЕСЛИ не заполнена одна ячейка A11, не учитывая ячейку E11?

Автор - Никанор
Дата добавления - 01.05.2018 в 20:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ЕСЛИ с 4 условиями ЕСЛИ Больше, Меньше или ПУСТАЯ ячейка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!