Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Еслисумма больше и меньше значении - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Еслисумма больше и меньше значении (Формулы/Formulas)
Еслисумма больше и меньше значении
Kaiyr Дата: Суббота, 28.04.2018, 08:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Код
=СУММЕСЛИ(A9:A109;И(A9:A109">=N8";A9:A109"<=O8");B9:B109)
Что то не работает формула. Надо что бы суммировал значения в интервалах указанных. Файл прикреплен.
К сообщению приложен файл: rTab01_00.xls(38.0 Kb)


Активный участник Википедии, могу проконсультировать
 
Ответить
СообщениеЗдравствуйте!
Код
=СУММЕСЛИ(A9:A109;И(A9:A109">=N8";A9:A109"<=O8");B9:B109)
Что то не работает формула. Надо что бы суммировал значения в интервалах указанных. Файл прикреплен.

Автор - Kaiyr
Дата добавления - 28.04.2018 в 08:37
Russel Дата: Суббота, 28.04.2018, 09:07 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1292
Репутация: 293 ±
Замечаний: 0% ±

Excel 2010
Доброе утро!

В столбце А числа сохранены как текст - это надо исправить.
Вариант формулы для подсчета:
Код
=СУММПРОИЗВ(($A$9:$A$109>=--ЛЕВБ(M8;2))*($A$9:$A$109<=--ПРАВБ(M8;2))*$B$9:$B$109)

Для последней строки чуть отличается:
Код
=СУММПРОИЗВ(($A$9:$A$109>=--ЛЕВБ(M20;2))*$B$9:$B$109)
К сообщению приложен файл: 3650425.xls(44.0 Kb)


QIWI 9173973973
 
Ответить
СообщениеДоброе утро!

В столбце А числа сохранены как текст - это надо исправить.
Вариант формулы для подсчета:
Код
=СУММПРОИЗВ(($A$9:$A$109>=--ЛЕВБ(M8;2))*($A$9:$A$109<=--ПРАВБ(M8;2))*$B$9:$B$109)

Для последней строки чуть отличается:
Код
=СУММПРОИЗВ(($A$9:$A$109>=--ЛЕВБ(M20;2))*$B$9:$B$109)

Автор - Russel
Дата добавления - 28.04.2018 в 09:07
Светлый Дата: Суббота, 28.04.2018, 09:13 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 560
Репутация: 132 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Код
=СУММПРОИЗВ((--A$9:A$109>=N8)*(--A$9:A$109<=O8)*B$9:B$109)

Код
=СУММПРОИЗВ((-A$9:A$109<=-ЛЕВБ(M8;2))*(-A$9:A$109>=ЕСЛИОШИБКА(-ПРАВБ(M8;2);-100))*B$9:B$109)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 28.04.2018, 09:23
 
Ответить
СообщениеЗдравствуйте!
Код
=СУММПРОИЗВ((--A$9:A$109>=N8)*(--A$9:A$109<=O8)*B$9:B$109)

Код
=СУММПРОИЗВ((-A$9:A$109<=-ЛЕВБ(M8;2))*(-A$9:A$109>=ЕСЛИОШИБКА(-ПРАВБ(M8;2);-100))*B$9:B$109)

Автор - Светлый
Дата добавления - 28.04.2018 в 09:13
Kaiyr Дата: Суббота, 28.04.2018, 10:32 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо всем.)) --ЛЕВБ для чего тут два дефиса?


Активный участник Википедии, могу проконсультировать

Сообщение отредактировал Kaiyr - Суббота, 28.04.2018, 12:51
 
Ответить
СообщениеСпасибо всем.)) --ЛЕВБ для чего тут два дефиса?

Автор - Kaiyr
Дата добавления - 28.04.2018 в 10:32
Russel Дата: Суббота, 28.04.2018, 13:57 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1292
Репутация: 293 ±
Замечаний: 0% ±

Excel 2010
--ЛЕВБ для чего тут два дефиса?

Для того, чтобы текстовое значение перевести в числовое.


QIWI 9173973973
 
Ответить
Сообщение
--ЛЕВБ для чего тут два дефиса?

Для того, чтобы текстовое значение перевести в числовое.

Автор - Russel
Дата добавления - 28.04.2018 в 13:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Еслисумма больше и меньше значении (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!