Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор данных при нескольких ЕСЛИ из массива с формулами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных при нескольких ЕСЛИ из массива с формулами (Формулы/Formulas)
Выбор данных при нескольких ЕСЛИ из массива с формулами
Risovod Дата: Суббота, 28.04.2018, 18:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.

Прошу помочь формулой (желательно для MS Excel 2003) для решения следующей задачи:
- нужно при соблюдении двух условий выбрать из массива соответствующее значение. Сначала диапазон из первой строки проверяется на соответствие с условием, а потом при выполнении первого условия проверяется второе из другой строки, но в диапазоне соответствующем первому условию. Далее из соответствующей двум условиям колонки в указанной строке выбирается необходимое значение.

Пробовал написать формулу для массива, но видимо есть ошибки и она не работает
Код
{=ЕСЛИ(ЕОШИБКА(ЕСЛИ(B$2:M$2=A130&B$3:M$3="га";ЕСЛИ(B$123:M$123;B$123:M$123);""));"";ЕСЛИ(B$2:M$2=A130&B$3:M$3="га";ЕСЛИ(B$123:M$123;B$123:M$123);""))}


Ниже прикрепляю файл с примером и описанием.
К сообщению приложен файл: 2175123.xls(41.0 Kb)


Сообщение отредактировал Risovod - Суббота, 28.04.2018, 18:28
 
Ответить
СообщениеЗдравствуйте.

Прошу помочь формулой (желательно для MS Excel 2003) для решения следующей задачи:
- нужно при соблюдении двух условий выбрать из массива соответствующее значение. Сначала диапазон из первой строки проверяется на соответствие с условием, а потом при выполнении первого условия проверяется второе из другой строки, но в диапазоне соответствующем первому условию. Далее из соответствующей двум условиям колонки в указанной строке выбирается необходимое значение.

Пробовал написать формулу для массива, но видимо есть ошибки и она не работает
Код
{=ЕСЛИ(ЕОШИБКА(ЕСЛИ(B$2:M$2=A130&B$3:M$3="га";ЕСЛИ(B$123:M$123;B$123:M$123);""));"";ЕСЛИ(B$2:M$2=A130&B$3:M$3="га";ЕСЛИ(B$123:M$123;B$123:M$123);""))}


Ниже прикрепляю файл с примером и описанием.

Автор - Risovod
Дата добавления - 28.04.2018 в 18:23
_Boroda_ Дата: Суббота, 28.04.2018, 18:33 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12097
Репутация: 4988 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($B$123:$M$123;ПОИСКПОЗ($A130;$B$2:$M$2;)+(B$129="ц/га"))
К сообщению приложен файл: 2175123_1.xls(41.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($B$123:$M$123;ПОИСКПОЗ($A130;$B$2:$M$2;)+(B$129="ц/га"))

Автор - _Boroda_
Дата добавления - 28.04.2018 в 18:33
Risovod Дата: Суббота, 28.04.2018, 18:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, Спасибо большое за оперативную помощь. Идеально.
Вопрос решён.

Я так понимаю, что для первой колонки в конце формулы можно прописывать любой текст (можно даже без него) - это не влияет на выполнение формулы ...+(B$129="ц/га")) так как сделали ссылку на ячейку с необходимым условием, а для второй нужно обязательно прописывать нужное значение.


Сообщение отредактировал Risovod - Суббота, 28.04.2018, 19:00
 
Ответить
Сообщение_Boroda_, Спасибо большое за оперативную помощь. Идеально.
Вопрос решён.

Я так понимаю, что для первой колонки в конце формулы можно прописывать любой текст (можно даже без него) - это не влияет на выполнение формулы ...+(B$129="ц/га")) так как сделали ссылку на ячейку с необходимым условием, а для второй нужно обязательно прописывать нужное значение.

Автор - Risovod
Дата добавления - 28.04.2018 в 18:45
Karataev Дата: Суббота, 28.04.2018, 18:51 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1232
Репутация: 464 ±
Замечаний: 0% ±

Excel
В строке 3 просматривается 100 столбцов. Формула немассивная, для "B130":
Код
=ИНДЕКС($123:$123;1;ПОИСКПОЗ(B$129;ИНДЕКС($3:$3;1;ПОИСКПОЗ($A130;$2:$2;0)):ИНДЕКС($3:$3;1;100);0)+ПОИСКПОЗ($A130;$2:$2;0)-1)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеВ строке 3 просматривается 100 столбцов. Формула немассивная, для "B130":
Код
=ИНДЕКС($123:$123;1;ПОИСКПОЗ(B$129;ИНДЕКС($3:$3;1;ПОИСКПОЗ($A130;$2:$2;0)):ИНДЕКС($3:$3;1;100);0)+ПОИСКПОЗ($A130;$2:$2;0)-1)

Автор - Karataev
Дата добавления - 28.04.2018 в 18:51
Risovod Дата: Суббота, 28.04.2018, 19:04 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Karataev, Спасибо Вам тоже. Всё работает.
просматривается 100 столбцов
- это был только пример.
 
Ответить
СообщениеKarataev, Спасибо Вам тоже. Всё работает.
просматривается 100 столбцов
- это был только пример.

Автор - Risovod
Дата добавления - 28.04.2018 в 19:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных при нескольких ЕСЛИ из массива с формулами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!