Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не получается избавиться от #ДЕЛ/0! в формуле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не получается избавиться от #ДЕЛ/0! в формуле (Формулы/Formulas)
Не получается избавиться от #ДЕЛ/0! в формуле
Risovod Дата: Воскресенье, 29.04.2018, 18:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.

Нужно, чтобы при выполнении формулы не отображалась ошибка #ДЕЛ/0!, а просто пустая ячейка.
Пробовал решить через ЕОШИБКА, но не получилось:
Код
=ЕСЛИ(ЕОШИБКА(СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36>0)))>0;СУММЕСЛИ($B$4:$M$4;"ц/га";B36:M36)/СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>""));"")

Пробовал решить через ЕЧИСЛО, но тоже не получилось:
Код
=ЕСЛИ(ЕЧИСЛО(СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36>0)))>0;СУММЕСЛИ($B$4:$M$4;"ц/га";B36:M36)/СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>""));"")

Подскажите как правильно?

В прилагаемом файле, ячейку с формулой выделил цветом.
К сообщению приложен файл: 5052071.xls(36.0 Kb)


Сообщение отредактировал Risovod - Воскресенье, 29.04.2018, 18:02
 
Ответить
СообщениеЗдравствуйте.

Нужно, чтобы при выполнении формулы не отображалась ошибка #ДЕЛ/0!, а просто пустая ячейка.
Пробовал решить через ЕОШИБКА, но не получилось:
Код
=ЕСЛИ(ЕОШИБКА(СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36>0)))>0;СУММЕСЛИ($B$4:$M$4;"ц/га";B36:M36)/СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>""));"")

Пробовал решить через ЕЧИСЛО, но тоже не получилось:
Код
=ЕСЛИ(ЕЧИСЛО(СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36>0)))>0;СУММЕСЛИ($B$4:$M$4;"ц/га";B36:M36)/СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>""));"")

Подскажите как правильно?

В прилагаемом файле, ячейку с формулой выделил цветом.

Автор - Risovod
Дата добавления - 29.04.2018 в 18:02
Karataev Дата: Воскресенье, 29.04.2018, 18:11 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1257
Репутация: 485 ±
Замечаний: 0% ±

Excel
Для "O36":
Код
=ЕСЛИ(СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>""))=0;"";СУММЕСЛИ($B$4:$M$4;"ц/га";B36:M36)/СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>"")))


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеДля "O36":
Код
=ЕСЛИ(СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>""))=0;"";СУММЕСЛИ($B$4:$M$4;"ц/га";B36:M36)/СУММПРОИЗВ(($B$4:$M$4="ц/га")*(B36:M36<>"")))

Автор - Karataev
Дата добавления - 29.04.2018 в 18:11
Risovod Дата: Воскресенье, 29.04.2018, 18:15 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Karataev, Спасибо. Работает.
Вопрос решён.
 
Ответить
СообщениеKarataev, Спасибо. Работает.
Вопрос решён.

Автор - Risovod
Дата добавления - 29.04.2018 в 18:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не получается избавиться от #ДЕЛ/0! в формуле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!