Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по дате из массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по дате из массива (Формулы/Formulas)
Поиск значения по дате из массива
Adelante225 Дата: Четверг, 10.05.2018, 09:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, прошу помощи. Ситуация: необходимо найти значение из таблицы на листе "индексы" по дате в столбце "Дата" на листе "1". Самостоятельно, к сожалению, составить формулу не получается.
К сообщению приложен файл: 3048029.xls(36.5 Kb)
 
Ответить
СообщениеЗдравствуйте, прошу помощи. Ситуация: необходимо найти значение из таблицы на листе "индексы" по дате в столбце "Дата" на листе "1". Самостоятельно, к сожалению, составить формулу не получается.

Автор - Adelante225
Дата добавления - 10.05.2018 в 09:36
sboy Дата: Четверг, 10.05.2018, 09:41 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1739
Репутация: 492 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=ИНДЕКС(индексы!$H$3:$AB$14;МЕСЯЦ(C7);ПОИСКПОЗ(ГОД(C7);индексы!$H$2:$AB$2;))
К сообщению приложен файл: 7606122.xls(38.0 Kb)
 
Ответить
СообщениеДобрый день.
Код
=ИНДЕКС(индексы!$H$3:$AB$14;МЕСЯЦ(C7);ПОИСКПОЗ(ГОД(C7);индексы!$H$2:$AB$2;))

Автор - sboy
Дата добавления - 10.05.2018 в 09:41
_Boroda_ Дата: Четверг, 10.05.2018, 09:42 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12097
Репутация: 4988 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Самое простое на мой взгляд
Код
=СУММПРОИЗВ((ГОД(C7)=индексы!H$2:AB$2)*(ТЕКСТ(C7;"ММММ")=индексы!G$3:G$14)*индексы!H$3:AB$14)


Или вот еще
Код
=ГПР(ГОД(C7);индексы!H$2:AB$14;МЕСЯЦ(C7)+1;)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСамое простое на мой взгляд
Код
=СУММПРОИЗВ((ГОД(C7)=индексы!H$2:AB$2)*(ТЕКСТ(C7;"ММММ")=индексы!G$3:G$14)*индексы!H$3:AB$14)


Или вот еще
Код
=ГПР(ГОД(C7);индексы!H$2:AB$14;МЕСЯЦ(C7)+1;)

Автор - _Boroda_
Дата добавления - 10.05.2018 в 09:42
Adelante225 Дата: Четверг, 10.05.2018, 09:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Огромное спасибо hands
 
Ответить
СообщениеОгромное спасибо hands

Автор - Adelante225
Дата добавления - 10.05.2018 в 09:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по дате из массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!