Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по дополнительному критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по дополнительному критерию (Формулы/Formulas)
Суммирование по дополнительному критерию
zegor Дата: Понедельник, 14.05.2018, 11:22 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Привет, exelworld. Во вложении в ячейке AT22 есть формула (спасибо bmv98rus и _Boroda_) которая суммирует 8 последних соответствующих критерию значений. Подскажи пожалуйста как "прикрутить" доп.критерий равный значению 1 из столбца AV:AV. Я пробовал вариант с функцией И но так и не осилил.
К сообщению приложен файл: 1514287.xlsx(39.7 Kb)
 
Ответить
СообщениеПривет, exelworld. Во вложении в ячейке AT22 есть формула (спасибо bmv98rus и _Boroda_) которая суммирует 8 последних соответствующих критерию значений. Подскажи пожалуйста как "прикрутить" доп.критерий равный значению 1 из столбца AV:AV. Я пробовал вариант с функцией И но так и не осилил.

Автор - zegor
Дата добавления - 14.05.2018 в 11:22
sboy Дата: Понедельник, 14.05.2018, 11:31 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
вместо СЧЁТЕСЛИ, попробуйте использовать СЧЁТЕСЛИМН в этом куске
Код
СЧЁТЕСЛИМН($B$2:$B21;B22;$AV$2:$AV21;1)>7
 
Ответить
СообщениеДобрый день.
вместо СЧЁТЕСЛИ, попробуйте использовать СЧЁТЕСЛИМН в этом куске
Код
СЧЁТЕСЛИМН($B$2:$B21;B22;$AV$2:$AV21;1)>7

Автор - sboy
Дата добавления - 14.05.2018 в 11:31
zegor Дата: Понедельник, 14.05.2018, 11:44 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
sboy, здравствуйте. Спасибо за подсказку. Так считает верно, в результате получаю "пусто" (по условию из ЕСЛИ>7). А как из уже вычлененных восьми "отщипнуть" те которые будут соответствовать ещё и критерию 1 и уже затем только их суммировать?

вот как я сделал
Код
=ЕСЛИ(СЧЁТЕСЛИМН($B$2:$B21;B22;$AW$2:$AW21;1)>7;СУММПРОИЗВ(ИНДЕКС(AH:AH;Ч(ИНДЕКС(НАИБОЛЬШИЙ(СТРОКА($2:21)*($B$2:$B21=B22);СТРОКА($1:$8));))));"")


Сообщение отредактировал zegor - Понедельник, 14.05.2018, 11:46
 
Ответить
Сообщениеsboy, здравствуйте. Спасибо за подсказку. Так считает верно, в результате получаю "пусто" (по условию из ЕСЛИ>7). А как из уже вычлененных восьми "отщипнуть" те которые будут соответствовать ещё и критерию 1 и уже затем только их суммировать?

вот как я сделал
Код
=ЕСЛИ(СЧЁТЕСЛИМН($B$2:$B21;B22;$AW$2:$AW21;1)>7;СУММПРОИЗВ(ИНДЕКС(AH:AH;Ч(ИНДЕКС(НАИБОЛЬШИЙ(СТРОКА($2:21)*($B$2:$B21=B22);СТРОКА($1:$8));))));"")

Автор - zegor
Дата добавления - 14.05.2018 в 11:44
_Boroda_ Дата: Понедельник, 14.05.2018, 11:57 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12772
Репутация: 5232 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для АТ22
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B21;B22)>7;СУММПРОИЗВ(ИНДЕКС(AH$1:AH21;Ч(ИНДЕКС(НАИБОЛЬШИЙ(СТРОКА($2:21)*(B$2:B21=B22)*(AV$2:AV21=1);СТРОКА($1:$8));))));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля АТ22
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B21;B22)>7;СУММПРОИЗВ(ИНДЕКС(AH$1:AH21;Ч(ИНДЕКС(НАИБОЛЬШИЙ(СТРОКА($2:21)*(B$2:B21=B22)*(AV$2:AV21=1);СТРОКА($1:$8));))));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 14.05.2018 в 11:57
zegor Дата: Понедельник, 14.05.2018, 12:11 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Большое Вам спасибо ,_Boroda_. Всё идеально.
 
Ответить
СообщениеБольшое Вам спасибо ,_Boroda_. Всё идеально.

Автор - zegor
Дата добавления - 14.05.2018 в 12:11
zegor Дата: Понедельник, 21.05.2018, 08:59 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Привет ещё раз, уважаемый excelworld. Новую тему не создаю т.к. возникла проблема с решенной. В прикрепленном файле один из случаев некорректной работы формулы от _Boroda_ (вполне возможно я сам делаю что-то не так). Суть– в ячейке AT31 неверное значение, вместо 17059780 по доп.критерию "O" получаем почему-то 33643999. Пожалуйста помогите разобраться.
К сообщению приложен файл: 5248939.xlsx(41.4 Kb)
 
Ответить
СообщениеПривет ещё раз, уважаемый excelworld. Новую тему не создаю т.к. возникла проблема с решенной. В прикрепленном файле один из случаев некорректной работы формулы от _Boroda_ (вполне возможно я сам делаю что-то не так). Суть– в ячейке AT31 неверное значение, вместо 17059780 по доп.критерию "O" получаем почему-то 33643999. Пожалуйста помогите разобраться.

Автор - zegor
Дата добавления - 21.05.2018 в 08:59
_Boroda_ Дата: Понедельник, 21.05.2018, 10:08 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12772
Репутация: 5232 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, действительно. Тогда немассивная формула
Код
=ЕСЛИ(СЧЁТЕСЛИ($B1:$B$2;B2)>7;СУММПРОИЗВ(AY1:AY$2*(B1:B$2=B2)*(AV1:AV$2="O")*(СТРОКА(AT1:AT$2)>=НАИБОЛЬШИЙ((B1:B$2=B2)*СТРОКА(B1:B$2);8)));"")
К сообщению приложен файл: 5248939_1.xlsx(41.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, действительно. Тогда немассивная формула
Код
=ЕСЛИ(СЧЁТЕСЛИ($B1:$B$2;B2)>7;СУММПРОИЗВ(AY1:AY$2*(B1:B$2=B2)*(AV1:AV$2="O")*(СТРОКА(AT1:AT$2)>=НАИБОЛЬШИЙ((B1:B$2=B2)*СТРОКА(B1:B$2);8)));"")

Автор - _Boroda_
Дата добавления - 21.05.2018 в 10:08
zegor Дата: Понедельник, 21.05.2018, 10:18 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, благодарю Вас. Вы делаете добрые дела yes
 
Ответить
Сообщение_Boroda_, благодарю Вас. Вы делаете добрые дела yes

Автор - zegor
Дата добавления - 21.05.2018 в 10:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по дополнительному критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!