Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Рассчитать дату первого воскресенья в месяце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитать дату первого воскресенья в месяце (Формулы/Formulas)
Рассчитать дату первого воскресенья в месяце
nirinan69 Дата: Среда, 16.05.2018, 13:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, подскажите возможно ли рассчитать дату первого воскресенья в месяце. Допустим в ячейке А1 я поставлю 01.05.2018 (это будет постоянно меняется на первое число месяца) и чтобы после этого допустим в ячейке С1 появился результат, в данном случае число 06.05.2018.
К сообщению приложен файл: Voskr.xlsx(7.8 Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите возможно ли рассчитать дату первого воскресенья в месяце. Допустим в ячейке А1 я поставлю 01.05.2018 (это будет постоянно меняется на первое число месяца) и чтобы после этого допустим в ячейке С1 появился результат, в данном случае число 06.05.2018.

Автор - nirinan69
Дата добавления - 16.05.2018 в 13:14
StoTisteg Дата: Среда, 16.05.2018, 13:53 | Сообщение № 2
Группа: Авторы
Ранг: Ветеран
Сообщений: 748
Репутация: 58 ±
Замечаний: 0% ±

Excel 2010
Код
=A1+(8-ДЕНЬНЕД(A1))
По-моему, так...


Проверь всё. ThisWorkbook.Save. On Error Resume Next.

Сообщение отредактировал StoTisteg - Среда, 16.05.2018, 13:53
 
Ответить
Сообщение
Код
=A1+(8-ДЕНЬНЕД(A1))
По-моему, так...

Автор - StoTisteg
Дата добавления - 16.05.2018 в 13:53
_Boroda_ Дата: Среда, 16.05.2018, 14:07 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12092
Репутация: 4987 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
=A1+(8-ДЕНЬНЕД(A1))
По-моему, так...

1/04/18 и 1/07/18
Такой вариант
Код
=A1+(8-ДЕНЬНЕД(A1))*(ДЕНЬНЕД(A1)<>1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
=A1+(8-ДЕНЬНЕД(A1))
По-моему, так...

1/04/18 и 1/07/18
Такой вариант
Код
=A1+(8-ДЕНЬНЕД(A1))*(ДЕНЬНЕД(A1)<>1)

Автор - _Boroda_
Дата добавления - 16.05.2018 в 14:07
abtextime Дата: Среда, 16.05.2018, 14:07 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 743
Репутация: 102 ±
Замечаний: 0% ±

Excel 2010
StoTisteg, но если воскресень - первое число, будет некорректно. Лучше так

Код
=ЕСЛИ(ДЕНЬНЕД(A1)=1;A1;A1+(8-ДЕНЬНЕД(A1)))
К сообщению приложен файл: 8325828.xlsx(9.6 Kb)
 
Ответить
СообщениеStoTisteg, но если воскресень - первое число, будет некорректно. Лучше так

Код
=ЕСЛИ(ДЕНЬНЕД(A1)=1;A1;A1+(8-ДЕНЬНЕД(A1)))

Автор - abtextime
Дата добавления - 16.05.2018 в 14:07
sboy Дата: Среда, 16.05.2018, 14:08 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1738
Репутация: 492 ±
Замечаний: 0% ±

Excel 2010
Такой вариант

а почему не так?
Код
=A1+(7-ДЕНЬНЕД(A1;2))
 
Ответить
Сообщение
Такой вариант

а почему не так?
Код
=A1+(7-ДЕНЬНЕД(A1;2))

Автор - sboy
Дата добавления - 16.05.2018 в 14:08
nirinan69 Дата: Среда, 16.05.2018, 14:13 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Большое спасибо за несколько вариантов
 
Ответить
СообщениеБольшое спасибо за несколько вариантов

Автор - nirinan69
Дата добавления - 16.05.2018 в 14:13
_Boroda_ Дата: Среда, 16.05.2018, 14:15 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12092
Репутация: 4987 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да,
Код
=A1+7-ДЕНЬНЕД(A1;2)

конечно лучше


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа,
Код
=A1+7-ДЕНЬНЕД(A1;2)

конечно лучше

Автор - _Boroda_
Дата добавления - 16.05.2018 в 14:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитать дату первого воскресенья в месяце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!