Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/данные из объединенной ячейки копируются с интервалом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » данные из объединенной ячейки копируются с интервалом (Формулы/Formulas)
данные из объединенной ячейки копируются с интервалом
Svetik@82 Дата: Пятница, 25.05.2018, 10:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Пытаюсь заполнить табель учета рабочего времени. Ввожу формулу в ячейку AW, после чего протягиваю ее за маркер заполнения на остальные ячейки. и тут возникает ПРОБЛЕМА. копирование происходит с интервалом в четыре. я понимаю что это происходить из за того, ячейка AW это объединенные ячейка AW-AZ, но что с этим делать не знаю, помогите. хочу сделать табель, чтобы не вносить все заново каждый мксяц, а заполнялся бы автоматически. если у кого нибудь есть табель уже с формулами буду признательна
К сообщению приложен файл: tabel13.xlsx(45.8 Kb)


Сообщение отредактировал Svetik@82 - Пятница, 25.05.2018, 10:50
 
Ответить
СообщениеДобрый день. Пытаюсь заполнить табель учета рабочего времени. Ввожу формулу в ячейку AW, после чего протягиваю ее за маркер заполнения на остальные ячейки. и тут возникает ПРОБЛЕМА. копирование происходит с интервалом в четыре. я понимаю что это происходить из за того, ячейка AW это объединенные ячейка AW-AZ, но что с этим делать не знаю, помогите. хочу сделать табель, чтобы не вносить все заново каждый мксяц, а заполнялся бы автоматически. если у кого нибудь есть табель уже с формулами буду признательна

Автор - Svetik@82
Дата добавления - 25.05.2018 в 10:06
Svetik@82 Дата: Пятница, 25.05.2018, 11:51 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вот новый табель с формулой
К сообщению приложен файл: 5042725.xlsx(93.2 Kb)
 
Ответить
Сообщениевот новый табель с формулой

Автор - Svetik@82
Дата добавления - 25.05.2018 в 11:51
Nic70y Дата: Пятница, 25.05.2018, 12:00 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4737
Репутация: 1023 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(Табель!B:B;СТРОКА(A4)/4+4)&СИМВОЛ(10)&ИНДЕКС(Табель!C:C;СТРОКА(A4)/4+4)
ну да, скобки пропустил
Код
=ИНДЕКС(Табель!B:B;СТРОКА(A4)/4+4)&СИМВОЛ(10)&"("&ИНДЕКС(Табель!C:C;СТРОКА(A4)/4+4)&")"


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 25.05.2018, 12:28
 
Ответить
Сообщение
Код
=ИНДЕКС(Табель!B:B;СТРОКА(A4)/4+4)&СИМВОЛ(10)&ИНДЕКС(Табель!C:C;СТРОКА(A4)/4+4)
ну да, скобки пропустил
Код
=ИНДЕКС(Табель!B:B;СТРОКА(A4)/4+4)&СИМВОЛ(10)&"("&ИНДЕКС(Табель!C:C;СТРОКА(A4)/4+4)&")"

Автор - Nic70y
Дата добавления - 25.05.2018 в 12:00
_Boroda_ Дата: Пятница, 25.05.2018, 12:12 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12744
Репутация: 5226 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
[vba]
Код
=ВПР(СЧЁТЗ(I$23:AI23);Табель!A$5:C$31;2;)&"
("&ВПР(СЧЁТЗ(I$23:AI23);Табель!A$5:C$31;3;)&")"
[/vba]
К сообщению приложен файл: 5042725_1.xlsx(92.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
[vba]
Код
=ВПР(СЧЁТЗ(I$23:AI23);Табель!A$5:C$31;2;)&"
("&ВПР(СЧЁТЗ(I$23:AI23);Табель!A$5:C$31;3;)&")"
[/vba]

Автор - _Boroda_
Дата добавления - 25.05.2018 в 12:12
Svetik@82 Дата: Понедельник, 28.05.2018, 10:10 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, спасибо большое за помощь. формулы скопировала, все получается, но к сожалению разобраться самой не выходит. %) Опять прикладываю табель с новой формулой, если не сложно помогите
К сообщению приложен файл: 5717603.rar(79.4 Kb)
 
Ответить
СообщениеЗдравствуйте, спасибо большое за помощь. формулы скопировала, все получается, но к сожалению разобраться самой не выходит. %) Опять прикладываю табель с новой формулой, если не сложно помогите

Автор - Svetik@82
Дата добавления - 28.05.2018 в 10:10
Svetik@82 Дата: Понедельник, 28.05.2018, 11:16 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
я хотела проставить "Я" "В", задав формулу
Код
=ЕСЛИ(ИЛИ(JQ26=6;JQ26=7);"В";"Я"),
для, для ячейки AW 24 (01.01) получилось, хотела скопировать формулу протянув ее за маркер заполнения на остальные ячейки, но для ячейки BA24, считает через четыре дня , т.е. не за 02.05., а за 05.05.


Сообщение отредактировал Svetik@82 - Понедельник, 28.05.2018, 15:39
 
Ответить
Сообщениея хотела проставить "Я" "В", задав формулу
Код
=ЕСЛИ(ИЛИ(JQ26=6;JQ26=7);"В";"Я"),
для, для ячейки AW 24 (01.01) получилось, хотела скопировать формулу протянув ее за маркер заполнения на остальные ячейки, но для ячейки BA24, считает через четыре дня , т.е. не за 02.05., а за 05.05.

Автор - Svetik@82
Дата добавления - 28.05.2018 в 11:16
Svetik@82 Дата: Понедельник, 28.05.2018, 13:37 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
ПРОШУ ПРОЩЕНИЯ, во многом еще не разбираюсь, обещаю исправиться
К сообщению приложен файл: ___.rar(96.7 Kb)
 
Ответить
СообщениеПРОШУ ПРОЩЕНИЯ, во многом еще не разбираюсь, обещаю исправиться

Автор - Svetik@82
Дата добавления - 28.05.2018 в 13:37
Svetik@82 Дата: Понедельник, 28.05.2018, 14:03 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
после ввода формулы в ячейку перетягиваю ее за маркер заполнения на остальные ячейки. копирование происходит с интервалом в четыре
 
Ответить
Сообщениепосле ввода формулы в ячейку перетягиваю ее за маркер заполнения на остальные ячейки. копирование происходит с интервалом в четыре

Автор - Svetik@82
Дата добавления - 28.05.2018 в 14:03
_Boroda_ Дата: Понедельник, 28.05.2018, 15:47 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12744
Репутация: 5226 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$27:$KU$28;;ДЕНЬ(AW17));));"В";"Я"))

Добавил там еще раскраску Условным форматированием
К сообщению приложен файл: 7_1.xlsb(91.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$27:$KU$28;;ДЕНЬ(AW17));));"В";"Я"))

Добавил там еще раскраску Условным форматированием

Автор - _Boroda_
Дата добавления - 28.05.2018 в 15:47
Svetik@82 Дата: Вторник, 29.05.2018, 09:45 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, вам огромное. Дальше попробую разобраться сама. но если не получиться, надеюсь в помощи не откажите
 
Ответить
СообщениеСпасибо, вам огромное. Дальше попробую разобраться сама. но если не получиться, надеюсь в помощи не откажите

Автор - Svetik@82
Дата добавления - 29.05.2018 в 09:45
Svetik@82 Дата: Среда, 30.05.2018, 10:33 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, мне опять нужна ваша помощь, хотела вставить формулу:
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$33:$KU$33;;ДЕНЬ(AW17));));"В";"Я";"Н"))

но для данной функции введено слишком много аргументов, помогите
К сообщению приложен файл: ___--.rar(88.6 Kb)
 
Ответить
СообщениеЗдравствуйте, мне опять нужна ваша помощь, хотела вставить формулу:
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$33:$KU$33;;ДЕНЬ(AW17));));"В";"Я";"Н"))

но для данной функции введено слишком много аргументов, помогите

Автор - Svetik@82
Дата добавления - 30.05.2018 в 10:33
_Boroda_ Дата: Среда, 30.05.2018, 10:45 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12744
Репутация: 5226 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Читайте справку по функции ЕСЛИ


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧитайте справку по функции ЕСЛИ

Автор - _Boroda_
Дата добавления - 30.05.2018 в 10:45
Svetik@82 Дата: Среда, 30.05.2018, 10:49 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
где это можно прочитать?
 
Ответить
Сообщениегде это можно прочитать?

Автор - Svetik@82
Дата добавления - 30.05.2018 в 10:49
Svetik@82 Дата: Среда, 30.05.2018, 10:59 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
прочитала, но где ошибка не разобралась :(
 
Ответить
Сообщениепрочитала, но где ошибка не разобралась :(

Автор - Svetik@82
Дата добавления - 30.05.2018 в 10:59
Pelena Дата: Среда, 30.05.2018, 11:02 | Сообщение № 15
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12905
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Файл не смотрела, но если по аналогии
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$33:$KU$33;;ДЕНЬ(AW17));));"В";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Я";ИНДЕКС($JQ$33:$KU$33;;ДЕНЬ(AW17));));"Я";"Н")))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл не смотрела, но если по аналогии
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$33:$KU$33;;ДЕНЬ(AW17));));"В";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Я";ИНДЕКС($JQ$33:$KU$33;;ДЕНЬ(AW17));));"Я";"Н")))

Автор - Pelena
Дата добавления - 30.05.2018 в 11:02
StoTisteg Дата: Среда, 30.05.2018, 13:37 | Сообщение № 16
Группа: Авторы
Ранг: Ветеран
Сообщений: 916
Репутация: 78 ±
Замечаний: 0% ±

Excel 2010
прочитала, но где ошибка не разобралась

Вот смотрите. В Вашей формуле сначала идёт условие, потом "В";"Я";"Н". "В" — если условие истинно, "Я" — если ложно. А "Н" когда и что с ним делать?


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
Сообщение
прочитала, но где ошибка не разобралась

Вот смотрите. В Вашей формуле сначала идёт условие, потом "В";"Я";"Н". "В" — если условие истинно, "Я" — если ложно. А "Н" когда и что с ним делать?

Автор - StoTisteg
Дата добавления - 30.05.2018 в 13:37
Svetik@82 Дата: Среда, 30.05.2018, 13:42 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
спасибо, огромное. как можно в этом разобраться????? читаю, читаю про эти формулы -темный лес <_<
 
Ответить
Сообщениеспасибо, огромное. как можно в этом разобраться????? читаю, читаю про эти формулы -темный лес <_<

Автор - Svetik@82
Дата добавления - 30.05.2018 в 13:42
Svetik@82 Дата: Среда, 30.05.2018, 14:46 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
это снова я
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"В";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("ВЧ";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"ВЧ";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Я";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"Я";"Н"))))

в ячейке в которой пишу данную формулу получается правильный ответ, а вот когда протягиваю на другие даты уже неверно, вместо В ставит Н, а в остальных ячейках правильно, где Я, там Я, где ВЧ, там ВЧ,помогите найти ошибку,


Сообщение отредактировал Svetik@82 - Среда, 30.05.2018, 15:16
 
Ответить
Сообщениеэто снова я
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("В";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"В";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("ВЧ";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"ВЧ";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Я";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"Я";"Н"))))

в ячейке в которой пишу данную формулу получается правильный ответ, а вот когда протягиваю на другие даты уже неверно, вместо В ставит Н, а в остальных ячейках правильно, где Я, там Я, где ВЧ, там ВЧ,помогите найти ошибку,

Автор - Svetik@82
Дата добавления - 30.05.2018 в 14:46
Svetik@82 Дата: Среда, 30.05.2018, 15:29 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
не знаю, правильно ли я сделала но в формуле
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Н";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"Н";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("ВЧ";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"ВЧ";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Я";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"Я";"В"))))
поменяла "В" на "Н", а "Н" на "В" и все получилось, надеюсь это не совпадение :D


Сообщение отредактировал Svetik@82 - Среда, 30.05.2018, 15:30
 
Ответить
Сообщениене знаю, правильно ли я сделала но в формуле
Код
=ЕСЛИ(AW17="Х";"Х";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Н";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"Н";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("ВЧ";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"ВЧ";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("Я";ИНДЕКС($JQ$40:$KU$40;;ДЕНЬ(AW17));));"Я";"В"))))
поменяла "В" на "Н", а "Н" на "В" и все получилось, надеюсь это не совпадение :D

Автор - Svetik@82
Дата добавления - 30.05.2018 в 15:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » данные из объединенной ячейки копируются с интервалом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!