Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и подстановка значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка значения (Формулы/Formulas)
Поиск и подстановка значения
slayge_nare Дата: Понедельник, 28.05.2018, 11:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!Помогите пожалуйста решение довольно простое и крутится в голове,но с Exel давненько не работал,вообщем необходимо из зеленого столбика найти такое же значение в одной из ячеек из красного и из этой строки подставить из синего в желтое)
К сообщению приложен файл: 123123.xls(54.0 Kb)


Сообщение отредактировал slayge_nare - Понедельник, 28.05.2018, 11:33
 
Ответить
СообщениеЗдравствуйте!Помогите пожалуйста решение довольно простое и крутится в голове,но с Exel давненько не работал,вообщем необходимо из зеленого столбика найти такое же значение в одной из ячеек из красного и из этой строки подставить из синего в желтое)

Автор - slayge_nare
Дата добавления - 28.05.2018 в 11:33
_Boroda_ Дата: Понедельник, 28.05.2018, 11:37 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12744
Репутация: 5226 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Добавлено
Пока писал, уже приложили

[offtop]Напомнило старую загадку: как на фоне черного из красного быстро сделать белое?
Ответ (мата нет, но впечатлительным моралистам читать не обязательно):


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Добавлено
Пока писал, уже приложили

[offtop]Напомнило старую загадку: как на фоне черного из красного быстро сделать белое?
Ответ (мата нет, но впечатлительным моралистам читать не обязательно):

Автор - _Boroda_
Дата добавления - 28.05.2018 в 11:37
_Boroda_ Дата: Понедельник, 28.05.2018, 11:41 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12744
Репутация: 5226 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИОШИБКА(ВПР(B1;L$1:M$673;2;);"")

Но ни одного значения не найдено
К сообщению приложен файл: 123123_1.xls(77.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(B1;L$1:M$673;2;);"")

Но ни одного значения не найдено

Автор - _Boroda_
Дата добавления - 28.05.2018 в 11:41
StoTisteg Дата: Понедельник, 28.05.2018, 11:49 | Сообщение № 4
Группа: Авторы
Ранг: Ветеран
Сообщений: 916
Репутация: 78 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, прошу прощения, если зря принял примечание за разрешение отвечать.
Если я правильно разобрался в нагромождении придаточных, то
Код
=ВПР(B1;$L$1:$M$673;2)


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
Сообщение_Boroda_, прошу прощения, если зря принял примечание за разрешение отвечать.
Если я правильно разобрался в нагромождении придаточных, то
Код
=ВПР(B1;$L$1:$M$673;2)

Автор - StoTisteg
Дата добавления - 28.05.2018 в 11:49
StoTisteg Дата: Понедельник, 28.05.2018, 11:50 | Сообщение № 5
Группа: Авторы
Ранг: Ветеран
Сообщений: 916
Репутация: 78 ±
Замечаний: 0% ±

Excel 2010
Но ни одного значения не найдено

Не, первое нашлось.


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
Сообщение
Но ни одного значения не найдено

Не, первое нашлось.

Автор - StoTisteg
Дата добавления - 28.05.2018 в 11:50
_Boroda_ Дата: Понедельник, 28.05.2018, 11:53 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12744
Репутация: 5226 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не, первое нашлось

Конечно, если ВПР без четвертого аргумента написать, не то еще найдется :D

=ВПР(B1;$L$1:$M$673;2)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Не, первое нашлось

Конечно, если ВПР без четвертого аргумента написать, не то еще найдется :D

=ВПР(B1;$L$1:$M$673;2)

Автор - _Boroda_
Дата добавления - 28.05.2018 в 11:53
slayge_nare Дата: Понедельник, 28.05.2018, 11:59 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, возможно потому что строки не совпадают,переделал документ суть вот в чем у меня есть первый лист артикул(зеленый столбик) и код товара (желтый) на втором листе необходимо найти такой же артикул в синем и подставить значение(код товара) из красного (лист2) в желтый (Лист1),я так понимаю значения из красного и синего это массив и поиск необходим по нему
К сообщению приложен файл: 7152737.xls(58.0 Kb)
 
Ответить
Сообщение_Boroda_, возможно потому что строки не совпадают,переделал документ суть вот в чем у меня есть первый лист артикул(зеленый столбик) и код товара (желтый) на втором листе необходимо найти такой же артикул в синем и подставить значение(код товара) из красного (лист2) в желтый (Лист1),я так понимаю значения из красного и синего это массив и поиск необходим по нему

Автор - slayge_nare
Дата добавления - 28.05.2018 в 11:59
sboy Дата: Понедельник, 28.05.2018, 12:06 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 2013
Репутация: 576 ±
Замечаний: 0% ±

Excel 2010
как на фоне черного из красного быстро сделать белое

:)
если правильно понял про цвета
Код
=ВПР(B1;ВЫБОР({1;2};Лист2!$B$1:$B$672;Лист2!$A$1:$A$672);2;)
 
Ответить
Сообщение
как на фоне черного из красного быстро сделать белое

:)
если правильно понял про цвета
Код
=ВПР(B1;ВЫБОР({1;2};Лист2!$B$1:$B$672;Лист2!$A$1:$A$672);2;)

Автор - sboy
Дата добавления - 28.05.2018 в 12:06
slayge_nare Дата: Понедельник, 28.05.2018, 12:18 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, отлично работает,помоги доработать на втором листе есть некоторые значения прописаные через дробь,как с ними быть,т.е найти совпадение по 6 значному числу и подставить?
 
Ответить
Сообщениеsboy, отлично работает,помоги доработать на втором листе есть некоторые значения прописаные через дробь,как с ними быть,т.е найти совпадение по 6 значному числу и подставить?

Автор - slayge_nare
Дата добавления - 28.05.2018 в 12:18
sboy Дата: Понедельник, 28.05.2018, 13:07 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 2013
Репутация: 576 ±
Замечаний: 0% ±

Excel 2010
так у Вас там не только дробь и не только 6значные числа
411180, 411181
801150, FG-04А2078-1
T194-26011
 
Ответить
Сообщениетак у Вас там не только дробь и не только 6значные числа
411180, 411181
801150, FG-04А2078-1
T194-26011

Автор - sboy
Дата добавления - 28.05.2018 в 13:07
StoTisteg Дата: Понедельник, 28.05.2018, 14:00 | Сообщение № 11
Группа: Авторы
Ранг: Ветеран
Сообщений: 916
Репутация: 78 ±
Замечаний: 0% ±

Excel 2010
Конечно, если ВПР без четвертого аргумента написать, не то еще найдется

[offtop]Ну не формулист я :)


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
Сообщение
Конечно, если ВПР без четвертого аргумента написать, не то еще найдется

[offtop]Ну не формулист я :)

Автор - StoTisteg
Дата добавления - 28.05.2018 в 14:00
slayge_nare Дата: Суббота, 02.06.2018, 08:09 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ребят всем огромная благодарность за помощь в решении вопроса,прям вот как жизнь спасли)теперь 15 человек довольны данным решением,ходют ахают и охают)
 
Ответить
СообщениеРебят всем огромная благодарность за помощь в решении вопроса,прям вот как жизнь спасли)теперь 15 человек довольны данным решением,ходют ахают и охают)

Автор - slayge_nare
Дата добавления - 02.06.2018 в 08:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!