Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование календаря платежей клиентов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование календаря платежей клиентов (Формулы/Formulas)
Формирование календаря платежей клиентов
shon87 Дата: Вторник, 29.05.2018, 11:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Возможно, кто-то знает как решить задачу:
Есть выгрузка биллинга (более 100 тыс записей), представляет собой дату списания и номер абонента, у которого произошло списание. Поскольку тарификация ежедневная, то за месяц каждый номер может встретиться от 1 до 31 раза (месяц январь).
Рядом с данными в строку растянул даты с 1 по 31 интересующего периода. В столбец указаны уникальные номера абонентов. Необходима формула или условное форматирование с формулой, чтобы для каждого номера закрасились ячейки в ту дату, когда было списание. Во вложении файл-образец, того как хотелось бы видеть итоговый результат.

Пробовал сделать диаграммой ганта, но выделились ячейки подряд равные количеству списаний за период. Это не совсем то, что нужно. Будет очень круто, если кто-то знает как решить такую задачу.
К сообщению приложен файл: 7317012.xlsx(12.4 Kb)


Сообщение отредактировал shon87 - Вторник, 29.05.2018, 11:23
 
Ответить
СообщениеДобрый день! Возможно, кто-то знает как решить задачу:
Есть выгрузка биллинга (более 100 тыс записей), представляет собой дату списания и номер абонента, у которого произошло списание. Поскольку тарификация ежедневная, то за месяц каждый номер может встретиться от 1 до 31 раза (месяц январь).
Рядом с данными в строку растянул даты с 1 по 31 интересующего периода. В столбец указаны уникальные номера абонентов. Необходима формула или условное форматирование с формулой, чтобы для каждого номера закрасились ячейки в ту дату, когда было списание. Во вложении файл-образец, того как хотелось бы видеть итоговый результат.

Пробовал сделать диаграммой ганта, но выделились ячейки подряд равные количеству списаний за период. Это не совсем то, что нужно. Будет очень круто, если кто-то знает как решить такую задачу.

Автор - shon87
Дата добавления - 29.05.2018 в 11:22
_Boroda_ Дата: Вторник, 29.05.2018, 11:30 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12399
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
На 100000 быстрее будет сводной таблицей с группировкой и фильтром по дате
К сообщению приложен файл: 7317012_1.xlsx(18.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНа 100000 быстрее будет сводной таблицей с группировкой и фильтром по дате

Автор - _Boroda_
Дата добавления - 29.05.2018 в 11:30
sboy Дата: Вторник, 29.05.2018, 11:31 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1861
Репутация: 535 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Условным форматированием
Код
=ПОИСКПОЗ($D2&E$1;$B$2:$B$13&$A$2:$A$13;)
К сообщению приложен файл: 4867970.xlsx(11.3 Kb)
 
Ответить
СообщениеДобрый день.
Условным форматированием
Код
=ПОИСКПОЗ($D2&E$1;$B$2:$B$13&$A$2:$A$13;)

Автор - sboy
Дата добавления - 29.05.2018 в 11:31
китин Дата: Вторник, 29.05.2018, 11:31 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4885
Репутация: 781 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула в УФ
Код
=СУММПРОИЗВ((E$1=$A$2:$A$13)*($D2=$B$2:$B$13))=1
К сообщению приложен файл: shon87.xlsx(12.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеформула в УФ
Код
=СУММПРОИЗВ((E$1=$A$2:$A$13)*($D2=$B$2:$B$13))=1

Автор - китин
Дата добавления - 29.05.2018 в 11:31
shon87 Дата: Вторник, 29.05.2018, 12:02 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем, кто откликнулся! Очень быстро, очень круто! Вопрос решен.
 
Ответить
СообщениеСпасибо всем, кто откликнулся! Очень быстро, очень круто! Вопрос решен.

Автор - shon87
Дата добавления - 29.05.2018 в 12:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование календаря платежей клиентов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!