Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как оставить таблицы в разных книгах связанными. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как оставить таблицы в разных книгах связанными. (Формулы/Formulas)
Как оставить таблицы в разных книгах связанными.
KrosTj Дата: Пятница, 01.06.2018, 13:04 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую. Прошу помощи. Есть книга, в которой данные в таблице имеют связи с таблицами из других книг. Проблема в том, что при закрытий книг-серверов в ячейках книги-клиента с основной таблицей при обновлении клеток возникает ошибка ССЫЛКА, даже при условии, что для каждой клетки ексель автоматически прописывает абсолютный путь. Подскажите как быть, в параметрах в разделе безопасности вроде поставил галочку на автоматическое обновление связей.
 
Ответить
СообщениеПриветствую. Прошу помощи. Есть книга, в которой данные в таблице имеют связи с таблицами из других книг. Проблема в том, что при закрытий книг-серверов в ячейках книги-клиента с основной таблицей при обновлении клеток возникает ошибка ССЫЛКА, даже при условии, что для каждой клетки ексель автоматически прописывает абсолютный путь. Подскажите как быть, в параметрах в разделе безопасности вроде поставил галочку на автоматическое обновление связей.

Автор - KrosTj
Дата добавления - 01.06.2018 в 13:04
_Boroda_ Дата: Пятница, 01.06.2018, 13:40 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12353
Репутация: 5079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
данные в таблице имеют связи с таблицами из других книг

А это смотря как Вы связи прописали. Покажите кусочек таблицы со связями


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
данные в таблице имеют связи с таблицами из других книг

А это смотря как Вы связи прописали. Покажите кусочек таблицы со связями

Автор - _Boroda_
Дата добавления - 01.06.2018 в 13:40
KrosTj Дата: Пятница, 01.06.2018, 14:46 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Вот создал маленькую демку. Связи с реальными внешними книгами не делал, но создал вкладки, которые пусть будут якобы другими книгами, а первая вкладка это та книга, где собираются все данные. Схожие по составу формулы я прописал. Изначально задача стояла так, что есть множество книг, с которых нужно собрать всю информацию в одну таблицу, чтобы всё было видно, я организовал это так как в этом файле с ВПР, посмотрите может что-то более эффективное есть.
К сообщению приложен файл: Example.xlsx(19.4 Kb)
 
Ответить
Сообщение_Boroda_, Вот создал маленькую демку. Связи с реальными внешними книгами не делал, но создал вкладки, которые пусть будут якобы другими книгами, а первая вкладка это та книга, где собираются все данные. Схожие по составу формулы я прописал. Изначально задача стояла так, что есть множество книг, с которых нужно собрать всю информацию в одну таблицу, чтобы всё было видно, я организовал это так как в этом файле с ВПР, посмотрите может что-то более эффективное есть.

Автор - KrosTj
Дата добавления - 01.06.2018 в 14:46
_Boroda_ Дата: Пятница, 01.06.2018, 14:59 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12353
Репутация: 5079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если Вы уберете ссылки на умные таблицы и запишете диапазон для поиска обычными ссялками ($A$2:$B$999), то по идее должно работать с закрытыми книгами
Примерно вот так
Код
=ВПР(C$1; ВЫБОР($A3; 'G:\Моя\Стереть\[Серв_1.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_2.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_3.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_4.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_5.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_6.xlsm]Лист1'!$A$2:$B$999); 2;0)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли Вы уберете ссылки на умные таблицы и запишете диапазон для поиска обычными ссялками ($A$2:$B$999), то по идее должно работать с закрытыми книгами
Примерно вот так
Код
=ВПР(C$1; ВЫБОР($A3; 'G:\Моя\Стереть\[Серв_1.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_2.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_3.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_4.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_5.xlsm]Лист1'!$A$2:$B$999; 'G:\Моя\Стереть\[Серв_6.xlsm]Лист1'!$A$2:$B$999); 2;0)

Автор - _Boroda_
Дата добавления - 01.06.2018 в 14:59
KrosTj Дата: Пятница, 01.06.2018, 15:55 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, благодарю, работает, а не подскажешь в чём проблема таких ссылок?
 
Ответить
Сообщение_Boroda_, благодарю, работает, а не подскажешь в чём проблема таких ссылок?

Автор - KrosTj
Дата добавления - 01.06.2018 в 15:55
_Boroda_ Дата: Пятница, 01.06.2018, 16:06 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12353
Репутация: 5079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В том, что они не работают с закрытыми книгами


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ том, что они не работают с закрытыми книгами

Автор - _Boroda_
Дата добавления - 01.06.2018 в 16:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как оставить таблицы в разных книгах связанными. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!