Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование сводной таблицы по двум условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование сводной таблицы по двум условиям (Формулы/Formulas)
Формирование сводной таблицы по двум условиям
SGromov Дата: Воскресенье, 03.06.2018, 19:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, друзья!

Обыскал весь форум, но ответа на свой вопрос, к сожалению, я не нашел.

Суть следующая:
1. На отдельной вкладке есть главная таблица (назовем её БД - База Данных);
2. Во второй вкладке необходимо чтобы формировалась таблица, содержащая значения только тех строк, которые соответствуют двум условиям из первой.

В моем примере есть аналогичная задача с одним условием, которую я выполняю следующим образом (вкладка Ruski_одно условие):
Код
{=ИНДЕКС(БД!I$1:I$100;НАИМЕНЬШИЙ(ЕСЛИ(БД!$L$1:$L$100=1;СТРОКА(БД!$L$1:$L$100));СТРОКА(БД!I1)))}


В данной вкладке формируется таблица только из тех строк, значения в столбце L которых равно единице.

Когда я пытаюсь сделать так, чтобы он выводил значения еще и только тех строк, где повсеместно единица есть в L и С столбцах, то он понимает что я хочу (ошибку не выдает), но и значения тоже выдавать не хочет...
Пытаюсь я это сделать подставляя формулу И (вкладка Ruski_два):
Код
{=ИНДЕКС(БД!I$1:I$100;И(НАИМЕНЬШИЙ(ЕСЛИ(БД!$L$1:$L$100=1;СТРОКА(БД!$L$1:$L$100));СТРОКА(БД!I1));НАИМЕНЬШИЙ(ЕСЛИ(БД!$C$1:$C$100=1;СТРОКА(БД!$C$1:$C$100));СТРОКА(БД!I1))))}


Что я делаю не так? уже всю голову сломал(

Большое спасибо заранее!
К сообщению приложен файл: 6676707.xlsx(18.1 Kb)
 
Ответить
СообщениеДобрый день, друзья!

Обыскал весь форум, но ответа на свой вопрос, к сожалению, я не нашел.

Суть следующая:
1. На отдельной вкладке есть главная таблица (назовем её БД - База Данных);
2. Во второй вкладке необходимо чтобы формировалась таблица, содержащая значения только тех строк, которые соответствуют двум условиям из первой.

В моем примере есть аналогичная задача с одним условием, которую я выполняю следующим образом (вкладка Ruski_одно условие):
Код
{=ИНДЕКС(БД!I$1:I$100;НАИМЕНЬШИЙ(ЕСЛИ(БД!$L$1:$L$100=1;СТРОКА(БД!$L$1:$L$100));СТРОКА(БД!I1)))}


В данной вкладке формируется таблица только из тех строк, значения в столбце L которых равно единице.

Когда я пытаюсь сделать так, чтобы он выводил значения еще и только тех строк, где повсеместно единица есть в L и С столбцах, то он понимает что я хочу (ошибку не выдает), но и значения тоже выдавать не хочет...
Пытаюсь я это сделать подставляя формулу И (вкладка Ruski_два):
Код
{=ИНДЕКС(БД!I$1:I$100;И(НАИМЕНЬШИЙ(ЕСЛИ(БД!$L$1:$L$100=1;СТРОКА(БД!$L$1:$L$100));СТРОКА(БД!I1));НАИМЕНЬШИЙ(ЕСЛИ(БД!$C$1:$C$100=1;СТРОКА(БД!$C$1:$C$100));СТРОКА(БД!I1))))}


Что я делаю не так? уже всю голову сломал(

Большое спасибо заранее!

Автор - SGromov
Дата добавления - 03.06.2018 в 19:23
Nic70y Дата: Воскресенье, 03.06.2018, 19:40 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4676
Репутация: 1007 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(БД!I$4:I$100;НАИМЕНЬШИЙ(ЕСЛИ((БД!$L$4:$L$100=1)*(БД!$C$4:$C$100=1);СТРОКА(БД!$A$4:$A$100)-3);СТРОКА(A1)))
К сообщению приложен файл: 6866386.xlsx(18.2 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС(БД!I$4:I$100;НАИМЕНЬШИЙ(ЕСЛИ((БД!$L$4:$L$100=1)*(БД!$C$4:$C$100=1);СТРОКА(БД!$A$4:$A$100)-3);СТРОКА(A1)))

Автор - Nic70y
Дата добавления - 03.06.2018 в 19:40
SGromov Дата: Воскресенье, 03.06.2018, 20:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное спасибо!!! hands

То что нужно! А то я всю голову сломал...
Если бы еще знать как и почему это работает... но это уже наверное слишком нагло с моей стороны будет спрашивать)

Спасибо еще раз, + к карме)
 
Ответить
СообщениеОгромное спасибо!!! hands

То что нужно! А то я всю голову сломал...
Если бы еще знать как и почему это работает... но это уже наверное слишком нагло с моей стороны будет спрашивать)

Спасибо еще раз, + к карме)

Автор - SGromov
Дата добавления - 03.06.2018 в 20:07
_Boroda_ Дата: Воскресенье, 03.06.2018, 21:03 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12399
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так это то же самое, что и в Вашей первой формуле
А если написать вот так, то более понятно будет?
Код
=ЕСЛИОШИБКА(ИНДЕКС(БД!I:I;НАИМЕНЬШИЙ(ЕСЛИ((БД!$L$4:$L$100&"_"&БД!$C$4:$C$100="1_1");СТРОКА(БД!$A$4:$A$100));СТРОКА(A1)));"")

В Вашем варианте для одного условия было написано БД!$L$1:$L$100, а здесь мы склеиваем через нижнее подчеркивание столбцы L и С БД!$L$4:$L$100&"_"&БД!$C$4:$C$100. Вы приравнивали к единице, мы теперь приравниваем к "1_1". Остальное все аналогично, кроме того, что в коэффициенте НАИМЕНЬНИЙ не нужно давать ссылку на лист БД СТРОКА(БД!I1) - если вдруг там будут вставляться/удаляться строки, то Ваша формула может поплыть.
К сообщению приложен файл: 6676707_1.xlsx(18.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак это то же самое, что и в Вашей первой формуле
А если написать вот так, то более понятно будет?
Код
=ЕСЛИОШИБКА(ИНДЕКС(БД!I:I;НАИМЕНЬШИЙ(ЕСЛИ((БД!$L$4:$L$100&"_"&БД!$C$4:$C$100="1_1");СТРОКА(БД!$A$4:$A$100));СТРОКА(A1)));"")

В Вашем варианте для одного условия было написано БД!$L$1:$L$100, а здесь мы склеиваем через нижнее подчеркивание столбцы L и С БД!$L$4:$L$100&"_"&БД!$C$4:$C$100. Вы приравнивали к единице, мы теперь приравниваем к "1_1". Остальное все аналогично, кроме того, что в коэффициенте НАИМЕНЬНИЙ не нужно давать ссылку на лист БД СТРОКА(БД!I1) - если вдруг там будут вставляться/удаляться строки, то Ваша формула может поплыть.

Автор - _Boroda_
Дата добавления - 03.06.2018 в 21:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование сводной таблицы по двум условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!