Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка данных при сопоставлении значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка данных при сопоставлении значений (Формулы/Formulas)
Подстановка данных при сопоставлении значений
Иваныч77 Дата: Вторник, 05.06.2018, 07:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Помогите, пожалуйста с формулой. Нужна подстановка значений из листа с данными в лист расчета. Ранее делали расчет на 3 и 4 м, все нормально. появилась необходимость расширения данных и что-то не клеится(
К сообщению приложен файл: 7605147.xlsx(13.9 Kb)
 
Ответить
СообщениеПомогите, пожалуйста с формулой. Нужна подстановка значений из листа с данными в лист расчета. Ранее делали расчет на 3 и 4 м, все нормально. появилась необходимость расширения данных и что-то не клеится(

Автор - Иваныч77
Дата добавления - 05.06.2018 в 07:29
китин Дата: Вторник, 05.06.2018, 07:34 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам здравствуйте!!!
так?
Код
=ИНДЕКС(кубатура!$B$3:$F$49;ПОИСКПОЗ(расчет!$B2;кубатура!$A$3:$A$49;0);ПОИСКПОЗ(расчет!$A2;кубатура!$B$1:$F$1;0))
К сообщению приложен файл: 77.xlsx(14.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 05.06.2018, 07:36
 
Ответить
Сообщениеи вам здравствуйте!!!
так?
Код
=ИНДЕКС(кубатура!$B$3:$F$49;ПОИСКПОЗ(расчет!$B2;кубатура!$A$3:$A$49;0);ПОИСКПОЗ(расчет!$A2;кубатура!$B$1:$F$1;0))

Автор - китин
Дата добавления - 05.06.2018 в 07:34
Иваныч77 Дата: Вторник, 05.06.2018, 07:44 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
ОК, работает. Огромное спасибо. hands
 
Ответить
СообщениеОК, работает. Огромное спасибо. hands

Автор - Иваныч77
Дата добавления - 05.06.2018 в 07:44
_Boroda_ Дата: Вторник, 05.06.2018, 07:53 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13245
Репутация: 5454 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Код
=СУММПРОИЗВ(кубатура!B$3:F$49*(кубатура!A$3:A$49=B2)*(кубатура!B$1:F$1=A2))

Код
=ВПР(B2;кубатура;ПОИСКПОЗ(A2;кубатура!A$1:F$1;);)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Код
=СУММПРОИЗВ(кубатура!B$3:F$49*(кубатура!A$3:A$49=B2)*(кубатура!B$1:F$1=A2))

Код
=ВПР(B2;кубатура;ПОИСКПОЗ(A2;кубатура!A$1:F$1;);)

Автор - _Boroda_
Дата добавления - 05.06.2018 в 07:53
Narahon Дата: Вторник, 05.06.2018, 16:54 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! 2 недели пытаюсь решить задачу, которую сам перед собой поставил, но так до сих пор и не получилось.

Есть документ, который состоит из двух листов, на одном листе поля ввода данных (титульный лист) на втором - некая база данных о клиентах.

Задача стоит следующая, сделать так, чтобы при вводе в определенные ячейки на выбор (их три: телефон, гос. номер, паспорт) excel искал это значение в "базе" и если бы находил, то во все остальные ячейки подставлял данные от нужного клиента

В целом, у меня получилось сделать это по одному значению, если добавить второе или третье, то появляется ошибка зациклинности.

Логику я понимаю, а вот с формулой какая-то беда...

Нужно найти (я делал через индекс и поискпоз) номер телефона и если нашел, то вставить в нужные ячейки нужные данные, если телефон не нашел, то искать по паспорту, если всё норм, то вставить, если нет, то искать по гос. номеру, если норм, то вставить, если нет, то оставить пустым.

Но так как все ячейки должны быть свободны для ввода, то формулы я вставлял через макрос (не уверен, что это правильно)

Надеюсь объяснил нормально)

Файл примера вложил, темно-синим помечены ячейки, по которым ведётся поиск
К сообщению приложен файл: primer.xlsx(13.2 Kb)
 
Ответить
СообщениеЗдравствуйте! 2 недели пытаюсь решить задачу, которую сам перед собой поставил, но так до сих пор и не получилось.

Есть документ, который состоит из двух листов, на одном листе поля ввода данных (титульный лист) на втором - некая база данных о клиентах.

Задача стоит следующая, сделать так, чтобы при вводе в определенные ячейки на выбор (их три: телефон, гос. номер, паспорт) excel искал это значение в "базе" и если бы находил, то во все остальные ячейки подставлял данные от нужного клиента

В целом, у меня получилось сделать это по одному значению, если добавить второе или третье, то появляется ошибка зациклинности.

Логику я понимаю, а вот с формулой какая-то беда...

Нужно найти (я делал через индекс и поискпоз) номер телефона и если нашел, то вставить в нужные ячейки нужные данные, если телефон не нашел, то искать по паспорту, если всё норм, то вставить, если нет, то искать по гос. номеру, если норм, то вставить, если нет, то оставить пустым.

Но так как все ячейки должны быть свободны для ввода, то формулы я вставлял через макрос (не уверен, что это правильно)

Надеюсь объяснил нормально)

Файл примера вложил, темно-синим помечены ячейки, по которым ведётся поиск

Автор - Narahon
Дата добавления - 05.06.2018 в 16:54
_Boroda_ Дата: Вторник, 05.06.2018, 16:55 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13245
Репутация: 5454 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума

Автор - _Boroda_
Дата добавления - 05.06.2018 в 16:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка данных при сопоставлении значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!