Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как преобразовать количество часов в минуты формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как преобразовать количество часов в минуты формулой (Формулы/Formulas)
Как преобразовать количество часов в минуты формулой
adilkarim Дата: Среда, 06.06.2018, 12:23 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте.
Подскажите формулу, чтобы формат 1h 7m 4s преобразовать просто в количество минут 1h 7m 4s = 67,4
http://joxi.ru/l2Zbb31iwENxR2
К сообщению приложен файл: CDR.xlsx(12.0 Kb)
 
Ответить
СообщениеЗдравствуйте.
Подскажите формулу, чтобы формат 1h 7m 4s преобразовать просто в количество минут 1h 7m 4s = 67,4
http://joxi.ru/l2Zbb31iwENxR2

Автор - adilkarim
Дата добавления - 06.06.2018 в 12:23
ShAM Дата: Среда, 06.06.2018, 13:47 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1249
Репутация: 212 ±
Замечаний: 0% ±

Excel 2010
А Вы уверены, что 1h 7m 4s = 67,4 минуты?
 
Ответить
СообщениеА Вы уверены, что 1h 7m 4s = 67,4 минуты?

Автор - ShAM
Дата добавления - 06.06.2018 в 13:47
Светлый Дата: Среда, 06.06.2018, 13:51 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 477
Репутация: 110 ±
Замечаний: 0% ±

Excel 2007
Если в десятых долях, то формула:
Код
=ЕСЛИ(ЕОШ(ПОИСК("h ";D2));;ЛЕВБ(D2;ПОИСК("h ";D2)-1))*60+ЕСЛИ(ЕОШ(ПОИСК("m ";D2));;ПСТР(D2;ПОИСК("m ";D2)-2;2))+ЕСЛИ(ЕОШ(ПОИСК("s";D2));;ЛЕВБ(ПРАВБ(D2;3);2)/60)

Если секунды, то:
Код
=ЕСЛИ(ЕОШ(ПОИСК("h ";D2));;ЛЕВБ(D2;ПОИСК("h ";D2)-1))*60+ЕСЛИ(ЕОШ(ПОИСК("m ";D2));;ПСТР(D2;ПОИСК("m ";D2)-2;2))&":"&--ЕСЛИ(ЕОШ(ПОИСК("s";D2));;ЛЕВБ(ПРАВБ(D2;3);2))

А если бы всё было в одинаковом формате "0h 0m 0s", то сработала бы формула:
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(D2;"s";"");"m ";":");"h ";":")*1440


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 06.06.2018, 13:57
 
Ответить
СообщениеЕсли в десятых долях, то формула:
Код
=ЕСЛИ(ЕОШ(ПОИСК("h ";D2));;ЛЕВБ(D2;ПОИСК("h ";D2)-1))*60+ЕСЛИ(ЕОШ(ПОИСК("m ";D2));;ПСТР(D2;ПОИСК("m ";D2)-2;2))+ЕСЛИ(ЕОШ(ПОИСК("s";D2));;ЛЕВБ(ПРАВБ(D2;3);2)/60)

Если секунды, то:
Код
=ЕСЛИ(ЕОШ(ПОИСК("h ";D2));;ЛЕВБ(D2;ПОИСК("h ";D2)-1))*60+ЕСЛИ(ЕОШ(ПОИСК("m ";D2));;ПСТР(D2;ПОИСК("m ";D2)-2;2))&":"&--ЕСЛИ(ЕОШ(ПОИСК("s";D2));;ЛЕВБ(ПРАВБ(D2;3);2))

А если бы всё было в одинаковом формате "0h 0m 0s", то сработала бы формула:
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(D2;"s";"");"m ";":");"h ";":")*1440

Автор - Светлый
Дата добавления - 06.06.2018 в 13:51
KrosTj Дата: Среда, 06.06.2018, 13:57 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Формула в прикреплённом файле. Создан столбец рядом. Отображает и минуты и секунды.
К сообщению приложен файл: 0789566.xlsx(13.7 Kb)


Сообщение отредактировал KrosTj - Среда, 06.06.2018, 13:58
 
Ответить
СообщениеФормула в прикреплённом файле. Создан столбец рядом. Отображает и минуты и секунды.

Автор - KrosTj
Дата добавления - 06.06.2018 в 13:57
adilkarim Дата: Среда, 06.06.2018, 14:00 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем спасибо. Все решили
 
Ответить
СообщениеВсем спасибо. Все решили

Автор - adilkarim
Дата добавления - 06.06.2018 в 14:00
_Boroda_ Дата: Среда, 06.06.2018, 14:02 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12399
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня такой вариант
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(" "&СЖПРОБЕЛЫ(ЛЕВБ(D2;ДЛСТР(D2)-3));ТЕКСТ(1-ВРЕМЯ(;СТРОКА($1:$1441)-1;);" чh мm"));1441-СТРОКА($1:$1440));)+ЛЕВБ(ПРАВБ(0&D2;3);2)%

Если секунды в десятых долях, то
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(" "&СЖПРОБЕЛЫ(ЛЕВБ(D2;ДЛСТР(D2)-3));ТЕКСТ(1-ВРЕМЯ(;СТРОКА($1:$1441)-1;);" чh мm"));1441-СТРОКА($1:$1440));)+ЛЕВБ(ПРАВБ(0&D2;3);2)/60


Всем спасибо. Все решили

Вы уверены?
Обратите внимание на время типа "7m 14s"
К сообщению приложен файл: CDR_1.xlsx(17.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня такой вариант
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(" "&СЖПРОБЕЛЫ(ЛЕВБ(D2;ДЛСТР(D2)-3));ТЕКСТ(1-ВРЕМЯ(;СТРОКА($1:$1441)-1;);" чh мm"));1441-СТРОКА($1:$1440));)+ЛЕВБ(ПРАВБ(0&D2;3);2)%

Если секунды в десятых долях, то
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(" "&СЖПРОБЕЛЫ(ЛЕВБ(D2;ДЛСТР(D2)-3));ТЕКСТ(1-ВРЕМЯ(;СТРОКА($1:$1441)-1;);" чh мm"));1441-СТРОКА($1:$1440));)+ЛЕВБ(ПРАВБ(0&D2;3);2)/60


Всем спасибо. Все решили

Вы уверены?
Обратите внимание на время типа "7m 14s"

Автор - _Boroda_
Дата добавления - 06.06.2018 в 14:02
adilkarim Дата: Пятница, 08.06.2018, 12:44 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, да действительно. Так лучше, а в том случае была ошибка http://joxi.ru/n2YbbYnioZKO7A

Спасибо
 
Ответить
Сообщение_Boroda_, да действительно. Так лучше, а в том случае была ошибка http://joxi.ru/n2YbbYnioZKO7A

Спасибо

Автор - adilkarim
Дата добавления - 08.06.2018 в 12:44
AlexM Дата: Пятница, 08.06.2018, 13:39 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3741
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
Формулы без массивов
Код
=(ПСТР(0&D2&"00h";ПОИСК("??h";0&D2&"00h");2)&":"&ПСТР(0&D2&"00m";ПОИСК("??m";0&D2&"00m");2)&":"&ПСТР(0&D2&"00s";ПОИСК("??s";0&D2&"00s");2))*1440
Если секунды в десятых долях, то
Код
=(ПСТР(0&D2&"00h";ПОИСК("??h";0&D2&"00h");2)&":"&ПСТР(0&D2&"00m";ПОИСК("??m";0&D2&"00m");2))*1440+ПСТР(0&D2&"00s";ПОИСК("??s";0&D2&"00s");2)%
К сообщению приложен файл: CDR_01.xlsx(14.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормулы без массивов
Код
=(ПСТР(0&D2&"00h";ПОИСК("??h";0&D2&"00h");2)&":"&ПСТР(0&D2&"00m";ПОИСК("??m";0&D2&"00m");2)&":"&ПСТР(0&D2&"00s";ПОИСК("??s";0&D2&"00s");2))*1440
Если секунды в десятых долях, то
Код
=(ПСТР(0&D2&"00h";ПОИСК("??h";0&D2&"00h");2)&":"&ПСТР(0&D2&"00m";ПОИСК("??m";0&D2&"00m");2))*1440+ПСТР(0&D2&"00s";ПОИСК("??s";0&D2&"00s");2)%

Автор - AlexM
Дата добавления - 08.06.2018 в 13:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как преобразовать количество часов в минуты формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!