Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/В ячейках оставить большее значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В ячейках оставить большее значение (Формулы/Formulas)
В ячейках оставить большее значение
Aimod Дата: Пятница, 08.06.2018, 11:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, уважаемые помогающие!
Пожалуйста, подскажите, как оставить в ячейках для ГВС бОльшее из значений в верхней строчке столбца В, а для ЦО бОльшее из значений в нижней строчке столбца В, учитывая, что некоторые ячейки столбца В содержат всего одну строчку, и в них тоже нужно оставить бОльшее из значений...?
К сообщению приложен файл: 6-.xlsx(26.4 Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые помогающие!
Пожалуйста, подскажите, как оставить в ячейках для ГВС бОльшее из значений в верхней строчке столбца В, а для ЦО бОльшее из значений в нижней строчке столбца В, учитывая, что некоторые ячейки столбца В содержат всего одну строчку, и в них тоже нужно оставить бОльшее из значений...?

Автор - Aimod
Дата добавления - 08.06.2018 в 11:14
alexa1965 Дата: Пятница, 08.06.2018, 11:50 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 3 ±
Замечаний: 0% ±

2003, 2010
А как понять что конкретное значение больше, посчитать математически? или какой то другой критерий?


Главное не быть балабастиком
 
Ответить
СообщениеА как понять что конкретное значение больше, посчитать математически? или какой то другой критерий?

Автор - alexa1965
Дата добавления - 08.06.2018 в 11:50
sboy Дата: Пятница, 08.06.2018, 11:56 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вариант на Power Query
К сообщению приложен файл: 4574844.xlsx(56.6 Kb)
 
Ответить
СообщениеДобрый день.
Вариант на Power Query

Автор - sboy
Дата добавления - 08.06.2018 в 11:56
Aimod Дата: Пятница, 08.06.2018, 12:06 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
А как понять что конкретное значение больше, посчитать математически? или какой то другой критерий?
Я не знаю, наверное математически.. Макрос бы я точно сохранил

sboy, Спасибо!

PS: Почему я не могу плюсануть репутацию помогающим? Сайт говорит, что форма заполнена неправильно, а как правильно заполнить?
PPS: О-о, спс! " Ураа, заработало!" (с)


Сообщение отредактировал Aimod - Пятница, 08.06.2018, 13:19
 
Ответить
Сообщение
А как понять что конкретное значение больше, посчитать математически? или какой то другой критерий?
Я не знаю, наверное математически.. Макрос бы я точно сохранил

sboy, Спасибо!

PS: Почему я не могу плюсануть репутацию помогающим? Сайт говорит, что форма заполнена неправильно, а как правильно заполнить?
PPS: О-о, спс! " Ураа, заработало!" (с)

Автор - Aimod
Дата добавления - 08.06.2018 в 12:06
abtextime Дата: Пятница, 08.06.2018, 12:53 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(A1="ГВС";MaxS(ЛЕВБ(B1;НАЙТИ(СИМВОЛ(10);B1)-1));ЕСЛИ(ПОДСТАВИТЬ(B1;СИМВОЛ(10);"")=B1;MaxS(B1);MaxS(ПРАВБ(B1;ДЛСТР(B1)-НАЙТИ(СИМВОЛ(10);B1)))))


UDF

[vba]
Код
Public Function MaxS(S As String) As Long
    Tail = Trim(S)
    If Right(Tail, 1) = Chr(10) Then Tail = Left(Tail, Len(Tail) - 1)
    Tail = Tail & "/"
    Do While Tail <> ""
        NextNum = CLng(Left(Tail, InStr(Tail, "/") - 1))
        Tail = Replace(Tail, CStr(NextNum) & "/", "")
        MaxS = Application.WorksheetFunction.Max(NextNum, MaxS)
    Loop
End Function
[/vba]
К сообщению приложен файл: 6-.xlsm(34.8 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(A1="ГВС";MaxS(ЛЕВБ(B1;НАЙТИ(СИМВОЛ(10);B1)-1));ЕСЛИ(ПОДСТАВИТЬ(B1;СИМВОЛ(10);"")=B1;MaxS(B1);MaxS(ПРАВБ(B1;ДЛСТР(B1)-НАЙТИ(СИМВОЛ(10);B1)))))


UDF

[vba]
Код
Public Function MaxS(S As String) As Long
    Tail = Trim(S)
    If Right(Tail, 1) = Chr(10) Then Tail = Left(Tail, Len(Tail) - 1)
    Tail = Tail & "/"
    Do While Tail <> ""
        NextNum = CLng(Left(Tail, InStr(Tail, "/") - 1))
        Tail = Replace(Tail, CStr(NextNum) & "/", "")
        MaxS = Application.WorksheetFunction.Max(NextNum, MaxS)
    Loop
End Function
[/vba]

Автор - abtextime
Дата добавления - 08.06.2018 в 12:53
Aimod Дата: Пятница, 08.06.2018, 13:17 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
abtextime, спасибо!
 
Ответить
Сообщениеabtextime, спасибо!

Автор - Aimod
Дата добавления - 08.06.2018 в 13:17
_Boroda_ Дата: Пятница, 08.06.2018, 22:17 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12761
Репутация: 5228 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Просто формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=МАКС(ЕСЛИОШИБКА(--(ПСТР(ПОДСТАВИТЬ("/"&ЕСЛИОШИБКА(ЗАМЕНИТЬ(B1;ПОИСК(СИМВОЛ(10);B1)^(A1="ГВС");ЕСЛИ(A1="ЦО";ПОИСК(СИМВОЛ(10);B1);99););B1);"/";ПОВТОР(" ";99));99*СТРОКА($1:$8);99));))
К сообщению приложен файл: 6-1.xlsx(71.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПросто формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=МАКС(ЕСЛИОШИБКА(--(ПСТР(ПОДСТАВИТЬ("/"&ЕСЛИОШИБКА(ЗАМЕНИТЬ(B1;ПОИСК(СИМВОЛ(10);B1)^(A1="ГВС");ЕСЛИ(A1="ЦО";ПОИСК(СИМВОЛ(10);B1);99););B1);"/";ПОВТОР(" ";99));99*СТРОКА($1:$8);99));))

Автор - _Boroda_
Дата добавления - 08.06.2018 в 22:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В ячейках оставить большее значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!