Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск результата по значению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск результата по значению (Формулы/Formulas)
Поиск результата по значению
SaFFari Дата: Суббота, 09.06.2018, 09:35 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть 2 таблицы. В табл 1 идут расчеты, в табл 2 отображаются результаты значений. в зависимости от результата в табл 1 надо найти в табл 2 - % который соответствует значению из табл 1 и автоматически должен подставляться в таб 1 (в строку %). Какую формулу можно прописать чтобы учесть весь необходимый диапазон из табл 2?
К сообщению приложен файл: 0043014.xls(46.5 Kb)
 
Ответить
СообщениеЕсть 2 таблицы. В табл 1 идут расчеты, в табл 2 отображаются результаты значений. в зависимости от результата в табл 1 надо найти в табл 2 - % который соответствует значению из табл 1 и автоматически должен подставляться в таб 1 (в строку %). Какую формулу можно прописать чтобы учесть весь необходимый диапазон из табл 2?

Автор - SaFFari
Дата добавления - 09.06.2018 в 09:35
sboy Дата: Суббота, 09.06.2018, 09:41 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2105
Репутация: 604 ±
Замечаний: 0% ±

Excel 2010
И Вам здравствуйте!
Код
=СУММПРОИЗВ((U7:AC16=V27)*V7:AD16)
К сообщению приложен файл: 3197304.xls(46.5 Kb)
 
Ответить
СообщениеИ Вам здравствуйте!
Код
=СУММПРОИЗВ((U7:AC16=V27)*V7:AD16)

Автор - sboy
Дата добавления - 09.06.2018 в 09:41
китин Дата: Суббота, 09.06.2018, 09:46 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам здравствовать!!
как понял в ячейку V28
Код
=ИНДЕКС(ИНДЕКС($U$7:$AD$16;;ПОИСКПОЗ(ОКРВНИЗ($V$27;10);$U$7:$AD$7;0)+1);ПОИСКПОЗ($V$27;ИНДЕКС($U$7:$AD$16;;ПОИСКПОЗ(ОКРВНИЗ($V$27;10);$U$7:$AD$7;0));0))


[p.s.]ну я и наизвращался :D :D :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Суббота, 09.06.2018, 09:47
 
Ответить
Сообщениеи вам здравствовать!!
как понял в ячейку V28
Код
=ИНДЕКС(ИНДЕКС($U$7:$AD$16;;ПОИСКПОЗ(ОКРВНИЗ($V$27;10);$U$7:$AD$7;0)+1);ПОИСКПОЗ($V$27;ИНДЕКС($U$7:$AD$16;;ПОИСКПОЗ(ОКРВНИЗ($V$27;10);$U$7:$AD$7;0));0))


[p.s.]ну я и наизвращался :D :D :D

Автор - китин
Дата добавления - 09.06.2018 в 09:46
китин Дата: Суббота, 09.06.2018, 09:49 | Сообщение № 4
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
sboy, Сергей красавчик hands hands hands hands hands hands hands hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеsboy, Сергей красавчик hands hands hands hands hands hands hands hands

Автор - китин
Дата добавления - 09.06.2018 в 09:49
_Boroda_ Дата: Суббота, 09.06.2018, 20:23 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13187
Репутация: 5422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
По Вашей таблице подойдет такая формула
Код
=110-V27

Кстати, вопрос - Таб.2 вправо будет расширяться (на значения, большие 59)? Если будет, то СУММПРОИЗВ не прокатит
К сообщению приложен файл: 0043014_1.xls(51.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПо Вашей таблице подойдет такая формула
Код
=110-V27

Кстати, вопрос - Таб.2 вправо будет расширяться (на значения, большие 59)? Если будет, то СУММПРОИЗВ не прокатит

Автор - _Boroda_
Дата добавления - 09.06.2018 в 20:23
Nic70y Дата: Суббота, 09.06.2018, 20:36 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4839
Репутация: 1047 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИ($U$7:$AC$16;H26;$V$7:$AD$16)
Код
=ИНДЕКС($U$7:$AD$16;ПРАВБ(H26)+1;H26/10*2)
Код
=ИНДЕКС($U$7:$AD$16;ПРАВБ(H26)+1;ЦЕЛОЕ(H26/10)*2)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 09.06.2018, 20:56
 
Ответить
Сообщение
Код
=СУММЕСЛИ($U$7:$AC$16;H26;$V$7:$AD$16)
Код
=ИНДЕКС($U$7:$AD$16;ПРАВБ(H26)+1;H26/10*2)
Код
=ИНДЕКС($U$7:$AD$16;ПРАВБ(H26)+1;ЦЕЛОЕ(H26/10)*2)

Автор - Nic70y
Дата добавления - 09.06.2018 в 20:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск результата по значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!