Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как найти в массиве аналогичные значения, скопировать данные - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти в массиве аналогичные значения, скопировать данные (Формулы/Formulas)
Как найти в массиве аналогичные значения, скопировать данные
Mitya Дата: Суббота, 09.06.2018, 16:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Подскажите, пожалуйста, как с помощью формул скопировать, а лучше вырезать и перенести из колонки AD в соответствующую ячейку колонки T числа?

Как это должно работать. Формула в ячейке T3 запрашивает, есть ли в диапазоне AB2:AB58 значение, соответствующее содержимому ячейки E3.
Если нет - то 0.
Если есть, то надо вырезать соответствующее этому значению число из колонки AD и вставить в ячейку T3.

Если такое с помощью формул сделать невозможно, то просто подставить это число (без вырезания).

Заранее спасибо откликнувшимся.
К сообщению приложен файл: 111.xlsx(25.0 Kb)
 
Ответить
СообщениеЗдравствуйте. Подскажите, пожалуйста, как с помощью формул скопировать, а лучше вырезать и перенести из колонки AD в соответствующую ячейку колонки T числа?

Как это должно работать. Формула в ячейке T3 запрашивает, есть ли в диапазоне AB2:AB58 значение, соответствующее содержимому ячейки E3.
Если нет - то 0.
Если есть, то надо вырезать соответствующее этому значению число из колонки AD и вставить в ячейку T3.

Если такое с помощью формул сделать невозможно, то просто подставить это число (без вырезания).

Заранее спасибо откликнувшимся.

Автор - Mitya
Дата добавления - 09.06.2018 в 16:37
Pelena Дата: Суббота, 09.06.2018, 16:57 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12753
Репутация: 2809 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Вырезать формулы не смогут, а подставить так
Код
=ЕСЛИОШИБКА(ВПР(E2;$AB$2:$AD$59;3;0);"")
К сообщению приложен файл: 7287517.xlsx(24.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вырезать формулы не смогут, а подставить так
Код
=ЕСЛИОШИБКА(ВПР(E2;$AB$2:$AD$59;3;0);"")

Автор - Pelena
Дата добавления - 09.06.2018 в 16:57
Mitya Дата: Суббота, 09.06.2018, 17:26 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - Mitya
Дата добавления - 09.06.2018 в 17:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти в массиве аналогичные значения, скопировать данные (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!