Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти из списка, данные, по условию. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти из списка, данные, по условию. (Формулы/Formulas)
Найти из списка, данные, по условию.
stalber Дата: Среда, 20.06.2018, 23:11 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, какой формулой можно решить данную задачу?
Приложил эксель файл в нём та же самая таблица что ниже:

Есть список данных: во второй строке находится.
123/1 55/4 3/1 4/1 55/1 12/1 6/1 67/1 1/2 32/2 3/2 4/2 5/2 6/2 7/2 8/2 9/2 10/2 2/3 51/3 4/3 5/3 5/3 7/3 8/3 9/3 10/3 12/3 1/4 2/4 2/1 12/4 51/4 67/4 8/4
Есть условие: в четвёртой строке находится.
*/1 */2
Нужно получить все возможные варианты на основании условия, в итоге 3 варианта получилось из всего списка: ниже находится. Звёздочка в условии * это должно быть одинаковое число.
3/1 3/2
4/1 4/2
6/1 6/2
К сообщению приложен файл: vopros2256.xlsx(8.9 Kb)
 
Ответить
СообщениеЗдравствуйте, какой формулой можно решить данную задачу?
Приложил эксель файл в нём та же самая таблица что ниже:

Есть список данных: во второй строке находится.
123/1 55/4 3/1 4/1 55/1 12/1 6/1 67/1 1/2 32/2 3/2 4/2 5/2 6/2 7/2 8/2 9/2 10/2 2/3 51/3 4/3 5/3 5/3 7/3 8/3 9/3 10/3 12/3 1/4 2/4 2/1 12/4 51/4 67/4 8/4
Есть условие: в четвёртой строке находится.
*/1 */2
Нужно получить все возможные варианты на основании условия, в итоге 3 варианта получилось из всего списка: ниже находится. Звёздочка в условии * это должно быть одинаковое число.
3/1 3/2
4/1 4/2
6/1 6/2

Автор - stalber
Дата добавления - 20.06.2018 в 23:11
_Boroda_ Дата: Четверг, 21.06.2018, 00:35 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Неоптимизировано, первое, что в голову пришло. Формулы массива (ввод одновременным нажатием Контрл Шифт Ентер)
Для А6
Код
=ИНДЕКС($2:$2;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ(ЕСЛИ(ЕЧИСЛО(ПОИСК($B$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($B$4;2;9);));ЕСЛИ(ЕЧИСЛО(ПОИСК($A$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($A$4;2;9););););СЧЁТЗ($2:$2)+1);СТРОКА(B1)))&""

Для В6
Код
=ИНДЕКС($2:$2;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ(ЕСЛИ(ЕЧИСЛО(ПОИСК($A$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($A$4;2;9);));ЕСЛИ(ЕЧИСЛО(ПОИСК($B$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($B$4;2;9););););СЧЁТЗ($2:$2)+1);СТРОКА(B1)))&""

Разница только в ссылках на А4 и В4
Можно одинаковую формулу для А и В написать, но если именно такую, то получится немного пострашнее
К сообщению приложен файл: vopros2256_1.xlsx(10.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНеоптимизировано, первое, что в голову пришло. Формулы массива (ввод одновременным нажатием Контрл Шифт Ентер)
Для А6
Код
=ИНДЕКС($2:$2;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ(ЕСЛИ(ЕЧИСЛО(ПОИСК($B$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($B$4;2;9);));ЕСЛИ(ЕЧИСЛО(ПОИСК($A$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($A$4;2;9););););СЧЁТЗ($2:$2)+1);СТРОКА(B1)))&""

Для В6
Код
=ИНДЕКС($2:$2;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ(ЕСЛИ(ЕЧИСЛО(ПОИСК($A$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($A$4;2;9);));ЕСЛИ(ЕЧИСЛО(ПОИСК($B$4;$A$2:$AI$2));ПОДСТАВИТЬ($A$2:$AI$2;ПСТР($B$4;2;9););););СЧЁТЗ($2:$2)+1);СТРОКА(B1)))&""

Разница только в ссылках на А4 и В4
Можно одинаковую формулу для А и В написать, но если именно такую, то получится немного пострашнее

Автор - _Boroda_
Дата добавления - 21.06.2018 в 00:35
stalber Дата: Четверг, 21.06.2018, 00:47 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
куда же страшнее) жесть, нет слов, как вы это делаете
 
Ответить
Сообщениекуда же страшнее) жесть, нет слов, как вы это делаете

Автор - stalber
Дата добавления - 21.06.2018 в 00:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти из списка, данные, по условию. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!