Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Из определённого столбца вытащить последнее или предп. число - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из определённого столбца вытащить последнее или предп. число (Формулы/Formulas)
Из определённого столбца вытащить последнее или предп. число
awaddwaawddw Дата: Четверг, 21.06.2018, 04:08 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 125
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Доброй ночи. Помогите пожалуйста.

Даны названия, нужно найти данное название в первой строке из нужного листа и вытащить из этого столбца последнее или предпоследнее число.

Файл прикрепил, легче будет по примеру объяснить.
К сообщению приложен файл: vopros306.xlsx(11.9 Kb)
 
Ответить
СообщениеДоброй ночи. Помогите пожалуйста.

Даны названия, нужно найти данное название в первой строке из нужного листа и вытащить из этого столбца последнее или предпоследнее число.

Файл прикрепил, легче будет по примеру объяснить.

Автор - awaddwaawddw
Дата добавления - 21.06.2018 в 04:08
Светлый Дата: Четверг, 21.06.2018, 06:34 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 516
Репутация: 124 ±
Замечаний: 0% ±

Excel 2007
При определённых ограничениях будет работать такая массивная (Ctrl+Shift+Enter) формула:
Код
=ОСТАТ(НАИБОЛЬШИЙ((A1=данные!$D$1:$AL$1)*(данные!$D$2:$AL$99<>"")*(данные!$D$2:$AL$99%%+СТРОКА($2:$99));1+(ЛЕВБ(B1;2)="пр"));1)/1%%


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПри определённых ограничениях будет работать такая массивная (Ctrl+Shift+Enter) формула:
Код
=ОСТАТ(НАИБОЛЬШИЙ((A1=данные!$D$1:$AL$1)*(данные!$D$2:$AL$99<>"")*(данные!$D$2:$AL$99%%+СТРОКА($2:$99));1+(ЛЕВБ(B1;2)="пр"));1)/1%%

Автор - Светлый
Дата добавления - 21.06.2018 в 06:34
sboy Дата: Четверг, 21.06.2018, 09:32 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1924
Репутация: 562 ±
Замечаний: 0% ±

Excel 2010
Еще вариант.
Код
=ЕСЛИ(ЛЕВБ(B1)="п";ИНДЕКС(данные!$D$2:$AL$99;СЧЁТЗ(данные!$D$2:$D$99)-(ЛЕВБ(B1;2)="пр");ПОИСКПОЗ(A1;данные!$D$1:$AL$1;));B1)

обратите внимание вставил 1 пустой столбец
К сообщению приложен файл: 8602149.xlsx(13.2 Kb)
 
Ответить
СообщениеЕще вариант.
Код
=ЕСЛИ(ЛЕВБ(B1)="п";ИНДЕКС(данные!$D$2:$AL$99;СЧЁТЗ(данные!$D$2:$D$99)-(ЛЕВБ(B1;2)="пр");ПОИСКПОЗ(A1;данные!$D$1:$AL$1;));B1)

обратите внимание вставил 1 пустой столбец

Автор - sboy
Дата добавления - 21.06.2018 в 09:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из определённого столбца вытащить последнее или предп. число (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!