Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет даты окончания срока годности - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет даты окончания срока годности (Формулы/Formulas)
Подсчет даты окончания срока годности
Tallen Дата: Четверг, 21.06.2018, 10:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые гуру Excel!
Подскажите пожалуйста, как можно вычислить дату окончания срока годности в столбце М от последней выдачи (из диапазона E3:L8) и подсчет сколько осталось выдать до конца календарного года в столбце D
К сообщению приложен файл: 0710972.xlsx(10.0 Kb)


Сообщение отредактировал Tallen - Четверг, 21.06.2018, 13:17
 
Ответить
СообщениеЗдравствуйте, уважаемые гуру Excel!
Подскажите пожалуйста, как можно вычислить дату окончания срока годности в столбце М от последней выдачи (из диапазона E3:L8) и подсчет сколько осталось выдать до конца календарного года в столбце D

Автор - Tallen
Дата добавления - 21.06.2018 в 10:43
anger47 Дата: Четверг, 21.06.2018, 10:59 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 6 ±
Замечаний: 0% ±

Самое простое решение как по мне такое
К сообщению приложен файл: 5926424.xlsx(9.6 Kb)
 
Ответить
СообщениеСамое простое решение как по мне такое

Автор - anger47
Дата добавления - 21.06.2018 в 10:59
sboy Дата: Четверг, 21.06.2018, 11:00 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2192
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял
Код
=ЕСЛИ(ЕТЕКСТ(C3);ЛЕВБ(C3)*(ПОДСТАВИТЬ(ПСТР(C3;6;99);" года";""))*365;365/C3)+D3
К сообщению приложен файл: 9378938.xlsx(9.4 Kb)
 
Ответить
СообщениеДобрый день.
Если правильно понял
Код
=ЕСЛИ(ЕТЕКСТ(C3);ЛЕВБ(C3)*(ПОДСТАВИТЬ(ПСТР(C3;6;99);" года";""))*365;365/C3)+D3

Автор - sboy
Дата добавления - 21.06.2018 в 11:00
Tallen Дата: Четверг, 21.06.2018, 13:12 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
anger47, спасибо большое! С одной стороны все работает, а с другой - только сообразила, что далеко не всегда выдают весь объем положенного сразу. Например рукавицы или перчатки положено в год 6 пар и выдают их раз в 2 месяца.
Добавила столбцы, чтобы было видно каждую выдачу. Возможен ли подсчет даты износа в столбце М от последней выдачи (из диапазона E3:L8) и подсчет сколько осталось выдать до конца календарного года в столбце D?
К сообщению приложен файл: 6280637.xlsx(10.0 Kb)
 
Ответить
Сообщениеanger47, спасибо большое! С одной стороны все работает, а с другой - только сообразила, что далеко не всегда выдают весь объем положенного сразу. Например рукавицы или перчатки положено в год 6 пар и выдают их раз в 2 месяца.
Добавила столбцы, чтобы было видно каждую выдачу. Возможен ли подсчет даты износа в столбце М от последней выдачи (из диапазона E3:L8) и подсчет сколько осталось выдать до конца календарного года в столбце D?

Автор - Tallen
Дата добавления - 21.06.2018 в 13:12
Tallen Дата: Четверг, 21.06.2018, 13:15 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, ячейку E7 считает неправильно - на год 6
 
Ответить
Сообщениеsboy, ячейку E7 считает неправильно - на год 6

Автор - Tallen
Дата добавления - 21.06.2018 в 13:15
sboy Дата: Четверг, 21.06.2018, 13:40 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2192
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
ячейку E7 считает неправильно

считает правильно, только не то, что Вам нужно :)
для нового файла
Код
=ЕСЛИ(ЕТЕКСТ(C3);ПОДСТАВИТЬ(ПСТР(C3;6;99);" года";"")*365;365/C3)*ПРОСМОТР(9^9;F3:L3;E3:K3)+ПРОСМОТР(9^9;F3:L3)
К сообщению приложен файл: 8050327.xlsx(10.0 Kb)
 
Ответить
Сообщение
ячейку E7 считает неправильно

считает правильно, только не то, что Вам нужно :)
для нового файла
Код
=ЕСЛИ(ЕТЕКСТ(C3);ПОДСТАВИТЬ(ПСТР(C3;6;99);" года";"")*365;365/C3)*ПРОСМОТР(9^9;F3:L3;E3:K3)+ПРОСМОТР(9^9;F3:L3)

Автор - sboy
Дата добавления - 21.06.2018 в 13:40
Tallen Дата: Четверг, 21.06.2018, 13:47 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, красота!!! А можно совсем уж обнаглеть и попросить поставить какую-нибудь хитрую формулу в столбец D - там не всегда же одна цифра, а часто что-то типа 1 на 3 года... )))
 
Ответить
Сообщениеsboy, красота!!! А можно совсем уж обнаглеть и попросить поставить какую-нибудь хитрую формулу в столбец D - там не всегда же одна цифра, а часто что-то типа 1 на 3 года... )))

Автор - Tallen
Дата добавления - 21.06.2018 в 13:47
sboy Дата: Четверг, 21.06.2018, 14:21 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2192
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Попросить можно, создайте новую тему, и опишите, что хотите получить.
 
Ответить
СообщениеПопросить можно, создайте новую тему, и опишите, что хотите получить.

Автор - sboy
Дата добавления - 21.06.2018 в 14:21
Tallen Дата: Четверг, 21.06.2018, 14:27 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, поняла. Спасибо!!!
 
Ответить
Сообщениеsboy, поняла. Спасибо!!!

Автор - Tallen
Дата добавления - 21.06.2018 в 14:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет даты окончания срока годности (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!