Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как вставить диапазон ячеек в один столбец? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вставить диапазон ячеек в один столбец? (Формулы/Formulas)
Как вставить диапазон ячеек в один столбец?
AdwordsDirect Дата: Пятница, 22.06.2018, 10:00 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 143
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Ещё раз здравствуйте, такая проблема, есть диапазон ячеек (A-F с 1-6) в разных столбцах, есть ли быстрый способ их копи/паст в один столбец по порядку? Порядок не важен.
Сори за злоупотребление помощью форума.
К сообщению приложен файл: 2159622.xlsx(8.5 Kb)


Сообщение отредактировал AdwordsDirect - Пятница, 22.06.2018, 10:01
 
Ответить
СообщениеЕщё раз здравствуйте, такая проблема, есть диапазон ячеек (A-F с 1-6) в разных столбцах, есть ли быстрый способ их копи/паст в один столбец по порядку? Порядок не важен.
Сори за злоупотребление помощью форума.

Автор - AdwordsDirect
Дата добавления - 22.06.2018 в 10:00
китин Дата: Пятница, 22.06.2018, 10:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4930
Репутация: 787 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Цитата AdwordsDirect, 22.06.2018 в 10:00, в сообщении № 1 ()
Сори за злоупотребление помощью форума.

форум для того и создан, что бы им "злоупотребляли" :D
Код
=ИНДЕКС($A$1:$F$6;ОСТАТ(СТРОКА(A1)-1;6)+1;(СТРОКА(A1)-1)/6+1)

[p.s.]
это чисто по вашему примеру на 6 строк и 6 столбцов( без файла)
а это для всего листа
Код
=ИНДЕКС($A$1:(ИНДЕКС($1:$1048576;СЧЁТЗ($F:$F);СЧЁТЗ($1:$1)));ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ($F:$F))+1;(СТРОКА(A1)-1)/СЧЁТЗ($F:$F)+1)

с файлом
К сообщению приложен файл: AdwordsDirect.xlsx(10.6 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 22.06.2018, 10:28
 
Ответить
Сообщение
Цитата AdwordsDirect, 22.06.2018 в 10:00, в сообщении № 1 ()
Сори за злоупотребление помощью форума.

форум для того и создан, что бы им "злоупотребляли" :D
Код
=ИНДЕКС($A$1:$F$6;ОСТАТ(СТРОКА(A1)-1;6)+1;(СТРОКА(A1)-1)/6+1)

[p.s.]
это чисто по вашему примеру на 6 строк и 6 столбцов( без файла)
а это для всего листа
Код
=ИНДЕКС($A$1:(ИНДЕКС($1:$1048576;СЧЁТЗ($F:$F);СЧЁТЗ($1:$1)));ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ($F:$F))+1;(СТРОКА(A1)-1)/СЧЁТЗ($F:$F)+1)

с файлом

Автор - китин
Дата добавления - 22.06.2018 в 10:11
AdwordsDirect Дата: Пятница, 22.06.2018, 10:34 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 143
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое!
 
Ответить
СообщениеСпасибо большое!

Автор - AdwordsDirect
Дата добавления - 22.06.2018 в 10:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вставить диапазон ячеек в один столбец? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!