Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Просуммировать данные по периоду по месяцам без учета дней - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать данные по периоду по месяцам без учета дней (Формулы/Formulas)
Просуммировать данные по периоду по месяцам без учета дней
CrazyNice Дата: Пятница, 22.06.2018, 14:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 RUS
Доброго дня!

Помогите посчитать сумму между датами.
Для меня сложность в том, что начало и конец периода заданы с днями (например с 15.03.2017 по 21.06.2018), а данные, которые нужно просуммировать - по месяцам.
Пример во вложении.

Заранее большое спасибо.
К сообщению приложен файл: __.xlsx(11.6 Kb)
 
Ответить
СообщениеДоброго дня!

Помогите посчитать сумму между датами.
Для меня сложность в том, что начало и конец периода заданы с днями (например с 15.03.2017 по 21.06.2018), а данные, которые нужно просуммировать - по месяцам.
Пример во вложении.

Заранее большое спасибо.

Автор - CrazyNice
Дата добавления - 22.06.2018 в 14:48
abtextime Дата: Пятница, 22.06.2018, 14:58 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
CrazyNice, Уточните, с 15.03.2017 по 21.06.2018 - это суммировать всё за март, апрель, май, июнь? Или за март и июнь нужно делить на 16/31 и 21/30 соответственно?
 
Ответить
СообщениеCrazyNice, Уточните, с 15.03.2017 по 21.06.2018 - это суммировать всё за март, апрель, май, июнь? Или за март и июнь нужно делить на 16/31 и 21/30 соответственно?

Автор - abtextime
Дата добавления - 22.06.2018 в 14:58
_Boroda_ Дата: Пятница, 22.06.2018, 15:08 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? (это если брать всю сумму за месяц)
Код
=СУММПРОИЗВ(D3:AM3*(--(D$2:AM$2&D$1:AM$1)>КОНМЕСЯЦА(A14;-1))*(--(D$2:AM$2&D$1:AM$1)<=КОНМЕСЯЦА(B14;0)))

Еще автораскраску Условным форматированием сделал в файле
К сообщению приложен файл: -31-1.xlsx(13.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? (это если брать всю сумму за месяц)
Код
=СУММПРОИЗВ(D3:AM3*(--(D$2:AM$2&D$1:AM$1)>КОНМЕСЯЦА(A14;-1))*(--(D$2:AM$2&D$1:AM$1)<=КОНМЕСЯЦА(B14;0)))

Еще автораскраску Условным форматированием сделал в файле

Автор - _Boroda_
Дата добавления - 22.06.2018 в 15:08
CrazyNice Дата: Пятница, 22.06.2018, 15:14 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 RUS
Спасибо большое!!! :p
 
Ответить
СообщениеСпасибо большое!!! :p

Автор - CrazyNice
Дата добавления - 22.06.2018 в 15:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать данные по периоду по месяцам без учета дней (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!