Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вставка тире черезе количество знаков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вставка тире черезе количество знаков (Формулы/Formulas)
вставка тире черезе количество знаков
vitek73 Дата: Понедельник, 25.06.2018, 10:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, подскажите как сделать тире в наборе цифр ? то есть столбик с 8 значными номерами 40608056..... и.т.д. а надо чтоб получилось 4060-8056 .......,
пробовал формат ечеек (дополнительные) индекс, но там он перед началом цифр вставляет нуль, а он мне совсем не нужен.
К сообщению приложен файл: _250618.xlsx(8.9 Kb)


vitёk73
 
Ответить
СообщениеДобрый день, подскажите как сделать тире в наборе цифр ? то есть столбик с 8 значными номерами 40608056..... и.т.д. а надо чтоб получилось 4060-8056 .......,
пробовал формат ечеек (дополнительные) индекс, но там он перед началом цифр вставляет нуль, а он мне совсем не нужен.

Автор - vitek73
Дата добавления - 25.06.2018 в 10:09
Manyasha Дата: Понедельник, 25.06.2018, 10:18 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 2193
Репутация: 892 ±
Замечаний: 0% ±

Excel 2010, 2016
vitek73, здравствуйте, так пойдет?
Код
=ЛЕВБ(B1;4)&"-"&ПРАВБ(B1;4)
К сообщению приложен файл: _250618-1.xlsx(9.4 Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеvitek73, здравствуйте, так пойдет?
Код
=ЛЕВБ(B1;4)&"-"&ПРАВБ(B1;4)

Автор - Manyasha
Дата добавления - 25.06.2018 в 10:18
sboy Дата: Понедельник, 25.06.2018, 10:27 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2160
Репутация: 620 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Формат ячеек 0000-0000
К сообщению приложен файл: 2755936.xlsx(9.0 Kb)
 
Ответить
СообщениеДобрый день.
Формат ячеек 0000-0000

Автор - sboy
Дата добавления - 25.06.2018 в 10:27
_Boroda_ Дата: Понедельник, 25.06.2018, 10:29 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Достаточно такого формата
0-0000
Формулу можно так еще
Код
=ТЕКСТ(B1;"0-0000")
К сообщению приложен файл: _250618_1.xlsx(9.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДостаточно такого формата
0-0000
Формулу можно так еще
Код
=ТЕКСТ(B1;"0-0000")

Автор - _Boroda_
Дата добавления - 25.06.2018 в 10:29
китин Дата: Понедельник, 25.06.2018, 12:14 | Сообщение № 5
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5100
Репутация: 809 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
А если поизвращаться?
Код
=ПОДСТАВИТЬ(B1;ЛЕВБ(B1;4);ЛЕВБ(B1;4)&"-")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеА если поизвращаться?
Код
=ПОДСТАВИТЬ(B1;ЛЕВБ(B1;4);ЛЕВБ(B1;4)&"-")

Автор - китин
Дата добавления - 25.06.2018 в 12:14
_Boroda_ Дата: Понедельник, 25.06.2018, 12:19 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если поизвращаться?

Действительно
Код
=ЗАМЕНИТЬ(B1;5;;"-")
К сообщению приложен файл: _250618_2.xlsx(9.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
А если поизвращаться?

Действительно
Код
=ЗАМЕНИТЬ(B1;5;;"-")

Автор - _Boroda_
Дата добавления - 25.06.2018 в 12:19
sv2014 Дата: Понедельник, 25.06.2018, 16:52 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 221
Репутация: 60 ±
Замечаний: 0% ±

Excel 2013
vitek73, вариант функции в столбце K или функции bbb

[vba]
Код
Function aaa$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "(\d{4})(\d{4})": aaa = .Replace(t, "$1-$2")
  End With
End Function
[/vba]

[vba]
Код
Function bbb$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "(\d{4})(\d{4})"
bbb = Left(t, 4) & .Replace(t, "-$+")
  End With
End Function
[/vba]
К сообщению приложен файл: example_25_06_2.xls(33.0 Kb)


Сообщение отредактировал sv2014 - Понедельник, 25.06.2018, 17:05
 
Ответить
Сообщениеvitek73, вариант функции в столбце K или функции bbb

[vba]
Код
Function aaa$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "(\d{4})(\d{4})": aaa = .Replace(t, "$1-$2")
  End With
End Function
[/vba]

[vba]
Код
Function bbb$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "(\d{4})(\d{4})"
bbb = Left(t, 4) & .Replace(t, "-$+")
  End With
End Function
[/vba]

Автор - sv2014
Дата добавления - 25.06.2018 в 16:52
krosav4ig Дата: Вторник, 26.06.2018, 03:37 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1669
Репутация: 696 ±
Замечаний: 0% ±

Excel 2007,2010,2013
до кучи [vba]
Код
Function ccc$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "\d{4}(?=\d)":ccc = .Replace(t, "$&-")
  End With
End Function
[/vba]


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Вторник, 26.06.2018, 03:37
 
Ответить
Сообщениедо кучи [vba]
Код
Function ccc$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "\d{4}(?=\d)":ccc = .Replace(t, "$&-")
  End With
End Function
[/vba]

Автор - krosav4ig
Дата добавления - 26.06.2018 в 03:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вставка тире черезе количество знаков (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!