Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ночные часы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ночные часы (Формулы/Formulas)
Ночные часы
Аверин Дата: Суббота, 30.06.2018, 15:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здраствуйте. Помогите, пожалуйста, сделать ночные часы (с 22:00 до 06:00)
Файл прикрепляю.
К сообщению приложен файл: 2572531.xlsx(10.2 Kb)


Сообщение отредактировал Аверин - Суббота, 30.06.2018, 15:44
 
Ответить
СообщениеЗдраствуйте. Помогите, пожалуйста, сделать ночные часы (с 22:00 до 06:00)
Файл прикрепляю.

Автор - Аверин
Дата добавления - 30.06.2018 в 15:44
ASWP Дата: Суббота, 30.06.2018, 17:00 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 98
Репутация: 10 ±
Замечаний: 0% ±

Excel 2007
Код
=МИН(ОСТАТ(D3;1);--"6:00")-МИН(ОСТАТ(C3;1);--"6:00")+МАКС(ОСТАТ(D3;1);--"22:00")-МАКС(ОСТАТ(C3;1);--"22:00")+(ОСТАТ(D3;1)<ОСТАТ(C3;1))*(1+"6:00"-"22:00")
К сообщению приложен файл: 2572531_1.xlsx(10.4 Kb)


я знаю что ничего не знаю, но другие не знают и этого
 
Ответить
Сообщение
Код
=МИН(ОСТАТ(D3;1);--"6:00")-МИН(ОСТАТ(C3;1);--"6:00")+МАКС(ОСТАТ(D3;1);--"22:00")-МАКС(ОСТАТ(C3;1);--"22:00")+(ОСТАТ(D3;1)<ОСТАТ(C3;1))*(1+"6:00"-"22:00")

Автор - ASWP
Дата добавления - 30.06.2018 в 17:00
Светлый Дата: Суббота, 30.06.2018, 17:23 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 614
Репутация: 165 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
И мой вариант:
Код
=ЕСЛИ(C3<B3+1/4;B3+1/4-C3)+ЕСЛИ(C3-B3<ОСТАТ(D3;1);ЕСЛИ(ОСТАТ(D3;1)<1/4;ОСТАТ(D3;1)-1/4)+ЕСЛИ(ОСТАТ(D3;1)>22/24;ОСТАТ(D3;1)-22/24);ЕСЛИ(ОСТАТ(D3;1)<1/4;1/12+ОСТАТ(D3;1);1/3))

Доб.
Нашёл ошибку в своей формуле. Исправил:
Код
=ЕСЛИ(C3<B3+1/4;B3+1/4-C3)+ЕСЛИ(C3-B3<ОСТАТ(D3;1);ЕСЛИ(ОСТАТ(D3;1)<1/4;ОСТАТ(D3;1)-1/4)+ЕСЛИ(ОСТАТ(D3;1)>22/24;ОСТАТ(D3;1)-22/24)+ЕСЛИ(C3>B3+22/24;B3+22/24-C3);ЕСЛИ(ОСТАТ(D3;1)<1/4;1/12+ОСТАТ(D3;1);1/3))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 30.06.2018, 17:49
 
Ответить
СообщениеЗдравствуйте!
И мой вариант:
Код
=ЕСЛИ(C3<B3+1/4;B3+1/4-C3)+ЕСЛИ(C3-B3<ОСТАТ(D3;1);ЕСЛИ(ОСТАТ(D3;1)<1/4;ОСТАТ(D3;1)-1/4)+ЕСЛИ(ОСТАТ(D3;1)>22/24;ОСТАТ(D3;1)-22/24);ЕСЛИ(ОСТАТ(D3;1)<1/4;1/12+ОСТАТ(D3;1);1/3))

Доб.
Нашёл ошибку в своей формуле. Исправил:
Код
=ЕСЛИ(C3<B3+1/4;B3+1/4-C3)+ЕСЛИ(C3-B3<ОСТАТ(D3;1);ЕСЛИ(ОСТАТ(D3;1)<1/4;ОСТАТ(D3;1)-1/4)+ЕСЛИ(ОСТАТ(D3;1)>22/24;ОСТАТ(D3;1)-22/24)+ЕСЛИ(C3>B3+22/24;B3+22/24-C3);ЕСЛИ(ОСТАТ(D3;1)<1/4;1/12+ОСТАТ(D3;1);1/3))

Автор - Светлый
Дата добавления - 30.06.2018 в 17:23
Аверин Дата: Суббота, 30.06.2018, 18:04 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем спасибо оба варианта рабочие!
 
Ответить
СообщениеВсем спасибо оба варианта рабочие!

Автор - Аверин
Дата добавления - 30.06.2018 в 18:04
AlexM Дата: Воскресенье, 01.07.2018, 09:57 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3755
Репутация: 947 ±
Замечаний: 0% ±

Excel 2003
Код
=МАКС(ОСТАТ(D3;1);"22:")-МАКС(ОСТАТ(C3;1);"22:")+МИН(ОСТАТ(D3;1);"6:")-МИН(ОСТАТ(C3;1);"6:")+(ОСТАТ(C3;1)>ОСТАТ(D3;1))*8/24



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=МАКС(ОСТАТ(D3;1);"22:")-МАКС(ОСТАТ(C3;1);"22:")+МИН(ОСТАТ(D3;1);"6:")-МИН(ОСТАТ(C3;1);"6:")+(ОСТАТ(C3;1)>ОСТАТ(D3;1))*8/24

Автор - AlexM
Дата добавления - 01.07.2018 в 09:57
_Boroda_ Дата: Понедельник, 02.07.2018, 13:58 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12972
Репутация: 5335 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И еще
Код
=МАКС(;МИН(1;ОСТАТ(D3+"18:";1)+(ОСТАТ(D3+"18:";1)<ОСТАТ(C3+"18:";1)))-МАКС("16:";ОСТАТ(C3+"18:";1)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ еще
Код
=МАКС(;МИН(1;ОСТАТ(D3+"18:";1)+(ОСТАТ(D3+"18:";1)<ОСТАТ(C3+"18:";1)))-МАКС("16:";ОСТАТ(C3+"18:";1)))

Автор - _Boroda_
Дата добавления - 02.07.2018 в 13:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ночные часы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!