Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматический выбор значения из списка. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический выбор значения из списка. (Формулы/Formulas)
Автоматический выбор значения из списка.
morfiol Дата: Четверг, 05.07.2018, 14:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброе время суток форумчане.
Подскажите пожалуйста, какую можно применить формулу.
Необходимо, что бы при вводе цифрового значения в соседней ячейке появлялось расшифровка кода.
Пример.
В ячейке A3 набираю код. В ячейке B3 должна появиться расшифровка кода из "Справочного материала".
К сообщению приложен файл: 8673847.xlsx(10.7 Kb)
 
Ответить
СообщениеДоброе время суток форумчане.
Подскажите пожалуйста, какую можно применить формулу.
Необходимо, что бы при вводе цифрового значения в соседней ячейке появлялось расшифровка кода.
Пример.
В ячейке A3 набираю код. В ячейке B3 должна появиться расшифровка кода из "Справочного материала".

Автор - morfiol
Дата добавления - 05.07.2018 в 14:32
pabchek Дата: Четверг, 05.07.2018, 14:34 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 878
Репутация: 211 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Так надо?
Код
=ВПР(G3;$A$2:$B$5;2;0)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте!
Так надо?
Код
=ВПР(G3;$A$2:$B$5;2;0)

Автор - pabchek
Дата добавления - 05.07.2018 в 14:34
_Boroda_ Дата: Четверг, 05.07.2018, 14:47 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12659
Репутация: 5191 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ВПР(A2;G$3:H$7;2;)
Код
=ИНДЕКС(H$3:H$7;ПОИСКПОЗ(A2;G$3:G$7;))
Код
=ПРОСМОТР(A2;G$3:G$7;H$3:H$7)

Все это можно обернуть в ЕСЛИОШИБКА
Код
=ЕСЛИОШИБКА(ВПР(A2;G$3:H$7;2;);"")

Или вот так, здесь ЕСЛИОШИБКА не нужна
Код
=ПРОСМОТР(;-1/(A2=G$3:G$7);H$3:H$7)&""
К сообщению приложен файл: 8673847_1.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=ВПР(A2;G$3:H$7;2;)
Код
=ИНДЕКС(H$3:H$7;ПОИСКПОЗ(A2;G$3:G$7;))
Код
=ПРОСМОТР(A2;G$3:G$7;H$3:H$7)

Все это можно обернуть в ЕСЛИОШИБКА
Код
=ЕСЛИОШИБКА(ВПР(A2;G$3:H$7;2;);"")

Или вот так, здесь ЕСЛИОШИБКА не нужна
Код
=ПРОСМОТР(;-1/(A2=G$3:G$7);H$3:H$7)&""

Автор - _Boroda_
Дата добавления - 05.07.2018 в 14:47
morfiol Дата: Четверг, 05.07.2018, 15:00 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем большое спасибо.

Тема закрыта
 
Ответить
СообщениеВсем большое спасибо.

Тема закрыта

Автор - morfiol
Дата добавления - 05.07.2018 в 15:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический выбор значения из списка. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!