Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по столбцу по заданным критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по столбцу по заданным критериям (Формулы/Formulas)
Поиск значения по столбцу по заданным критериям
agroster Дата: Четверг, 05.07.2018, 17:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Ребята подскажите чайнику как найти искомое. Описание в файле. Заранее спасибо!
К сообщению приложен файл: 5673251.xlsx(9.6 Kb)
 
Ответить
СообщениеДобрый день!
Ребята подскажите чайнику как найти искомое. Описание в файле. Заранее спасибо!

Автор - agroster
Дата добавления - 05.07.2018 в 17:35
_Boroda_ Дата: Четверг, 05.07.2018, 17:46 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=НАИБОЛЬШИЙ(ИНДЕКС(A$3:G$11;;ПОИСКПОЗ(I$1;A$2:G$2;));СТРОКА(K1))

или
Код
=НАИБОЛЬШИЙ(A$3:G$11*(I$1=A$2:G$2);СТРОКА(K1))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 5673251_1.xlsx(9.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=НАИБОЛЬШИЙ(ИНДЕКС(A$3:G$11;;ПОИСКПОЗ(I$1;A$2:G$2;));СТРОКА(K1))

или
Код
=НАИБОЛЬШИЙ(A$3:G$11*(I$1=A$2:G$2);СТРОКА(K1))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 05.07.2018 в 17:46
agroster Дата: Четверг, 05.07.2018, 21:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да, спс! Теперь не получается наименьшее сделать. Вроде ставлю функцию наименьшее, с итоге все 0, подскажите что не так?


Сообщение отредактировал agroster - Четверг, 05.07.2018, 22:40
 
Ответить
СообщениеДа, спс! Теперь не получается наименьшее сделать. Вроде ставлю функцию наименьшее, с итоге все 0, подскажите что не так?

Автор - agroster
Дата добавления - 05.07.2018 в 21:54
boa Дата: Пятница, 06.07.2018, 10:35 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 39 ±
Замечаний: 0% ±

2013, 365
agroster,

Код
=НАИМЕНЬШИЙ(ИНДЕКС($A$3:$G$11;;ПОИСКПОЗ($I$1;$A$2:$G$2;));СТРОКА(N1))

или ф.массива
Код
=НАИМЕНЬШИЙ($A$3:$G$11*($I$1=$A$2:$G$2);СЧЁТЗ($A$3:$G$11)-СЧЁТЗ($A$3:$A$11)+СТРОКА(M1))
К сообщению приложен файл: 5673251_2.xlsx(11.8 Kb)


 
Ответить
Сообщениеagroster,

Код
=НАИМЕНЬШИЙ(ИНДЕКС($A$3:$G$11;;ПОИСКПОЗ($I$1;$A$2:$G$2;));СТРОКА(N1))

или ф.массива
Код
=НАИМЕНЬШИЙ($A$3:$G$11*($I$1=$A$2:$G$2);СЧЁТЗ($A$3:$G$11)-СЧЁТЗ($A$3:$A$11)+СТРОКА(M1))

Автор - boa
Дата добавления - 06.07.2018 в 10:35
_Boroda_ Дата: Пятница, 06.07.2018, 10:48 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
ставлю функцию наименьшее, с итоге все 0

Все правильно, первые несколько записей за 25/06 - нули. Если их не нужно показывать, то
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ИНДЕКС(A$3:G$11;;ПОИСКПОЗ(I$1;A$2:G$2;));СТРОКА(K1)+СЧЁТЕСЛИ(ИНДЕКС(A$3:G$11;;ПОИСКПОЗ(I$1;A$2:G$2;));));"")

или
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(A$3:G$11*(I$1=A$2:G$2);A$3:G$11);СТРОКА(K1));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 5673251_11.xlsx(10.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
ставлю функцию наименьшее, с итоге все 0

Все правильно, первые несколько записей за 25/06 - нули. Если их не нужно показывать, то
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ИНДЕКС(A$3:G$11;;ПОИСКПОЗ(I$1;A$2:G$2;));СТРОКА(K1)+СЧЁТЕСЛИ(ИНДЕКС(A$3:G$11;;ПОИСКПОЗ(I$1;A$2:G$2;));));"")

или
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(A$3:G$11*(I$1=A$2:G$2);A$3:G$11);СТРОКА(K1));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 06.07.2018 в 10:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по столбцу по заданным критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!