Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск данных в таблице на основании запроса недели - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных в таблице на основании запроса недели (Формулы/Formulas)
Поиск данных в таблице на основании запроса недели
wifinoob1 Дата: Воскресенье, 08.07.2018, 12:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня товарищи! Имеется таблица данных, разделенных на недельные отрезки, каждая неделя приводится к определенному итогу, все делается в ручную, хотелось бы как-то автоматизировать процесс не использую ВБА, уверен есть доступная функция. Опишу более подробнее. Имеются ячейки объединенные по вертикали в порядковые номера недели, далее идут определенные данные, которые нужно обработать (2 лист примера). Подскажите пожалуйста функцию, которая обрабатывала область и производила вычисления описанные в ячейках G5-G7 основываясь на вводе данных G4 (порядковый номер недели).
К сообщению приложен файл: 8414723.xlsx(11.6 Kb)


Сообщение отредактировал wifinoob1 - Воскресенье, 08.07.2018, 12:33
 
Ответить
СообщениеДоброго дня товарищи! Имеется таблица данных, разделенных на недельные отрезки, каждая неделя приводится к определенному итогу, все делается в ручную, хотелось бы как-то автоматизировать процесс не использую ВБА, уверен есть доступная функция. Опишу более подробнее. Имеются ячейки объединенные по вертикали в порядковые номера недели, далее идут определенные данные, которые нужно обработать (2 лист примера). Подскажите пожалуйста функцию, которая обрабатывала область и производила вычисления описанные в ячейках G5-G7 основываясь на вводе данных G4 (порядковый номер недели).

Автор - wifinoob1
Дата добавления - 08.07.2018 в 12:33
jakim Дата: Воскресенье, 08.07.2018, 13:17 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 848
Репутация: 225 ±
Замечаний: 0% ±

Excel 2010
Формулы

Код
=COUNTIFS(B:B;G4;C:C;"<0")

Код
=COUNTIFS(B:B;G4;C:C;">0")

Код
=SUMIF(B:B;G4;C:C)
К сообщению приложен файл: 8279059.xlsx(11.9 Kb)
 
Ответить
Сообщение
Формулы

Код
=COUNTIFS(B:B;G4;C:C;"<0")

Код
=COUNTIFS(B:B;G4;C:C;">0")

Код
=SUMIF(B:B;G4;C:C)

Автор - jakim
Дата добавления - 08.07.2018 в 13:17
Nic70y Дата: Воскресенье, 08.07.2018, 13:24 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4875
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2013
Код
=СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(G4;B:B;)):ИНДЕКС(C:C;ЕСЛИОШИБКА(ПОИСКПОЗ(G4+1;B:B;)-1;ПОИСКПОЗ(9E+307;C:C)));"<0")
и т.п.
добавлено:
итог можно и так
Код
=СУММ(G5:G6)
К сообщению приложен файл: 2967588.xlsx(11.6 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 08.07.2018, 13:26
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(G4;B:B;)):ИНДЕКС(C:C;ЕСЛИОШИБКА(ПОИСКПОЗ(G4+1;B:B;)-1;ПОИСКПОЗ(9E+307;C:C)));"<0")
и т.п.
добавлено:
итог можно и так
Код
=СУММ(G5:G6)

Автор - Nic70y
Дата добавления - 08.07.2018 в 13:24
wifinoob1 Дата: Воскресенье, 08.07.2018, 13:26 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Формулы
=СЧЁТЕСЛИМН(B:B;G4;C:C;"<0")

Вы меня немножко не так поняли, эти функции мне известны. Мне необходимо указывая номер недели в выделенном поле G4 выводить итоговые данные за эту неделю. То есть из массива таблицы, выделять массив с соответствующей неделей по горизонтали, и из этой выборки уже суммировать или считать результаты по вертикали

Излишнее цитирование удалено администрацией
 
Ответить
Сообщение
Формулы
=СЧЁТЕСЛИМН(B:B;G4;C:C;"<0")

Вы меня немножко не так поняли, эти функции мне известны. Мне необходимо указывая номер недели в выделенном поле G4 выводить итоговые данные за эту неделю. То есть из массива таблицы, выделять массив с соответствующей неделей по горизонтали, и из этой выборки уже суммировать или считать результаты по вертикали

Излишнее цитирование удалено администрацией

Автор - wifinoob1
Дата добавления - 08.07.2018 в 13:26
wifinoob1 Дата: Воскресенье, 08.07.2018, 13:32 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013

=СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(G4;B:B;)):ИНДЕКС(C:C;ЕСЛИОШИБКА(ПОИСКПОЗ(G4+1;B:B;)-1;ПОИСКПОЗ(9E+307;C:C)));"<0")

Точное попадание! Первая функция дает поле для дальнейших действий, благодарю за помощь!
Излишнее цитирование удалено администрацией
 
Ответить
Сообщение

=СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(G4;B:B;)):ИНДЕКС(C:C;ЕСЛИОШИБКА(ПОИСКПОЗ(G4+1;B:B;)-1;ПОИСКПОЗ(9E+307;C:C)));"<0")

Точное попадание! Первая функция дает поле для дальнейших действий, благодарю за помощь!
Излишнее цитирование удалено администрацией

Автор - wifinoob1
Дата добавления - 08.07.2018 в 13:32
_Boroda_ Дата: Воскресенье, 08.07.2018, 13:39 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант. Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=СЧЁТ(1/(ПРОСМОТР(СТРОКА(3:99);СТРОКА(3:99)/(B3:B99<>"");B3:B99=G4)*C3:C99<0))


wifinoob1, не нужно цитировать весь пост целиком - это нарушение Правил форума
К сообщению приложен файл: 8414723_1.xlsx(12.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант. Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=СЧЁТ(1/(ПРОСМОТР(СТРОКА(3:99);СТРОКА(3:99)/(B3:B99<>"");B3:B99=G4)*C3:C99<0))


wifinoob1, не нужно цитировать весь пост целиком - это нарушение Правил форума

Автор - _Boroda_
Дата добавления - 08.07.2018 в 13:39
wifinoob1 Дата: Воскресенье, 08.07.2018, 13:56 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Прошу прощения! Вы мне очень помогли!
 
Ответить
СообщениеПрошу прощения! Вы мне очень помогли!

Автор - wifinoob1
Дата добавления - 08.07.2018 в 13:56
Светлый Дата: Воскресенье, 08.07.2018, 19:00 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 690
Репутация: 184 ±
Замечаний: 0% ±

Excel 2010
Я понял, что надо было сумму найти, а не количество?
Массивная формула для Лист 1. Сумма отрицательных значений:
Код
=СУММ((СТРОКА(5:99)>=ПОИСКПОЗ("Неделя "&J7;A:A;))*(СТРОКА(5:99)<ЕСЛИОШИБКА(ПОИСКПОЗ("Неделя "&J7+1;A:A;);53))*(B5:B99<0)*B5:B99)

Для Лист 2:
Код
=СУММ((СТРОКА(3:99)>=ПОИСКПОЗ(G4;B:B;))*(СТРОКА(3:99)<ЕСЛИОШИБКА(ПОИСКПОЗ(G4+1;B:B;);53))*(C3:C99<0)*C3:C99)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЯ понял, что надо было сумму найти, а не количество?
Массивная формула для Лист 1. Сумма отрицательных значений:
Код
=СУММ((СТРОКА(5:99)>=ПОИСКПОЗ("Неделя "&J7;A:A;))*(СТРОКА(5:99)<ЕСЛИОШИБКА(ПОИСКПОЗ("Неделя "&J7+1;A:A;);53))*(B5:B99<0)*B5:B99)

Для Лист 2:
Код
=СУММ((СТРОКА(3:99)>=ПОИСКПОЗ(G4;B:B;))*(СТРОКА(3:99)<ЕСЛИОШИБКА(ПОИСКПОЗ(G4+1;B:B;);53))*(C3:C99<0)*C3:C99)

Автор - Светлый
Дата добавления - 08.07.2018 в 19:00
Nic70y Дата: Воскресенье, 08.07.2018, 19:14 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4875
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 08.07.2018 в 19:00, в сообщении № 8 ()
сумму найти
таки да
эт я не ту формулу в тег засунул
дает поле для дальнейших действий
в файле все норм


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Цитата Светлый, 08.07.2018 в 19:00, в сообщении № 8 ()
сумму найти
таки да
эт я не ту формулу в тег засунул
дает поле для дальнейших действий
в файле все норм

Автор - Nic70y
Дата добавления - 08.07.2018 в 19:14
_Boroda_ Дата: Воскресенье, 08.07.2018, 20:11 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если сумму, то
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА(3:99);СТРОКА(3:99)/(B3:B99<>"");B3:B99=G4)*C3:C99<0)*C3:C99)

А первый лист я не заметил. Там так можно
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА(4:99);СТРОКА(4:99)/(A4:A99<>"");--ПРАВБ(A4:A99)=J7)*B4:B99<0)*B4:B99)


Обе немассивные
К сообщению приложен файл: 8414723_2.xlsx(12.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли сумму, то
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА(3:99);СТРОКА(3:99)/(B3:B99<>"");B3:B99=G4)*C3:C99<0)*C3:C99)

А первый лист я не заметил. Там так можно
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА(4:99);СТРОКА(4:99)/(A4:A99<>"");--ПРАВБ(A4:A99)=J7)*B4:B99<0)*B4:B99)


Обе немассивные

Автор - _Boroda_
Дата добавления - 08.07.2018 в 20:11
wifinoob1 Дата: Воскресенье, 08.07.2018, 21:03 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Благодарю вас еще раз за отзывчивость и ваш опыт, товарищи!
 
Ответить
СообщениеБлагодарю вас еще раз за отзывчивость и ваш опыт, товарищи!

Автор - wifinoob1
Дата добавления - 08.07.2018 в 21:03
wifinoob1 Дата: Воскресенье, 08.07.2018, 21:10 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 08.07.2018 в 19:00, в сообщении № 8 ()
Я понял, что надо было сумму найти, а не количество?

Ну вообще моего опыта мало, не смог найти решение поиску данных в пределах объединенных ячеек по вертикали, в моем случае недели, а то что сумма или счат, не так важно, вы мне помогли понять и действовать дальше, благодарю :)
 
Ответить
Сообщение
Цитата Светлый, 08.07.2018 в 19:00, в сообщении № 8 ()
Я понял, что надо было сумму найти, а не количество?

Ну вообще моего опыта мало, не смог найти решение поиску данных в пределах объединенных ячеек по вертикали, в моем случае недели, а то что сумма или счат, не так важно, вы мне помогли понять и действовать дальше, благодарю :)

Автор - wifinoob1
Дата добавления - 08.07.2018 в 21:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных в таблице на основании запроса недели (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!