Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование данных в таблицу из поименованных таблиц внутри - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование данных в таблицу из поименованных таблиц внутри (Иное/Other)
Копирование данных в таблицу из поименованных таблиц внутри
Agro_soft Дата: Вторник, 10.07.2018, 14:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!

Стоит задача по переносу данных из нескольких поименованных таблиц, расположенных на одном листе книги, в другую таблицу на другом листе.
Данные какой поименованной таблицы будут скопированы и вставлены в таблицу на листе будет зависеть от выбранного значения из выпадающего списка.

Например: Имеем выпадающий список с 5 значениями, а так же на соседнем листе имеем 5 поименованных таблиц.
Выбираем "значения таблицы №1" из списка, и рядом со списком на этом же листе появляется таблица с соседнего листа с именем "значения таблицы №1".

Таблица на листе со списком должна быть динамическая, т.е. изменятся в зависимости от выбранного значения в списке.

"файл-образец" прикреплён к сообщению.
 
Ответить
СообщениеДоброго времени суток!

Стоит задача по переносу данных из нескольких поименованных таблиц, расположенных на одном листе книги, в другую таблицу на другом листе.
Данные какой поименованной таблицы будут скопированы и вставлены в таблицу на листе будет зависеть от выбранного значения из выпадающего списка.

Например: Имеем выпадающий список с 5 значениями, а так же на соседнем листе имеем 5 поименованных таблиц.
Выбираем "значения таблицы №1" из списка, и рядом со списком на этом же листе появляется таблица с соседнего листа с именем "значения таблицы №1".

Таблица на листе со списком должна быть динамическая, т.е. изменятся в зависимости от выбранного значения в списке.

"файл-образец" прикреплён к сообщению.

Автор - Agro_soft
Дата добавления - 10.07.2018 в 14:29
китин Дата: Вторник, 10.07.2018, 15:09 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5100
Репутация: 809 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
файл-образец" прикреплён к сообщению.

нетути


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
файл-образец" прикреплён к сообщению.

нетути

Автор - китин
Дата добавления - 10.07.2018 в 15:09
Agro_soft Дата: Вторник, 10.07.2018, 18:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин,
К сообщению приложен файл: 8057416.xlsx(11.4 Kb)
 
Ответить
Сообщениекитин,

Автор - Agro_soft
Дата добавления - 10.07.2018 в 18:28
Nic70y Дата: Вторник, 10.07.2018, 19:21 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4875
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2013
Код
=ПОИСКПОЗ(D4;'Поименованные таблици'!B:B;)
и
Код
=ИНДЕКС()
К сообщению приложен файл: 3891567.xlsx(13.0 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 10.07.2018, 19:22
 
Ответить
Сообщение
Код
=ПОИСКПОЗ(D4;'Поименованные таблици'!B:B;)
и
Код
=ИНДЕКС()

Автор - Nic70y
Дата добавления - 10.07.2018 в 19:21
krosav4ig Дата: Вторник, 10.07.2018, 22:32 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1669
Репутация: 696 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Код
=ИНДЕКС(ДВССЫЛ($D$4;);СТРОКА(A1);СТОЛБЕЦ(A1))
К сообщению приложен файл: 2597395.xlsx(11.7 Kb)


(_)Õvõ(_)
 
Ответить
Сообщение
Код
=ИНДЕКС(ДВССЫЛ($D$4;);СТРОКА(A1);СТОЛБЕЦ(A1))

Автор - krosav4ig
Дата добавления - 10.07.2018 в 22:32
_Boroda_ Дата: Среда, 11.07.2018, 09:41 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ПРОСМОТР(;-1/($D$4='Поименованные таблици'!$B$2:$B$25);'Поименованные таблици'!B2:B25)
К сообщению приложен файл: 8057416_1.xlsx(12.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ПРОСМОТР(;-1/($D$4='Поименованные таблици'!$B$2:$B$25);'Поименованные таблици'!B2:B25)

Автор - _Boroda_
Дата добавления - 11.07.2018 в 09:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование данных в таблицу из поименованных таблиц внутри (Иное/Other)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!