Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Смещаемая ссылка на 1 месяц через 6 столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Смещаемая ссылка на 1 месяц через 6 столбцов (Формулы/Formulas)
Смещаемая ссылка на 1 месяц через 6 столбцов
Rusya807 Дата: Вторник, 17.07.2018, 11:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, очень нужна помощь
Есть - сводный отчет в разрезе предприятий по месяцам, формулы прописаны через формулу - суммаеслимн- выбор идет из базы операций по предприятию, по статье и по месяцу, но так как формул много, а месяцев 12, придется в каждом месяце менять ссылку на период, которая находиться в строчке 1, если я убираю $
пример формулы из свода который есть в данный момент:
Код
ЕСЛИОШИБКА(СУММЕСЛИМН('3. Base'!$P:$P;'3. Base'!$S:$S;[u]$C$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5)+СУММЕСЛИМН('3. Base'!$Q:$Q;'3. Base'!$S:$S;[u]$C$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5);0)


Нужно что бы в формуле С1 менялось на I1 при копировании

Код
ЕСЛИОШИБКА(СУММЕСЛИМН('3. Base'!$P:$P;'3. Base'!$S:$S;[u]$I$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5)+СУММЕСЛИМН('3. Base'!$Q:$Q;'3. Base'!$S:$S;[u]$I$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5);0)


проблема в подчеркнутой ячейки
в ней должна меняться только буква - C, I, O, U и т.д. цифра всегда должна быть 1
нужно что бы при копировании в формуле был дописан шаг смещения , так как наличие и отсутствие $ не спасает, шаг состоит из 5 граф предприятий

буду очень благодарна и надеюсь, что понятно написала :(
К сообщению приложен файл: 7870178.rar(16.8 Kb)


Сообщение отредактировал Rusya807 - Вторник, 17.07.2018, 11:39
 
Ответить
СообщениеДобрый день, очень нужна помощь
Есть - сводный отчет в разрезе предприятий по месяцам, формулы прописаны через формулу - суммаеслимн- выбор идет из базы операций по предприятию, по статье и по месяцу, но так как формул много, а месяцев 12, придется в каждом месяце менять ссылку на период, которая находиться в строчке 1, если я убираю $
пример формулы из свода который есть в данный момент:
Код
ЕСЛИОШИБКА(СУММЕСЛИМН('3. Base'!$P:$P;'3. Base'!$S:$S;[u]$C$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5)+СУММЕСЛИМН('3. Base'!$Q:$Q;'3. Base'!$S:$S;[u]$C$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5);0)


Нужно что бы в формуле С1 менялось на I1 при копировании

Код
ЕСЛИОШИБКА(СУММЕСЛИМН('3. Base'!$P:$P;'3. Base'!$S:$S;[u]$I$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5)+СУММЕСЛИМН('3. Base'!$Q:$Q;'3. Base'!$S:$S;[u]$I$1[/u];'3. Base'!$M:$M;D$2;'3. Base'!$R:$R;$B5);0)


проблема в подчеркнутой ячейки
в ней должна меняться только буква - C, I, O, U и т.д. цифра всегда должна быть 1
нужно что бы при копировании в формуле был дописан шаг смещения , так как наличие и отсутствие $ не спасает, шаг состоит из 5 граф предприятий

буду очень благодарна и надеюсь, что понятно написала :(

Автор - Rusya807
Дата добавления - 17.07.2018 в 11:07
_Boroda_ Дата: Вторник, 17.07.2018, 11:47 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13196
Репутация: 5426 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я думаю, что проще всего добавить справа два пустых столбца и написать вот такую формулу
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН(база!$P:$P;база!$S:$S;СУММ(A$1:F$1);база!$M:$M;F$2;база!$R:$R;$D3)+СУММЕСЛИМН(база!$Q:$Q;база!$S:$S;СУММ(A$1:F$1);база!$M:$M;F$2;база!$R:$R;$D3);0)

Можно не добавлять и написать вот так
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН(база!$P:$P;база!$S:$S;ПРОСМОТР(9^9;$C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3)+СУММЕСЛИМН(база!$Q:$Q;база!$S:$S;ПРОСМОТР(9^9;$C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3);0)

или так
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН(база!$P:$P;база!$S:$S;МАКС($C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3)+СУММЕСЛИМН(база!$Q:$Q;база!$S:$S;МАКС($C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3);0)
К сообщению приложен файл: 9127970.xlsb(20.1 Kb) · _2.xlsb(20.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ думаю, что проще всего добавить справа два пустых столбца и написать вот такую формулу
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН(база!$P:$P;база!$S:$S;СУММ(A$1:F$1);база!$M:$M;F$2;база!$R:$R;$D3)+СУММЕСЛИМН(база!$Q:$Q;база!$S:$S;СУММ(A$1:F$1);база!$M:$M;F$2;база!$R:$R;$D3);0)

Можно не добавлять и написать вот так
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН(база!$P:$P;база!$S:$S;ПРОСМОТР(9^9;$C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3)+СУММЕСЛИМН(база!$Q:$Q;база!$S:$S;ПРОСМОТР(9^9;$C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3);0)

или так
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН(база!$P:$P;база!$S:$S;МАКС($C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3)+СУММЕСЛИМН(база!$Q:$Q;база!$S:$S;МАКС($C$1:D$1);база!$M:$M;D$2;база!$R:$R;$B3);0)

Автор - _Boroda_
Дата добавления - 17.07.2018 в 11:47
Rusya807 Дата: Вторник, 17.07.2018, 12:06 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Я думаю, что проще всего добавить справа два пустых столбца и написать вот такую формулу


в обычном екселе считают эти формулы, а в гугл диске нет, в чем может быть подвох?
 
Ответить
Сообщение
Я думаю, что проще всего добавить справа два пустых столбца и написать вот такую формулу


в обычном екселе считают эти формулы, а в гугл диске нет, в чем может быть подвох?

Автор - Rusya807
Дата добавления - 17.07.2018 в 12:06
abtextime Дата: Вторник, 17.07.2018, 12:12 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
в гугл диске нет, в чем может быть подвох?

И в Ворде эти формулы почему-то не работают. Ничего не понимаю! Загадка! :D
 
Ответить
Сообщение
в гугл диске нет, в чем может быть подвох?

И в Ворде эти формулы почему-то не работают. Ничего не понимаю! Загадка! :D

Автор - abtextime
Дата добавления - 17.07.2018 в 12:12
Rusya807 Дата: Вторник, 17.07.2018, 12:15 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
abtextime, при чем тут ворд

рассматривается ексель, логично что можно создать ексель и на гугл диске


Сообщение отредактировал Rusya807 - Вторник, 17.07.2018, 12:15
 
Ответить
Сообщениеabtextime, при чем тут ворд

рассматривается ексель, логично что можно создать ексель и на гугл диске

Автор - Rusya807
Дата добавления - 17.07.2018 в 12:15
_Boroda_ Дата: Вторник, 17.07.2018, 12:22 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13196
Репутация: 5426 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Наверное в том дело, что это Гугл, а не Excel.
Попробуйте заменить СУММЕСЛИМН на СУММПРОИЗВ. Но только не делайте ссылки на весь столбец
Как-то примерно так
Код
=СУММПРОИЗВ((база!$P$5:$P$99+база!$Q$5:$Q$99)*(база!$S$5:$S$99=МАКС($C$1:D$1))*(база!$M$5:$M$99=D$2)*(база!$R$5:$R$99=$B3))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНаверное в том дело, что это Гугл, а не Excel.
Попробуйте заменить СУММЕСЛИМН на СУММПРОИЗВ. Но только не делайте ссылки на весь столбец
Как-то примерно так
Код
=СУММПРОИЗВ((база!$P$5:$P$99+база!$Q$5:$Q$99)*(база!$S$5:$S$99=МАКС($C$1:D$1))*(база!$M$5:$M$99=D$2)*(база!$R$5:$R$99=$B3))

Автор - _Boroda_
Дата добавления - 17.07.2018 в 12:22
Rusya807 Дата: Вторник, 17.07.2018, 15:01 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Спасибо огромное за помощь, формула красиво отражать нужную инфу гугл екселе


Сообщение отредактировал _Boroda_ - Вторник, 17.07.2018, 16:17
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Спасибо огромное за помощь, формула красиво отражать нужную инфу гугл екселе

Автор - Rusya807
Дата добавления - 17.07.2018 в 15:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Смещаемая ссылка на 1 месяц через 6 столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!