Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как разбить по столбцам и не затереть нужные данные? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разбить по столбцам и не затереть нужные данные? (Формулы/Formulas)
Как разбить по столбцам и не затереть нужные данные?
borus Дата: Вторник, 17.07.2018, 16:36 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

2007
Здравствуйте!

В прилагаемом файле требуется разбить значения в первом столбце по столбцам, опираясь на разделитель в виде точки. Если делать в лоб(выделить первый столбец и выбрать "Текст по столбцам"), то будут затерты значения второго столбца там, где они есть. Можно ли как-то полуавтоматизировано разбить значения по стобцам, оставив те строки, где нет значений, содержащих точки?
К сообщению приложен файл: 1193116.xlsx(9.9 Kb)


желаю вам счастья
 
Ответить
СообщениеЗдравствуйте!

В прилагаемом файле требуется разбить значения в первом столбце по столбцам, опираясь на разделитель в виде точки. Если делать в лоб(выделить первый столбец и выбрать "Текст по столбцам"), то будут затерты значения второго столбца там, где они есть. Можно ли как-то полуавтоматизировано разбить значения по стобцам, оставив те строки, где нет значений, содержащих точки?

Автор - borus
Дата добавления - 17.07.2018 в 16:36
_Boroda_ Дата: Вторник, 17.07.2018, 16:47 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12743
Репутация: 5225 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно в соседнем столбце
Код
=ЕСЛИ(ПСТР(A2;2;1)=".";ЛЕВБ(A2;2);A2)
или
Код
=ЕСЛИ(ПРАВБ(A2)=".";ЛЕВБ(A2;2);A2)

и в следующем
Код
=ЕСЛИ(ПСТР(A2;2;1)=".";ПРАВБ(A2;2);B2)
или
Код
=ЕСЛИ(ПРАВБ(A2)=".";ПРАВБ(A2;2);B2)


Или макросом
К сообщению приложен файл: 1193116_1.xlsx(11.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно в соседнем столбце
Код
=ЕСЛИ(ПСТР(A2;2;1)=".";ЛЕВБ(A2;2);A2)
или
Код
=ЕСЛИ(ПРАВБ(A2)=".";ЛЕВБ(A2;2);A2)

и в следующем
Код
=ЕСЛИ(ПСТР(A2;2;1)=".";ПРАВБ(A2;2);B2)
или
Код
=ЕСЛИ(ПРАВБ(A2)=".";ПРАВБ(A2;2);B2)


Или макросом

Автор - _Boroda_
Дата добавления - 17.07.2018 в 16:47
borus Дата: Вторник, 17.07.2018, 16:59 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

2007
Спасибо!
А как в столбце с отчеством не брать завершающую точку? Для имени я догодался


желаю вам счастья
 
Ответить
СообщениеСпасибо!
А как в столбце с отчеством не брать завершающую точку? Для имени я догодался

Автор - borus
Дата добавления - 17.07.2018 в 16:59
_Boroda_ Дата: Вторник, 17.07.2018, 17:03 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12743
Репутация: 5225 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИ(ПРАВБ(A2)=".";ЛЕВБ(A2);A2)

Код
=ЕСЛИ(ПРАВБ(A2)=".";ПСТР(A1;3;1);B2)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИ(ПРАВБ(A2)=".";ЛЕВБ(A2);A2)

Код
=ЕСЛИ(ПРАВБ(A2)=".";ПСТР(A1;3;1);B2)

Автор - _Boroda_
Дата добавления - 17.07.2018 в 17:03
borus Дата: Вторник, 17.07.2018, 17:08 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

2007
Спасибо!


желаю вам счастья
 
Ответить
СообщениеСпасибо!

Автор - borus
Дата добавления - 17.07.2018 в 17:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разбить по столбцам и не затереть нужные данные? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!