Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в диапазоне по нескольким критериям и вывод результата - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в диапазоне по нескольким критериям и вывод результата (Формулы/Formulas)
Поиск в диапазоне по нескольким критериям и вывод результата
parovoznik Дата: Четверг, 19.07.2018, 21:17 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 264
Репутация: 16 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер.
Прошу помочь в решении проблемы составлении формулы для подсчета тарифа по нескольким критериям.
Вводим расстояние , вес груза и выбираем принадлежность транспортного средства(общий,собственный или арендованный) и в зависимости от выбранных критериев ищем тариф на перевозку.
В прилагаемом файле описал проблему.
К сообщению приложен файл: _1.xlsm(19.9 Kb)
 
Ответить
СообщениеДобрый вечер.
Прошу помочь в решении проблемы составлении формулы для подсчета тарифа по нескольким критериям.
Вводим расстояние , вес груза и выбираем принадлежность транспортного средства(общий,собственный или арендованный) и в зависимости от выбранных критериев ищем тариф на перевозку.
В прилагаемом файле описал проблему.

Автор - parovoznik
Дата добавления - 19.07.2018 в 21:17
_Boroda_ Дата: Четверг, 19.07.2018, 21:40 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13705
Репутация: 5588 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? (в I3:К3 лишний пробел)
Код
=ИНДЕКС(I4:N30;ПОИСКПОЗ(A3;G4:G30);ПОИСКПОЗ(B3+2;I2:K2)+3*(C3<>I3))

Не понял написанного сбоку в А4:А5. Если понял, то
Код
=ИНДЕКС(I4:N30;ПОИСКПОЗ(A3;G4:G30);ЕСЛИ(C3<>I3;6;ПОИСКПОЗ(B3+2;I2:K2)))
К сообщению приложен файл: _1_2.xlsm(20.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? (в I3:К3 лишний пробел)
Код
=ИНДЕКС(I4:N30;ПОИСКПОЗ(A3;G4:G30);ПОИСКПОЗ(B3+2;I2:K2)+3*(C3<>I3))

Не понял написанного сбоку в А4:А5. Если понял, то
Код
=ИНДЕКС(I4:N30;ПОИСКПОЗ(A3;G4:G30);ЕСЛИ(C3<>I3;6;ПОИСКПОЗ(B3+2;I2:K2)))

Автор - _Boroda_
Дата добавления - 19.07.2018 в 21:40
parovoznik Дата: Четверг, 19.07.2018, 21:58 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 264
Репутация: 16 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, все верно. Только теперь надо разобраться .как это работает :ПОИСКПОЗ(B3+2;I2:K2)+3*(C3<>I3)) ?
в А4:А5 я пытался описать ,как должно быть.
Сейчас протестировал : расстояние -215км ,вес 66 тн ,принадлежность -"собственный" ,то на формулах выдает два значения и оба разные, правильно :2406.
К сообщению приложен файл: 6610254.xlsm(18.8 Kb)


Сообщение отредактировал parovoznik - Четверг, 19.07.2018, 22:10
 
Ответить
Сообщение_Boroda_, все верно. Только теперь надо разобраться .как это работает :ПОИСКПОЗ(B3+2;I2:K2)+3*(C3<>I3)) ?
в А4:А5 я пытался описать ,как должно быть.
Сейчас протестировал : расстояние -215км ,вес 66 тн ,принадлежность -"собственный" ,то на формулах выдает два значения и оба разные, правильно :2406.

Автор - parovoznik
Дата добавления - 19.07.2018 в 21:58
_Boroda_ Дата: Четверг, 19.07.2018, 22:21 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13705
Репутация: 5588 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
как это работает :ПОИСКПОЗ(B3+2;I2:K2)+3*(C3<>I3))
Обычный ПОИСКПОЗ без 3-го аргумента и плюс 3 столбца вправо если не общая принадлежность
два значения и оба разные, правильно :2406
Тогда берите первую формулу. Я просто не знал что Вам нужно и сделал 2 варианта разных


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
как это работает :ПОИСКПОЗ(B3+2;I2:K2)+3*(C3<>I3))
Обычный ПОИСКПОЗ без 3-го аргумента и плюс 3 столбца вправо если не общая принадлежность
два значения и оба разные, правильно :2406
Тогда берите первую формулу. Я просто не знал что Вам нужно и сделал 2 варианта разных

Автор - _Boroda_
Дата добавления - 19.07.2018 в 22:21
parovoznik Дата: Четверг, 19.07.2018, 22:30 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 264
Репутация: 16 ±
Замечаний: 0% ±

Excel 2007
Хорошо ,но заметил если выбирать "Общий",то оба результата верны . :)
А можно добавить в формулу если вес перевозимого груза меньше 58 или больше 72 то расчета нет или 0.


Сообщение отредактировал parovoznik - Четверг, 19.07.2018, 22:36
 
Ответить
СообщениеХорошо ,но заметил если выбирать "Общий",то оба результата верны . :)
А можно добавить в формулу если вес перевозимого груза меньше 58 или больше 72 то расчета нет или 0.

Автор - parovoznik
Дата добавления - 19.07.2018 в 22:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в диапазоне по нескольким критериям и вывод результата (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!