Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вычисление качества работы оператора по критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вычисление качества работы оператора по критериям (Формулы/Formulas)
вычисление качества работы оператора по критериям
k987 Дата: Суббота, 21.07.2018, 19:37 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Помогите, пожалуйста, с такой ситуацией. Я оцениваю работу оператора контакт центра по определенным критериям. Ранее, если какой-то критерий отсутствовал, он оценивался максимальной оценкой (т.е. отсутствие ошибки). Формулу я написала тогда без проблем. Сейчас, если критерий не оценивается, я должна ставить "Н". Его вес распределяется на весь блок (т.е. оценка не должна снижаться). Тут формула у меня не выходит. Можно конечно просуммировать 13 раз формулу "ЕСЛИ", но возможно есть более изящное решение. Заранее благодарю за помощь! Файл прилагаю
К сообщению приложен файл: 5606461.xlsx(20.0 Kb)
 
Ответить
СообщениеДобрый день! Помогите, пожалуйста, с такой ситуацией. Я оцениваю работу оператора контакт центра по определенным критериям. Ранее, если какой-то критерий отсутствовал, он оценивался максимальной оценкой (т.е. отсутствие ошибки). Формулу я написала тогда без проблем. Сейчас, если критерий не оценивается, я должна ставить "Н". Его вес распределяется на весь блок (т.е. оценка не должна снижаться). Тут формула у меня не выходит. Можно конечно просуммировать 13 раз формулу "ЕСЛИ", но возможно есть более изящное решение. Заранее благодарю за помощь! Файл прилагаю

Автор - k987
Дата добавления - 21.07.2018 в 19:37
Pelena Дата: Суббота, 21.07.2018, 19:47 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13298
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Файл запаролен


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл запаролен

Автор - Pelena
Дата добавления - 21.07.2018 в 19:47
k987 Дата: Суббота, 21.07.2018, 20:05 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

Ой, извините
К сообщению приложен файл: 5131246.xlsx(12.3 Kb)
 
Ответить
СообщениеОй, извините

Автор - k987
Дата добавления - 21.07.2018 в 20:05
Светлый Дата: Суббота, 21.07.2018, 20:21 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 747
Репутация: 198 ±
Замечаний: 0% ±

Excel 2010
Возможно, такая формула устроит:
Код
=ЕСЛИ(B6="";"";(СУММПРОИЗВ(ЕСЛИ(C6:Q6="н";1;C6:Q6);$C$4:$Q$4)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВозможно, такая формула устроит:
Код
=ЕСЛИ(B6="";"";(СУММПРОИЗВ(ЕСЛИ(C6:Q6="н";1;C6:Q6);$C$4:$Q$4)))

Автор - Светлый
Дата добавления - 21.07.2018 в 20:21
gling Дата: Суббота, 21.07.2018, 22:37 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1824
Репутация: 452 ±
Замечаний: 0% ±

2010
Еще вариант формулы массива
Код
=ЕСЛИ(B6="";"";СУММ(ЕСЛИОШИБКА(C6:Q6*$C$4:$Q$4;$C$4:$Q$4)))


ЯД-41001506838083
 
Ответить
СообщениеЕще вариант формулы массива
Код
=ЕСЛИ(B6="";"";СУММ(ЕСЛИОШИБКА(C6:Q6*$C$4:$Q$4;$C$4:$Q$4)))

Автор - gling
Дата добавления - 21.07.2018 в 22:37
k987 Дата: Воскресенье, 22.07.2018, 22:09 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное. Это то, что нужно!
 
Ответить
СообщениеСпасибо огромное. Это то, что нужно!

Автор - k987
Дата добавления - 22.07.2018 в 22:09
k987 Дата: Воскресенье, 22.07.2018, 22:17 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

gling, А ВЫ могли бы объяснить как работает формула, чтобы понимать суть, а не просто как обезьянка подставлять значения :).
 
Ответить
Сообщениеgling, А ВЫ могли бы объяснить как работает формула, чтобы понимать суть, а не просто как обезьянка подставлять значения :).

Автор - k987
Дата добавления - 22.07.2018 в 22:17
gling Дата: Воскресенье, 22.07.2018, 22:30 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1824
Репутация: 452 ±
Замечаний: 0% ±

2010
Попробуйте посмотреть её работу пошагово. Активируйте ячейку с формулой--на вкладке Формулы--Вычислить формулу--Вычислить. Объяснение такое: С6*С4; D6*D4;....Q6*Q4, если при умножении произошла ошибка (т.е. число умножаем на текст (буква Н=тект)),то подставляется число из строки 4 соответствующего столбца, умножать его на 1 не нужно, результат будет тот же, а далее весь этот массив полученных чисел складывается функцией СУММ(). Как то так, как смог, я не специалист по объяснениям.


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 22.07.2018, 22:32
 
Ответить
СообщениеПопробуйте посмотреть её работу пошагово. Активируйте ячейку с формулой--на вкладке Формулы--Вычислить формулу--Вычислить. Объяснение такое: С6*С4; D6*D4;....Q6*Q4, если при умножении произошла ошибка (т.е. число умножаем на текст (буква Н=тект)),то подставляется число из строки 4 соответствующего столбца, умножать его на 1 не нужно, результат будет тот же, а далее весь этот массив полученных чисел складывается функцией СУММ(). Как то так, как смог, я не специалист по объяснениям.

Автор - gling
Дата добавления - 22.07.2018 в 22:30
_Boroda_ Дата: Воскресенье, 22.07.2018, 22:37 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13661
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ольга, возможно вот так понятнее будет? Немассивная формула
Код
=ЕСЛИ(A6;СУММПРОИЗВ(ПОДСТАВИТЬ(C6:Q6;"н";1)*C$4:Q$4);"")
К сообщению приложен файл: 5131246_1.xlsx(12.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОльга, возможно вот так понятнее будет? Немассивная формула
Код
=ЕСЛИ(A6;СУММПРОИЗВ(ПОДСТАВИТЬ(C6:Q6;"н";1)*C$4:Q$4);"")

Автор - _Boroda_
Дата добавления - 22.07.2018 в 22:37
k987 Дата: Понедельник, 23.07.2018, 08:07 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

gling, _Boroda_, спасибо большое за помощь!
 
Ответить
Сообщениеgling, _Boroda_, спасибо большое за помощь!

Автор - k987
Дата добавления - 23.07.2018 в 08:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вычисление качества работы оператора по критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!