Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка к диапазонам дат соответствующей ключ.ставки ЦБ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка к диапазонам дат соответствующей ключ.ставки ЦБ (Формулы/Formulas)
Подстановка к диапазонам дат соответствующей ключ.ставки ЦБ
fitnesstrener Дата: Понедельник, 23.07.2018, 21:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, уважаемые Форумчане!
Помогите, пожалуйста, формулой, которая позволит решить следующую задачку:
Дано:
Ключевая ставка ЦБ, которая иногда по каким то датам пересматривается.
Диапазоны дат, периоды (в примере, это недели), на которые распространяется действие этой самой ставки.

Задача:
Присвоить каждому диапазону дат в таблице соответствующую актуальную Ключевую ставку ЦБ, действующую на даты, которые включают в себя эти самые диапазоны дат.

Постарался максимально просто описать всё в файле.
Всем благодарность за любую помощь в решении задачи!
К сообщению приложен файл: 5725637.xls(32.0 Kb)
 
Ответить
СообщениеДоброго дня, уважаемые Форумчане!
Помогите, пожалуйста, формулой, которая позволит решить следующую задачку:
Дано:
Ключевая ставка ЦБ, которая иногда по каким то датам пересматривается.
Диапазоны дат, периоды (в примере, это недели), на которые распространяется действие этой самой ставки.

Задача:
Присвоить каждому диапазону дат в таблице соответствующую актуальную Ключевую ставку ЦБ, действующую на даты, которые включают в себя эти самые диапазоны дат.

Постарался максимально просто описать всё в файле.
Всем благодарность за любую помощь в решении задачи!

Автор - fitnesstrener
Дата добавления - 23.07.2018 в 21:47
_Boroda_ Дата: Понедельник, 23.07.2018, 22:08 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13245
Репутация: 5454 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(H$3:H$99;СЧЁТЕСЛИ(G$3:G$99;">"&C3)+1)

А почему с 17.06 пусто? Там же действует ставка от 15.06
К сообщению приложен файл: 5725637_1.xls(35.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(H$3:H$99;СЧЁТЕСЛИ(G$3:G$99;">"&C3)+1)

А почему с 17.06 пусто? Там же действует ставка от 15.06

Автор - _Boroda_
Дата добавления - 23.07.2018 в 22:08
fitnesstrener Дата: Понедельник, 23.07.2018, 22:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, благодарю за помощь! Вы мне очень помогли! Решение оригинальное и простое. Думал, что без формулы массива тут не обойтись было... ан нет. Без массива получилось! Благодарю Вас!!!
 
Ответить
Сообщение_Boroda_, благодарю за помощь! Вы мне очень помогли! Решение оригинальное и простое. Думал, что без формулы массива тут не обойтись было... ан нет. Без массива получилось! Благодарю Вас!!!

Автор - fitnesstrener
Дата добавления - 23.07.2018 в 22:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка к диапазонам дат соответствующей ключ.ставки ЦБ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!