Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Прибавление к дате с учетом праздников и раб дней в выходные - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Прибавление к дате с учетом праздников и раб дней в выходные (Формулы/Formulas)
Прибавление к дате с учетом праздников и раб дней в выходные
supercelt Дата: Вторник, 24.07.2018, 18:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет! Подскажите пожалуйста. Я расчитываю график работы. У нас выходные впринципе совпадают с государственными но встречаются свои переносы. Вот у меня есть ячейка с датой окончания работ - 13,12,2019. Ввод в эксплуатацию у нас осуществляется спустя 7 дней. Я специально моделирую что 20 декабря 19г - это праздник, но 21 - суббота объявлена рабочей. Функция рабдень вернёт мне 23 декабря, а надо вернуть 21, так как это объявлен рабочий день. Я находил примеры где надо завести таблицу датами праздников и с датами дней выходных на которые выпадают рабочие дни. Но я не понимаю сам расчёт. Что надо делать и как. Пример из инета
Код
=ЕСЛИ(ЕНД(ВПР(A5;Рабочие_дни;1;ЛОЖЬ));РАБДЕНЬ(A5-1;1;Праздники);A5)


в А5 - исходная дата. Раб дни - там перечислены даты раб дней, которые выпадают на выходные, Праздники - там забиты праздники. И ещё эта формула выдают следующий рабочий день. А мне надо на 7 вперёд. И непонятно зачем в формуле из А5 вычитают 1. Как мне это реализовать?
 
Ответить
СообщениеВсем привет! Подскажите пожалуйста. Я расчитываю график работы. У нас выходные впринципе совпадают с государственными но встречаются свои переносы. Вот у меня есть ячейка с датой окончания работ - 13,12,2019. Ввод в эксплуатацию у нас осуществляется спустя 7 дней. Я специально моделирую что 20 декабря 19г - это праздник, но 21 - суббота объявлена рабочей. Функция рабдень вернёт мне 23 декабря, а надо вернуть 21, так как это объявлен рабочий день. Я находил примеры где надо завести таблицу датами праздников и с датами дней выходных на которые выпадают рабочие дни. Но я не понимаю сам расчёт. Что надо делать и как. Пример из инета
Код
=ЕСЛИ(ЕНД(ВПР(A5;Рабочие_дни;1;ЛОЖЬ));РАБДЕНЬ(A5-1;1;Праздники);A5)


в А5 - исходная дата. Раб дни - там перечислены даты раб дней, которые выпадают на выходные, Праздники - там забиты праздники. И ещё эта формула выдают следующий рабочий день. А мне надо на 7 вперёд. И непонятно зачем в формуле из А5 вычитают 1. Как мне это реализовать?

Автор - supercelt
Дата добавления - 24.07.2018 в 18:37
ASWP Дата: Вторник, 24.07.2018, 19:06 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
supercelt, Добрый день. Приложите файл пример.


я знаю что ничего не знаю, но другие не знают и этого
 
Ответить
Сообщениеsupercelt, Добрый день. Приложите файл пример.

Автор - ASWP
Дата добавления - 24.07.2018 в 19:06
Pelena Дата: Вторник, 24.07.2018, 19:22 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12906
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
мне надо на 7 вперёд

Код
=ЕСЛИ(ЕНД(ВПР(A1+7;Рабочие_дни;1;ЛОЖЬ));РАБДЕНЬ(A1+6;1;Праздники);A1+7)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
мне надо на 7 вперёд

Код
=ЕСЛИ(ЕНД(ВПР(A1+7;Рабочие_дни;1;ЛОЖЬ));РАБДЕНЬ(A1+6;1;Праздники);A1+7)

Автор - Pelena
Дата добавления - 24.07.2018 в 19:22
supercelt Дата: Среда, 25.07.2018, 08:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Всё-равно 23 показывает
=ЕСЛИ( ЕНД( ВПР( NH12+7 ; Календарь!B4:B29 ; 1 ; ЛОЖЬ) ) ; РАБДЕНЬ( NH12+6 ; 1 ; Календарь!A4:A29 ) ; NH12+7 )

В ячейках В - даты рабочих дней, выпадающих на выходные, в А - даты праздников
 
Ответить
СообщениеPelena, Всё-равно 23 показывает
=ЕСЛИ( ЕНД( ВПР( NH12+7 ; Календарь!B4:B29 ; 1 ; ЛОЖЬ) ) ; РАБДЕНЬ( NH12+6 ; 1 ; Календарь!A4:A29 ) ; NH12+7 )

В ячейках В - даты рабочих дней, выпадающих на выходные, в А - даты праздников

Автор - supercelt
Дата добавления - 25.07.2018 в 08:59
Pelena Дата: Среда, 25.07.2018, 09:03 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12906
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
supercelt, оформите формулу тегами с помощью кнопки fx в режиме правки поста.
И файл приложите с датами, праздниками и рабочими выходными


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеsupercelt, оформите формулу тегами с помощью кнопки fx в режиме правки поста.
И файл приложите с датами, праздниками и рабочими выходными

Автор - Pelena
Дата добавления - 25.07.2018 в 09:03
supercelt Дата: Среда, 25.07.2018, 10:54 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Код
=ЕСЛИ(ЕНД(ВПР(A2+7;D2:D27;1;ЛОЖЬ));РАБДЕНЬ(A2+6;1;C2:C27);A2+7)

Вложить файл не получилось, так как меньше 200 кб сделать никак, поэтому залил на обменник
Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума
[moder]Скопируйте данные в новый файл. У меня новый файл с Вашими данными весит 9 кб[/moder]
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕНД(ВПР(A2+7;D2:D27;1;ЛОЖЬ));РАБДЕНЬ(A2+6;1;C2:C27);A2+7)

Вложить файл не получилось, так как меньше 200 кб сделать никак, поэтому залил на обменник
Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума
[moder]Скопируйте данные в новый файл. У меня новый файл с Вашими данными весит 9 кб[/moder]

Автор - supercelt
Дата добавления - 25.07.2018 в 10:54
_Boroda_ Дата: Среда, 25.07.2018, 11:25 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12761
Репутация: 5228 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня Ваш файл весит 9кб после переноса данных в новую книгу. Ссылка удалана - это нарушение Правил форума

По поводу 7 дней - не учитываются только праздники? Обычные выходные (сб и вск) считаются в эти 7 дней? Если да, то столбец "Рабочие дни, которые ..." не нужен, нужен только список праздников. Если же выходные учитываются, то как у Вас получилось с 12/12/19 + 7 рабочих дней = 21/12/19 (с учетом того, что 20/12/19 - праздник, а 21/12/19 - рабочий)?
13, 16, 17, 18, 19, 21, 23 - седьмой день (первым считая 13 число) будет 23 число


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня Ваш файл весит 9кб после переноса данных в новую книгу. Ссылка удалана - это нарушение Правил форума

По поводу 7 дней - не учитываются только праздники? Обычные выходные (сб и вск) считаются в эти 7 дней? Если да, то столбец "Рабочие дни, которые ..." не нужен, нужен только список праздников. Если же выходные учитываются, то как у Вас получилось с 12/12/19 + 7 рабочих дней = 21/12/19 (с учетом того, что 20/12/19 - праздник, а 21/12/19 - рабочий)?
13, 16, 17, 18, 19, 21, 23 - седьмой день (первым считая 13 число) будет 23 число

Автор - _Boroda_
Дата добавления - 25.07.2018 в 11:25
supercelt Дата: Среда, 25.07.2018, 11:34 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Когда я перенёс в новую книгу у меня весило 5 мб и предупреждение вылезло что при сохранеии будет утеряна какая-то совместимость. Изначальная дата не 12, а 13 декабря 19 года. Прибавляем 7 дней не рабочих, а всех, с учётом и выходных. Попадаем на 20 число. Но для проверки я намеренно указал что это праздничный день как бы, потому что это одно из условий, что любой день могут сделать выходной, а выходной - рабочим. раз попали на 20 число, то ф-ия рабдень поняла что это праздник и вернула 23 декабря, ближайший раб день - понедельник. НО у меня же в списке рабочих дней в праздники и выходные специально стоит 21 декабря. Поэтому формула должна вывести именно 21, потому что получается что 21 это следующий рабочий день после праздника 20 дек (по нашим внутренним законам)
К сообщению приложен файл: 1224757.xls(24.0 Kb)


Сообщение отредактировал supercelt - Среда, 25.07.2018, 12:08
 
Ответить
СообщениеКогда я перенёс в новую книгу у меня весило 5 мб и предупреждение вылезло что при сохранеии будет утеряна какая-то совместимость. Изначальная дата не 12, а 13 декабря 19 года. Прибавляем 7 дней не рабочих, а всех, с учётом и выходных. Попадаем на 20 число. Но для проверки я намеренно указал что это праздничный день как бы, потому что это одно из условий, что любой день могут сделать выходной, а выходной - рабочим. раз попали на 20 число, то ф-ия рабдень поняла что это праздник и вернула 23 декабря, ближайший раб день - понедельник. НО у меня же в списке рабочих дней в праздники и выходные специально стоит 21 декабря. Поэтому формула должна вывести именно 21, потому что получается что 21 это следующий рабочий день после праздника 20 дек (по нашим внутренним законам)

Автор - supercelt
Дата добавления - 25.07.2018 в 11:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Прибавление к дате с учетом праздников и раб дней в выходные (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!