Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как написать функцию искать от определенного символа до друг - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как написать функцию искать от определенного символа до друг (Формулы/Formulas)
Как написать функцию искать от определенного символа до друг
Alexodiy Дата: Среда, 25.07.2018, 18:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток. Ребят подскажите пожалуйста как сделать такую функцию - Найти в ячейке слово и перенести до определенного символа

Я использую это =ЕСЛИОШИБКА(ПСТР(A1;ПОИСК("ля-ля";A1);ПОИСК("|";A1)-ПОИСК("ля-ля";A1));"") , но немного не работает и не совсем то что нужно...

Разберем на конкретном примере - загрузил файл. Вот смотрите в первом столбце, надо от "Обои>" до символа "|" вставить в ячейку B ...

Ребята, помогите пожалуйста, я уже целый день разобраться могу с этим
К сообщению приложен файл: 3446450.xls(29.0 Kb)
 
Ответить
СообщениеДоброго времени суток. Ребят подскажите пожалуйста как сделать такую функцию - Найти в ячейке слово и перенести до определенного символа

Я использую это =ЕСЛИОШИБКА(ПСТР(A1;ПОИСК("ля-ля";A1);ПОИСК("|";A1)-ПОИСК("ля-ля";A1));"") , но немного не работает и не совсем то что нужно...

Разберем на конкретном примере - загрузил файл. Вот смотрите в первом столбце, надо от "Обои>" до символа "|" вставить в ячейку B ...

Ребята, помогите пожалуйста, я уже целый день разобраться могу с этим

Автор - Alexodiy
Дата добавления - 25.07.2018 в 18:40
Nic70y Дата: Среда, 25.07.2018, 18:46 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4847
Репутация: 1050 ±
Замечаний: 0% ±

Excel 2013
засуньте пожалуйста формулу в тЭг
Код
=СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("Обои>";A2);745);"|";ПОВТОР(" ";743));747))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениезасуньте пожалуйста формулу в тЭг
Код
=СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("Обои>";A2);745);"|";ПОВТОР(" ";743));747))

Автор - Nic70y
Дата добавления - 25.07.2018 в 18:46
Alexodiy Дата: Среда, 25.07.2018, 18:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016

Ранг: Участник клуба
Сообщений: 4703
Репутация: 1011 ±
Замечаний: 0% ±

Excel 2013
засуньте пожалуйста формулу в тЭг


работает... Спасибо. А можно как то сделать несколько ключевых слов сделать, допустим копировать из ячейки 2ва ключевых слова, вытянуть "Обои>" и "Винил" к примеру...
 
Ответить
Сообщение

Ранг: Участник клуба
Сообщений: 4703
Репутация: 1011 ±
Замечаний: 0% ±

Excel 2013
засуньте пожалуйста формулу в тЭг


работает... Спасибо. А можно как то сделать несколько ключевых слов сделать, допустим копировать из ячейки 2ва ключевых слова, вытянуть "Обои>" и "Винил" к примеру...

Автор - Alexodiy
Дата добавления - 25.07.2018 в 18:54
Nic70y Дата: Среда, 25.07.2018, 18:58 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4847
Репутация: 1050 ±
Замечаний: 0% ±

Excel 2013
все можно,
тока у нас модераторы злые
и мне навещают %)
5j правил,
а так же
http://www.excelworld.ru/forum/13-2708-1


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевсе можно,
тока у нас модераторы злые
и мне навещают %)
5j правил,
а так же
http://www.excelworld.ru/forum/13-2708-1

Автор - Nic70y
Дата добавления - 25.07.2018 в 18:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как написать функцию искать от определенного символа до друг (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!