Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка и поиск заданных значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка и поиск заданных значений (Формулы/Formulas)
Подстановка и поиск заданных значений
soly Дата: Пятница, 27.07.2018, 19:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Берется значение из А4 и производится поиск в столбце G, если совпадение наедено то значения B4, C4, D4, E4 копируются в соседние строки найденного значений в столбце G.
Например А4 = Ирина, В4 = 1, C4 = 2, D4 = 3, E4 = 4. В столбце G найдено совпадение, G10 = Ирина. Тогда H10 = 1. I10 = 2, J10 = 3, K10 = 4
Пример в файле
К сообщению приложен файл: 123.xlsx(6.3 Kb)


Сообщение отредактировал soly - Пятница, 27.07.2018, 19:40
 
Ответить
СообщениеБерется значение из А4 и производится поиск в столбце G, если совпадение наедено то значения B4, C4, D4, E4 копируются в соседние строки найденного значений в столбце G.
Например А4 = Ирина, В4 = 1, C4 = 2, D4 = 3, E4 = 4. В столбце G найдено совпадение, G10 = Ирина. Тогда H10 = 1. I10 = 2, J10 = 3, K10 = 4
Пример в файле

Автор - soly
Дата добавления - 27.07.2018 в 19:32
Nic70y Дата: Пятница, 27.07.2018, 19:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4847
Репутация: 1050 ±
Замечаний: 0% ±

Excel 2013
Вы вообще уверенны, что правильно описали задачу? %)
Код
=ЕСЛИОШИБКА(ВПР($G4;$A:$E;СТОЛБЕЦ(B1););"")
файл оказался слегла поврежденным (ну у меня по крайней мере)
К сообщению приложен файл: 4427425.xlsx(11.0 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 27.07.2018, 19:39
 
Ответить
СообщениеВы вообще уверенны, что правильно описали задачу? %)
Код
=ЕСЛИОШИБКА(ВПР($G4;$A:$E;СТОЛБЕЦ(B1););"")
файл оказался слегла поврежденным (ну у меня по крайней мере)

Автор - Nic70y
Дата добавления - 27.07.2018 в 19:38
Pelena Дата: Пятница, 27.07.2018, 19:41 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13140
Репутация: 2895 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Код
=ЕСЛИОШИБКА(ВПР($G4;$A$4:$E$11;СТОЛБЕЦ(B1);0);"")
К сообщению приложен файл: 5298106.xlsx(11.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Код
=ЕСЛИОШИБКА(ВПР($G4;$A$4:$E$11;СТОЛБЕЦ(B1);0);"")

Автор - Pelena
Дата добавления - 27.07.2018 в 19:41
soly Дата: Пятница, 27.07.2018, 19:43 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо друзья
 
Ответить
СообщениеСпасибо друзья

Автор - soly
Дата добавления - 27.07.2018 в 19:43
_Boroda_ Дата: Пятница, 27.07.2018, 19:53 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13245
Репутация: 5454 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот не люблю я ВПР
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$11;ПОИСКПОЗ($G4;$A$4:$A$11;));"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($G4=$A$4:$A$11);B$4:B$11);"")
К сообщению приложен файл: 123_1.xlsx(11.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот не люблю я ВПР
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$11;ПОИСКПОЗ($G4;$A$4:$A$11;));"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($G4=$A$4:$A$11);B$4:B$11);"")

Автор - _Boroda_
Дата добавления - 27.07.2018 в 19:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка и поиск заданных значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!