Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет средневзвешенного значения в дубликатах столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет средневзвешенного значения в дубликатах столбца (Формулы/Formulas)
Подсчет средневзвешенного значения в дубликатах столбца
Tallen Дата: Понедельник, 30.07.2018, 19:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер, уважаемые специалисты Excel!
Помогите посчитать средневзвешенное значение цены (столбец G), при условии, что значение ячейки в столбце А не уникально.
т.е. на моем примере.. если значение ячейки (А3) встречается более 1 раза, считаем сумму произведений количества и цены, поделенную на общее количество единиц с одинаковым номенклатурным номером
К сообщению приложен файл: 4775040.xlsx(14.3 Kb)
 
Ответить
СообщениеДобрый вечер, уважаемые специалисты Excel!
Помогите посчитать средневзвешенное значение цены (столбец G), при условии, что значение ячейки в столбце А не уникально.
т.е. на моем примере.. если значение ячейки (А3) встречается более 1 раза, считаем сумму произведений количества и цены, поделенную на общее количество единиц с одинаковым номенклатурным номером

Автор - Tallen
Дата добавления - 30.07.2018 в 19:22
Pelena Дата: Понедельник, 30.07.2018, 20:19 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13143
Репутация: 2897 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(($A$3:$A$46=A3)*$E$3:$E$46*$C$3:$C$46)/СУММЕСЛИ($A$3:$A$46;A3;$C$3:$C$46)
К сообщению приложен файл: 8623214.xlsx(15.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(($A$3:$A$46=A3)*$E$3:$E$46*$C$3:$C$46)/СУММЕСЛИ($A$3:$A$46;A3;$C$3:$C$46)

Автор - Pelena
Дата добавления - 30.07.2018 в 20:19
Tallen Дата: Понедельник, 30.07.2018, 20:49 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, спасибо большое!!! :flower:
 
Ответить
СообщениеPelena, спасибо большое!!! :flower:

Автор - Tallen
Дата добавления - 30.07.2018 в 20:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет средневзвешенного значения в дубликатах столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!