Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределение суммы по ячейкам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение суммы по ячейкам (Формулы/Formulas)
Распределение суммы по ячейкам
aidenok Дата: Среда, 01.08.2018, 16:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Просьба помочь в решении вопроса:
Есть сумма (ячейка А1), которую необходимо распределить по 10 ячейкам, причем 5 ячеек (с Е2 по Е6) должны быть со знаком "+", а 5 ячеек (с Е7 по Е11) должны быть со знаком "-".
Распределить нудно так, чтобы цифры получились более-менее целыми, можно округлить до двух (максимум) трех цифр после запятой.
После распределения сумма ячеек с Е по Е должна быть равна цифре, указанной в ячейке А.

Спасибо
К сообщению приложен файл: 5098435.xlsx(10.0 Kb)
 
Ответить
СообщениеДобрый день.
Просьба помочь в решении вопроса:
Есть сумма (ячейка А1), которую необходимо распределить по 10 ячейкам, причем 5 ячеек (с Е2 по Е6) должны быть со знаком "+", а 5 ячеек (с Е7 по Е11) должны быть со знаком "-".
Распределить нудно так, чтобы цифры получились более-менее целыми, можно округлить до двух (максимум) трех цифр после запятой.
После распределения сумма ячеек с Е по Е должна быть равна цифре, указанной в ячейке А.

Спасибо

Автор - aidenok
Дата добавления - 01.08.2018 в 16:27
sboy Дата: Среда, 01.08.2018, 17:04 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
1. Вопрос: Как Вы хотите получить сумму с 6 знаками после запятой, если у слагаемых максимум 3 знака?
2. Вопрос: В чем заключается задача? Есть ли у нее прикладное/практическое применение? Ведь решений для поставленной задачи = математическая бесконечность
для примера так
Код
=$A$1/ВЫБОР((СТРОКА()>6)+1;4;-20)
К сообщению приложен файл: 5981407.xlsx(10.8 Kb)
 
Ответить
СообщениеДобрый день.
1. Вопрос: Как Вы хотите получить сумму с 6 знаками после запятой, если у слагаемых максимум 3 знака?
2. Вопрос: В чем заключается задача? Есть ли у нее прикладное/практическое применение? Ведь решений для поставленной задачи = математическая бесконечность
для примера так
Код
=$A$1/ВЫБОР((СТРОКА()>6)+1;4;-20)

Автор - sboy
Дата добавления - 01.08.2018 в 17:04
aidenok Дата: Среда, 01.08.2018, 17:48 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
1.) я об этом не подумала. извините.
2. Практическое значение есть, необходимо посчитать цифру от обратного.

То, что Вы сделали мне подходит, только подскажите, пожалуйста, как сделать так, чтобы при распределении не одинаковые числа получались в ячейках, а каждой ячейке получались разные числа?
 
Ответить
Сообщение1.) я об этом не подумала. извините.
2. Практическое значение есть, необходимо посчитать цифру от обратного.

То, что Вы сделали мне подходит, только подскажите, пожалуйста, как сделать так, чтобы при распределении не одинаковые числа получались в ячейках, а каждой ячейке получались разные числа?

Автор - aidenok
Дата добавления - 01.08.2018 в 17:48
Светлый Дата: Среда, 01.08.2018, 22:05 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 132 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
С дополнительными ячейками можно так:
Код
=ЕСЛИ(СТРОКА()<СТРОКА(E$7);(A$2+A$1)/СУММ(C$2:C$6);-A$2/СУММ(C$7:C$11))*C2
К сообщению приложен файл: 5098435-2.xlsx(11.0 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗдравствуйте!
С дополнительными ячейками можно так:
Код
=ЕСЛИ(СТРОКА()<СТРОКА(E$7);(A$2+A$1)/СУММ(C$2:C$6);-A$2/СУММ(C$7:C$11))*C2

Автор - Светлый
Дата добавления - 01.08.2018 в 22:05
aidenok Дата: Среда, 01.08.2018, 23:36 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное!
Можно также попросить, как сделать так, чтобы распределяемые числа были не больше 10 и -10?
 
Ответить
СообщениеСпасибо огромное!
Можно также попросить, как сделать так, чтобы распределяемые числа были не больше 10 и -10?

Автор - aidenok
Дата добавления - 01.08.2018 в 23:36
Светлый Дата: Четверг, 02.08.2018, 00:06 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 132 ±
Замечаний: 0% ±

Excel 2007
Изменить число в ячейке A2.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИзменить число в ячейке A2.

Автор - Светлый
Дата добавления - 02.08.2018 в 00:06
aidenok Дата: Четверг, 02.08.2018, 00:18 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. все получилось
 
Ответить
СообщениеСпасибо. все получилось

Автор - aidenok
Дата добавления - 02.08.2018 в 00:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение суммы по ячейкам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!