Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создать из таблицы другую таблицу по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать из таблицы другую таблицу по условию (Формулы/Formulas)
Создать из таблицы другую таблицу по условию
Legolas Дата: Понедельник, 06.08.2018, 22:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Зравствуйте. Есть таблица двумя столбцами: "время" и "остаток". Ячейки в столбце "время" в формате "чч:мм:сс". А в столбце "остаток" либо числовое, либо "ЛОЖЬ".
Как создать новую таблицу состоящую из последовательных (без пробелов) строк старой таблицы в которых ячейки в столбце "остаток" только числовые, исключая "ложь"?

К сообщению приложен файл: 8674366.xlsx(47.7 Kb)


Сообщение отредактировал Legolas - Понедельник, 06.08.2018, 22:26
 
Ответить
СообщениеЗравствуйте. Есть таблица двумя столбцами: "время" и "остаток". Ячейки в столбце "время" в формате "чч:мм:сс". А в столбце "остаток" либо числовое, либо "ЛОЖЬ".
Как создать новую таблицу состоящую из последовательных (без пробелов) строк старой таблицы в которых ячейки в столбце "остаток" только числовые, исключая "ложь"?


Автор - Legolas
Дата добавления - 06.08.2018 в 22:08
gling Дата: Понедельник, 06.08.2018, 23:47 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1816
Репутация: 440 ±
Замечаний: 0% ±

2010
Здравствуйте. Автофильтр по столбцу J-- снять галку с ЛОЖЬ--Выделяем что видим, диапазон A1:J....--ПКМ--Копировать--активируем ячейку где хотим создать таблицу--ПКМ--вставить.


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Автофильтр по столбцу J-- снять галку с ЛОЖЬ--Выделяем что видим, диапазон A1:J....--ПКМ--Копировать--активируем ячейку где хотим создать таблицу--ПКМ--вставить.

Автор - gling
Дата добавления - 06.08.2018 в 23:47
Che79 Дата: Вторник, 07.08.2018, 00:07 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Legolas, здравствуйте. Вариант формулами, чтобы получить
Цитата
что-то на подобии этого
как на картинке
Остаток (L): формула массива (ввод одновременным нажатием Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$2:$J$42;НАИМЕНЬШИЙ(ЕСЛИ($J$2:$J$42<>ЛОЖЬ;СТРОКА($A$1:$A$41));СТРОКА(A1)));"")
Время (K): обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$C$42;ПОИСКПОЗ(L2;$J$2:$J$42;));"")
К сообщению приложен файл: 8674366_1.xlsx(49.3 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеLegolas, здравствуйте. Вариант формулами, чтобы получить
Цитата
что-то на подобии этого
как на картинке
Остаток (L): формула массива (ввод одновременным нажатием Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$2:$J$42;НАИМЕНЬШИЙ(ЕСЛИ($J$2:$J$42<>ЛОЖЬ;СТРОКА($A$1:$A$41));СТРОКА(A1)));"")
Время (K): обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$C$42;ПОИСКПОЗ(L2;$J$2:$J$42;));"")

Автор - Che79
Дата добавления - 07.08.2018 в 00:07
Legolas Дата: Среда, 08.08.2018, 01:46 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное спасибо! Оба способа записал в тетрадь hands


Сообщение отредактировал Legolas - Среда, 08.08.2018, 01:47
 
Ответить
СообщениеОгромное спасибо! Оба способа записал в тетрадь hands

Автор - Legolas
Дата добавления - 08.08.2018 в 01:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать из таблицы другую таблицу по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!