Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Произведение в зависимости от условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Произведение в зависимости от условий (Формулы/Formulas)
Произведение в зависимости от условий
nexus7 Дата: Вторник, 21.08.2018, 07:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день уважаемые знатоки, прошу вашей помощи. Суть такова, нужно чтобы в столбце P (рулонки), значения из столбца G умножались на 100, но только при следующих значениях в столбце C - рул, мк, рим, зебра.
И еще вопрос, как сделать чтобы в столбце Q (комиссия и налог), значения из столбца L (оплата) умножались на 1%, когда в столбце M оплата или предоплата наличными или по счету, и на 2,5% когда оплата или предоплата по терминалу. Желательно чтобы формула считала только при тех же значениях из столбца C - рул, мк, рим, зебра.
К сообщению приложен файл: 3339289.xlsx(12.2 Kb)


Сообщение отредактировал nexus7 - Вторник, 21.08.2018, 07:01
 
Ответить
СообщениеДобрый день уважаемые знатоки, прошу вашей помощи. Суть такова, нужно чтобы в столбце P (рулонки), значения из столбца G умножались на 100, но только при следующих значениях в столбце C - рул, мк, рим, зебра.
И еще вопрос, как сделать чтобы в столбце Q (комиссия и налог), значения из столбца L (оплата) умножались на 1%, когда в столбце M оплата или предоплата наличными или по счету, и на 2,5% когда оплата или предоплата по терминалу. Желательно чтобы формула считала только при тех же значениях из столбца C - рул, мк, рим, зебра.

Автор - nexus7
Дата добавления - 21.08.2018 в 07:00
китин Дата: Вторник, 21.08.2018, 08:35 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго и вам
ну как то так
для столбца L
Код
=ЕСЛИ(И(ЕЧИСЛО(ПОИСК("терминал";M3));P3<>0);L3*0,25;ЕСЛИ(И(ИЛИ(ЕЧИСЛО(ПОИСК("нал";M3));ЕЧИСЛО(ПОИСК("счет";M3)));P3<>0);L3*0,1;0))

для столбца Р
Код
=ЕСЛИ(ИЛИ(C3="рул";C3="мк";C3="рим";C3="зебра");G3*100;0)
К сообщению приложен файл: nexus7.xlsx(12.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброго и вам
ну как то так
для столбца L
Код
=ЕСЛИ(И(ЕЧИСЛО(ПОИСК("терминал";M3));P3<>0);L3*0,25;ЕСЛИ(И(ИЛИ(ЕЧИСЛО(ПОИСК("нал";M3));ЕЧИСЛО(ПОИСК("счет";M3)));P3<>0);L3*0,1;0))

для столбца Р
Код
=ЕСЛИ(ИЛИ(C3="рул";C3="мк";C3="рим";C3="зебра");G3*100;0)

Автор - китин
Дата добавления - 21.08.2018 в 08:35
sboy Дата: Вторник, 21.08.2018, 09:20 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2105
Репутация: 604 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Еще вариант
Код
=ЕЧИСЛО(ПОИСК(C3;"рулмкримзебра"))*G3*100

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/ПОИСК({"нал";"терминал";"счет"};M3);{1;2,5;1});)%*L3*(P3>0)
К сообщению приложен файл: 3311587.xlsx(12.3 Kb)


Сообщение отредактировал sboy - Вторник, 21.08.2018, 09:51
 
Ответить
СообщениеДобрый день.
Еще вариант
Код
=ЕЧИСЛО(ПОИСК(C3;"рулмкримзебра"))*G3*100

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/ПОИСК({"нал";"терминал";"счет"};M3);{1;2,5;1});)%*L3*(P3>0)

Автор - sboy
Дата добавления - 21.08.2018 в 09:20
nexus7 Дата: Вторник, 21.08.2018, 09:49 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, работает, только у меня почему-то ноль лишний добавляет.

Интересно, а как функция ключевое слово определяет, выходит если полностью написано "наличные" или "терминал" и тд, она все равно понимает что искать?
 
Ответить
Сообщениеsboy, работает, только у меня почему-то ноль лишний добавляет.

Интересно, а как функция ключевое слово определяет, выходит если полностью написано "наличные" или "терминал" и тд, она все равно понимает что искать?

Автор - nexus7
Дата добавления - 21.08.2018 в 09:49
sboy Дата: Вторник, 21.08.2018, 09:52 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2105
Репутация: 604 ±
Замечаний: 0% ±

Excel 2010
почему-то ноль лишний добавляет

потому что я брал не 1%, а 10%. Исправил, файл перевложил
 
Ответить
Сообщение
почему-то ноль лишний добавляет

потому что я брал не 1%, а 10%. Исправил, файл перевложил

Автор - sboy
Дата добавления - 21.08.2018 в 09:52
Светлый Дата: Вторник, 21.08.2018, 11:33 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Еще вариант

А если не число, будет 0. Или я условия неправильно понял...
Лучше так:
Код
=ЕСЛИ(ЕОШ(ПОИСК(C3;"рул,мк,рим,зебра"));1;100)*G3


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 21.08.2018, 11:39
 
Ответить
Сообщение
Еще вариант

А если не число, будет 0. Или я условия неправильно понял...
Лучше так:
Код
=ЕСЛИ(ЕОШ(ПОИСК(C3;"рул,мк,рим,зебра"));1;100)*G3

Автор - Светлый
Дата добавления - 21.08.2018 в 11:33
sboy Дата: Вторник, 21.08.2018, 14:26 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2105
Репутация: 604 ±
Замечаний: 0% ±

Excel 2010
Цитата Светлый, 21.08.2018 в 11:33, в сообщении № 6 ()
Или я условия неправильно понял...

Не знаю, может и я :)
Ориентировался на результат в примере
 
Ответить
Сообщение
Цитата Светлый, 21.08.2018 в 11:33, в сообщении № 6 ()
Или я условия неправильно понял...

Не знаю, может и я :)
Ориентировался на результат в примере

Автор - sboy
Дата добавления - 21.08.2018 в 14:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Произведение в зависимости от условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!