Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическая протяжка формула при наличии разрыва ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая протяжка формула при наличии разрыва ячеек (Формулы/Formulas)
Автоматическая протяжка формула при наличии разрыва ячеек
cants Дата: Вторник, 28.08.2018, 21:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые участники форума, добрый вечер!

Возник следующий вопрос:

В ячейке О10 выводится средневзвешанный процентный показатель выручки и дохода компании Альфа, который аккумулирует данные за 7 месяцев
В ячейке О11 выводится аналогичное значение по компании Бета за 6 месяцев.

При добавлении нового временного периода (август) и попытке скопировать формулу в ячейку q10/q11 она перестает учитывать 1-ый месяц, где содержаться данные (для Альфы - это январь, для Беты - февраль). Приходится в формулу добавлять эти значения вручную. Как сделать так, чтобы при добавлении нового месяца формула автоматически подтягивала данные, начиная с 1-го месяца по последний включительно
К сообщению приложен файл: _28.08.18.xlsx(15.0 Kb)
 
Ответить
СообщениеУважаемые участники форума, добрый вечер!

Возник следующий вопрос:

В ячейке О10 выводится средневзвешанный процентный показатель выручки и дохода компании Альфа, который аккумулирует данные за 7 месяцев
В ячейке О11 выводится аналогичное значение по компании Бета за 6 месяцев.

При добавлении нового временного периода (август) и попытке скопировать формулу в ячейку q10/q11 она перестает учитывать 1-ый месяц, где содержаться данные (для Альфы - это январь, для Беты - февраль). Приходится в формулу добавлять эти значения вручную. Как сделать так, чтобы при добавлении нового месяца формула автоматически подтягивала данные, начиная с 1-го месяца по последний включительно

Автор - cants
Дата добавления - 28.08.2018 в 21:33
Pelena Дата: Вторник, 28.08.2018, 21:50 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13225
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как варинат
Код
=СУММПРОИЗВ(($B$2:O2="альфа")*$B$6:O6*$B$9:O9)/СУММПРОИЗВ(($B$2:O2="альфа")*$B$6:O6)
К сообщению приложен файл: 4303543.xlsx(15.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак варинат
Код
=СУММПРОИЗВ(($B$2:O2="альфа")*$B$6:O6*$B$9:O9)/СУММПРОИЗВ(($B$2:O2="альфа")*$B$6:O6)

Автор - Pelena
Дата добавления - 28.08.2018 в 21:50
_Boroda_ Дата: Вторник, 28.08.2018, 21:53 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5530 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Для О10
Код
=СУММЕСЛИ($B2:O2;N2;$B4:O4)/СУММЕСЛИ($B2:O2;N2;$B6:O6)*12

Дальше там сами, а то я запутался - где 7, где 6, почему, ...
К сообщению приложен файл: _28.08.18_1.xlsx(15.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Для О10
Код
=СУММЕСЛИ($B2:O2;N2;$B4:O4)/СУММЕСЛИ($B2:O2;N2;$B6:O6)*12

Дальше там сами, а то я запутался - где 7, где 6, почему, ...

Автор - _Boroda_
Дата добавления - 28.08.2018 в 21:53
cants Дата: Вторник, 28.08.2018, 22:08 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Господа, спасибо! То, что нужно!
 
Ответить
СообщениеГоспода, спасибо! То, что нужно!

Автор - cants
Дата добавления - 28.08.2018 в 22:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая протяжка формула при наличии разрыва ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!