Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как разделить ячейку с данными на две ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разделить ячейку с данными на две ячейки (Формулы/Formulas)
Как разделить ячейку с данными на две ячейки
Antonzx55 Дата: Среда, 29.08.2018, 23:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!
Есть интересная задача.
Есть столбик с данными, в каждой ячейке несколько ссылок с разделителем "|".
Так вот нужно первую ссылку в каждой ячейке выделить в отдельный столбик, а оставшиеся ссылки разделить знаком ","
Получается должно получиться два столбика: первый столбик с одной ссылкой, второй столбик с несколькими ссылками и разделителем "," между ними.

Кто что может посоветовать?

Прикрепил исходный файл.
А так же файл с примером того что должно в итоге получиться.
К сообщению приложен файл: 4769587.xlsx(13.9 Kb) · 9725517.xlsx(8.6 Kb)


Сообщение отредактировал Antonzx55 - Четверг, 30.08.2018, 10:39
 
Ответить
СообщениеДоброго времени суток!
Есть интересная задача.
Есть столбик с данными, в каждой ячейке несколько ссылок с разделителем "|".
Так вот нужно первую ссылку в каждой ячейке выделить в отдельный столбик, а оставшиеся ссылки разделить знаком ","
Получается должно получиться два столбика: первый столбик с одной ссылкой, второй столбик с несколькими ссылками и разделителем "," между ними.

Кто что может посоветовать?

Прикрепил исходный файл.
А так же файл с примером того что должно в итоге получиться.

Автор - Antonzx55
Дата добавления - 29.08.2018 в 23:11
krosav4ig Дата: Среда, 29.08.2018, 23:31 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 687 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здравствуйте, могу посоветовать прочитать вот это


(_)Õvõ(_)
 
Ответить
СообщениеЗдравствуйте, могу посоветовать прочитать вот это

Автор - krosav4ig
Дата добавления - 29.08.2018 в 23:31
китин Дата: Четверг, 30.08.2018, 07:25 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5024
Репутация: 798 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Antonzx55, при наличии отсутствия файла примера можно посоветовать текст по столбцам на вкладке Данные


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеAntonzx55, при наличии отсутствия файла примера можно посоветовать текст по столбцам на вкладке Данные

Автор - китин
Дата добавления - 30.08.2018 в 07:25
Antonzx55 Дата: Четверг, 30.08.2018, 10:35 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, прикрепил файл
 
Ответить
СообщениеСпасибо, прикрепил файл

Автор - Antonzx55
Дата добавления - 30.08.2018 в 10:35
китин Дата: Четверг, 30.08.2018, 10:47 | Сообщение № 5
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5024
Репутация: 798 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Ну как я и писал:
посоветовать текст по столбцам на вкладке Данные


Выделяете столбец А-вкладка Данные-текст по столбцам-с разделителями-далее- в квадратике другой ставите знак | - Далее-готово. и вуаля`!!!
К сообщению приложен файл: Antonzx55.xlsx(15.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеНу как я и писал:
посоветовать текст по столбцам на вкладке Данные


Выделяете столбец А-вкладка Данные-текст по столбцам-с разделителями-далее- в квадратике другой ставите знак | - Далее-готово. и вуаля`!!!

Автор - китин
Дата добавления - 30.08.2018 в 10:47
Antonzx55 Дата: Четверг, 30.08.2018, 18:20 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Выделяете столбец А-вкладка Данные-текст по столбцам-с разделителями-далее- в квадратике другой ставите знак | - Далее-готово. и вуаля`!!!


Этот способ разделяет все на множество столбиков, мне нужно что бы было 2 столбика, в одном первая ссылка а во втором все остальные ссылки через запятую.
 
Ответить
Сообщение
Выделяете столбец А-вкладка Данные-текст по столбцам-с разделителями-далее- в квадратике другой ставите знак | - Далее-готово. и вуаля`!!!


Этот способ разделяет все на множество столбиков, мне нужно что бы было 2 столбика, в одном первая ссылка а во втором все остальные ссылки через запятую.

Автор - Antonzx55
Дата добавления - 30.08.2018 в 18:20
_Boroda_ Дата: Четверг, 30.08.2018, 18:35 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12958
Репутация: 5330 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В ячейку В1
Код
=ЛЕВСИМВ(A1;ПОИСК("|";A1&"|")-1)

В ячейку С1
Код
=ЕСЛИ(B1=A1;"";ПОДСТАВИТЬ(A1;B1&"|";))

или
Код
=ПСТР(A1;ДЛСТР(B1)+2;999)

И тянете формулы вниз
К сообщению приложен файл: 4769587_1.xlsx(22.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ ячейку В1
Код
=ЛЕВСИМВ(A1;ПОИСК("|";A1&"|")-1)

В ячейку С1
Код
=ЕСЛИ(B1=A1;"";ПОДСТАВИТЬ(A1;B1&"|";))

или
Код
=ПСТР(A1;ДЛСТР(B1)+2;999)

И тянете формулы вниз

Автор - _Boroda_
Дата добавления - 30.08.2018 в 18:35
Antonzx55 Дата: Четверг, 30.08.2018, 22:46 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией

Вот так спасибо, все отлично помогло.
Вы сэкономили кучу моего времени, благодарю
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией

Вот так спасибо, все отлично помогло.
Вы сэкономили кучу моего времени, благодарю

Автор - Antonzx55
Дата добавления - 30.08.2018 в 22:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разделить ячейку с данными на две ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!