Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перенести в строку и вытащить дату. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенести в строку и вытащить дату. (Формулы/Formulas)
перенести в строку и вытащить дату.
bobrenja Дата: Четверг, 06.09.2018, 23:42 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Не знаю как пояснить )) В файле пример.

Пустых строк между накладными нет.
К сообщению приложен файл: 7331031.xlsx(10.0 Kb)
 
Ответить
СообщениеНе знаю как пояснить )) В файле пример.

Пустых строк между накладными нет.

Автор - bobrenja
Дата добавления - 06.09.2018 в 23:42
Светлый Дата: Пятница, 07.09.2018, 07:03 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 708
Репутация: 187 ±
Замечаний: 0% ±

Excel 2010
В столбце H делаем построчную нумерацию (можно скрыть или обесцветить):
Код
=ЕСЛИ(СЧЁТЗ(B:B)<=H1;"";H1+1+2*(СМЕЩ(C$2;H1;)=$C$2))

А в таблице формулы:
Код
=ЕСЛИ(H2="";"";ЕСЛИ(ЛЕВБ(ИНДЕКС(B:B;H2-2);4)="Накл";ПРАВБ(ИНДЕКС(B:B;H2-2);10);I1))

Код
=ЕСЛИ(H2="";"";ЕСЛИ(ЛЕВБ(ИНДЕКС(B:B;H2-2);4)="Накл";ЛЕВБ(ИНДЕКС(B:B;H2-2);13);J1))

Код
=ЕСЛИ($H2="";"";ИНДЕКС(C:C;$H2))
К сообщению приложен файл: 7331031-1.xlsx(10.4 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВ столбце H делаем построчную нумерацию (можно скрыть или обесцветить):
Код
=ЕСЛИ(СЧЁТЗ(B:B)<=H1;"";H1+1+2*(СМЕЩ(C$2;H1;)=$C$2))

А в таблице формулы:
Код
=ЕСЛИ(H2="";"";ЕСЛИ(ЛЕВБ(ИНДЕКС(B:B;H2-2);4)="Накл";ПРАВБ(ИНДЕКС(B:B;H2-2);10);I1))

Код
=ЕСЛИ(H2="";"";ЕСЛИ(ЛЕВБ(ИНДЕКС(B:B;H2-2);4)="Накл";ЛЕВБ(ИНДЕКС(B:B;H2-2);13);J1))

Код
=ЕСЛИ($H2="";"";ИНДЕКС(C:C;$H2))

Автор - Светлый
Дата добавления - 07.09.2018 в 07:03
_Boroda_ Дата: Пятница, 07.09.2018, 09:47 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13515
Репутация: 5530 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Без допстолбцов
Для дат
Код
=ЕСЛИ(K2="";"";--ПРАВБ(ПРОСМОТР(НАИМЕНЬШИЙ(ЕСЛИ(Ч(+B$3:B$21);СТРОКА($1:$19));СТРОКА(J1));СТРОКА($1:$19)/(B$2:B$20="№");B$1:B$19);10))

Для накладных
Код
=ЕСЛИ(K2="";"";СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПРОСМОТР(НАИМЕНЬШИЙ(ЕСЛИ(Ч(+B$3:B$21);СТРОКА($1:$19));СТРОКА(J1));СТРОКА($1:$19)/(B$2:B$20="№");B$1:B$19);"от";ПОВТОР(" ";99));99)))

Для остального
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(Ч(+$B$3:$B$21);СТРОКА($3:$21));СТРОКА(K1)));"")
К сообщению приложен файл: 7331031_1.xlsx(11.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеБез допстолбцов
Для дат
Код
=ЕСЛИ(K2="";"";--ПРАВБ(ПРОСМОТР(НАИМЕНЬШИЙ(ЕСЛИ(Ч(+B$3:B$21);СТРОКА($1:$19));СТРОКА(J1));СТРОКА($1:$19)/(B$2:B$20="№");B$1:B$19);10))

Для накладных
Код
=ЕСЛИ(K2="";"";СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПРОСМОТР(НАИМЕНЬШИЙ(ЕСЛИ(Ч(+B$3:B$21);СТРОКА($1:$19));СТРОКА(J1));СТРОКА($1:$19)/(B$2:B$20="№");B$1:B$19);"от";ПОВТОР(" ";99));99)))

Для остального
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(Ч(+$B$3:$B$21);СТРОКА($3:$21));СТРОКА(K1)));"")

Автор - _Boroda_
Дата добавления - 07.09.2018 в 09:47
bobrenja Дата: Пятница, 07.09.2018, 10:27 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
За решение спасибо. Выручили. Сейчас мучаюсь, как дату преобразовать в разный формат вывода.
К примеру 01 сентября 2018.
Через формат ячейки ничего не происходит. Куда посмотреть?

_Boroda_, в вашем варианте дат можно привести к разным форматам вывода.
В варианте выше вроде применял СЖПРОБЕЛЫ


Сообщение отредактировал bobrenja - Пятница, 07.09.2018, 10:28
 
Ответить
СообщениеЗа решение спасибо. Выручили. Сейчас мучаюсь, как дату преобразовать в разный формат вывода.
К примеру 01 сентября 2018.
Через формат ячейки ничего не происходит. Куда посмотреть?

_Boroda_, в вашем варианте дат можно привести к разным форматам вывода.
В варианте выше вроде применял СЖПРОБЕЛЫ

Автор - bobrenja
Дата добавления - 07.09.2018 в 10:27
bobrenja Дата: Пятница, 07.09.2018, 10:57 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Вроде через ТЕКСТ получилось.
 
Ответить
СообщениеВроде через ТЕКСТ получилось.

Автор - bobrenja
Дата добавления - 07.09.2018 в 10:57
_Boroda_ Дата: Пятница, 07.09.2018, 11:00 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13515
Репутация: 5530 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В формуле для дат у Светлого поставьте перед ЕСЛИ два минуса и не нужен никакой ТЕКСТ, там тогда даты будут и их можно будет как обычно форматировать

Что такое два минуса "--" http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ формуле для дат у Светлого поставьте перед ЕСЛИ два минуса и не нужен никакой ТЕКСТ, там тогда даты будут и их можно будет как обычно форматировать

Что такое два минуса "--" http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9

Автор - _Boroda_
Дата добавления - 07.09.2018 в 11:00
buka77 Дата: Пятница, 07.09.2018, 11:02 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 6 ±
Замечаний: 0% ±

Excel 2010
Сейчас мучаюсь, как дату преобразовать в разный формат вывода.
К примеру 01 сентября 2018.

Столбец I через Формат ячеек...
К сообщению приложен файл: 5647335.xlsx(12.8 Kb)
 
Ответить
Сообщение
Сейчас мучаюсь, как дату преобразовать в разный формат вывода.
К примеру 01 сентября 2018.

Столбец I через Формат ячеек...

Автор - buka77
Дата добавления - 07.09.2018 в 11:02
_Boroda_ Дата: Пятница, 07.09.2018, 11:10 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13515
Репутация: 5530 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
buka77, в моем файле и так все работало.
_Boroda_, в вашем варианте дат можно привести к разным форматам вывода.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеbuka77, в моем файле и так все работало.
_Boroda_, в вашем варианте дат можно привести к разным форматам вывода.

Автор - _Boroda_
Дата добавления - 07.09.2018 в 11:10
bobrenja Дата: Пятница, 07.09.2018, 13:53 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Столбец I через Формат ячеек...


Через формат ячейки ничего не происходит. Куда посмотреть?
 
Ответить
Сообщение
Столбец I через Формат ячеек...


Через формат ячейки ничего не происходит. Куда посмотреть?

Автор - bobrenja
Дата добавления - 07.09.2018 в 13:53
bobrenja Дата: Пятница, 07.09.2018, 13:56 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
В формуле для дат у Светлого поставьте перед ЕСЛИ два минуса и не нужен никакой ТЕКСТ

Супер. Все работает. )))
 
Ответить
Сообщение
В формуле для дат у Светлого поставьте перед ЕСЛИ два минуса и не нужен никакой ТЕКСТ

Супер. Все работает. )))

Автор - bobrenja
Дата добавления - 07.09.2018 в 13:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенести в строку и вытащить дату. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!